[touch] NetworkManager needs to inhibit sleep if hotspot is active

Bug #1458046 reported by Tony Espy on 2015-05-22
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Canonical System Image
High
Pat McGowan
indicator-network (Ubuntu)
High
Pete Woods
network-manager (Ubuntu)
Undecided
Unassigned
network-manager (Ubuntu RTM)
Undecided
Unassigned

Bug Description

As Ubuntu touch uses an auto-suspend model, it's possible for the system to be suspended while a user has a hotspot active and in use.

In order to prevent such behavior, we should modify NetworkManager to inhibit suspend via powerd's DBus interface when hotspot is active and one or more clients are connected to the hotspot. As a first pass, inhibiting suspend when hotspot is active would probably be sufficient. This could probably be implemented via a NM dispatcher script, which would run when the hotspot is activated.

<https://wiki.ubuntu.com/Networking#hotspot-power>:
"* Whenever at least one person is using your hotspot, the device should not sleep automatically.
* The indicator icon should be different when anyone is connected than when no-one is.
* If a hotspot is set up, there should be a “Hotspot” item in the “Ways to reduce battery use” list in “Power” settings."

Related branches

Tony Espy (awe) on 2015-05-22
Changed in network-manager (Ubuntu):
assignee: nobody → Tony Espy (awe)
status: New → Confirmed
Tony Espy (awe) on 2015-06-12
Changed in network-manager (Ubuntu RTM):
status: New → Confirmed
Changed in network-manager (Ubuntu):
assignee: Tony Espy (awe) → nobody
Matthew Paul Thomas (mpt) wrote :

Ubuntu for PC has an auto-suspend option too, so exactly the same inhibiting behavior should apply there, right? No need for this to be form-factor-specific.

Anyway, specifications updated.
<https://wiki.ubuntu.com/Networking?action=diff&rev2=281&rev1=280>
<https://wiki.ubuntu.com/Power?action=diff&rev2=75&rev1=74>

description: updated
Changed in canonical-devices-system-image:
assignee: nobody → Pat McGowan (pat-mcgowan)
importance: Undecided → High
milestone: none → ww28-2015
status: New → Confirmed
Pat McGowan (pat-mcgowan) wrote :

needs assigning, I think pete was going to handle it

Changed in canonical-devices-system-image:
milestone: ww28-2015 → ww34-2015
Changed in indicator-network (Ubuntu):
assignee: nobody → Alejandro J. Cura (alecu)
Alejandro J. Cura (alecu) wrote :

Reassigning since Pete is working on this

Changed in indicator-network (Ubuntu):
assignee: Alejandro J. Cura (alecu) → Pete Woods (pete-woods)
Pete Woods (pete-woods) on 2015-07-23
Changed in indicator-network (Ubuntu):
importance: Undecided → High
status: New → In Progress
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-system-settings (Ubuntu):
status: New → Confirmed
Changed in canonical-devices-system-image:
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-network - 0.5.2+15.10.20150810.1-0ubuntu1

---------------
indicator-network (0.5.2+15.10.20150810.1-0ubuntu1) wily; urgency=medium

  [ Pete Woods ]
  * Add hotspot management.
  * Don't show access points when hotspot is enabled (LP: #1478160)
  * Hold a wakelock when the hotspot is active. (LP: #1458046)
  * Seed the random number generator (LP: #1478157)
  * Simplify wifi/flight toggles

 -- CI Train Bot <email address hidden> Mon, 10 Aug 2015 16:51:11 +0000

Changed in indicator-network (Ubuntu):
status: In Progress → Fix Released
Bill Filler (bfiller) on 2015-08-19
Changed in canonical-devices-system-image:
status: In Progress → Fix Committed
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
no longer affects: ubuntu-system-settings (Ubuntu)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers