NetworkManager unresponsive

Bug #145723 reported by JohnBender on 2007-09-27
6
Affects Status Importance Assigned to Milestone
network-manager (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: NetworkManager

I have a new Lenovo ThinkPad X61 with the Intel 4965 wireless chipset. The network manager applet in Gutsy recognizes the wireless device and configures it properly, which is the main reason I installed Gutsy Beta rather than waiting for release. However, once it connects to the wireless network, it refuses to switch back to the wired network, and when I choose the "manual configuration" option, the app hangs. It opens a new window which is supposed to show my network devices and allow me to configure them, but the window contains no text or options, and I have to "force-quit" it. I can still manage the network devices from the command line, but the panel applet does not update after I do so and is now out of sync with the real configuration.

Sometime I have the same problem.

JohnBender (johnnyb01) wrote :

Seems to be fixed today (or in any case, is working correctly today).

Kow (kow) wrote :

This seems to be the result of poor application (network-manager) design as there are not any kernel level errors being output in dmesg. Sometimes when I plug in wired network-manager has no issues switching interfaces. Other times I lose internet connectivity altogether and network-manager is very, very slow (about 1 minute response times to user input). This appears to be related to the intel wireless drivers however I dont see why switching over to wired would be influenced by the stability of the wireless driver. Even worse is that network-manager basically takes over and doesnt allow me to forcefully remove the ipw3945 module when things get flakey. The end result is usually having to reboot and the NetworkManager process using 125mb of memory!!!! (this is about the same amount as the gtk window decorator which to me should be using a lot).

JohnBender (johnnyb01) wrote :

I take back my comment about it being fixed... I'm having the same problem today. It does seem to be intermittent, though (i.e., "fun" to debug).

description: updated
Daniel T Chen (crimsun) wrote :

Is this symptom still reproducible in 8.10?

Changed in network-config:
status: New → Incomplete
JohnBender (johnnyb01) wrote :

Nope, it seems to be OK now. At least nothing is obviously wrong, and it is definitely more hot-pluggable than it was.

JohnBender wrote:
> Nope, it seems to be OK now. At least nothing is obviously wrong, and it
> is definitely more hot-pluggable than it was.
>
>
thanks. fixed in intrepid and beyond ...

 status fixreleased

Changed in network-manager:
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers