Network manager crash with WPA

Bug #145683 reported by Alex Mauer on 2007-09-27
122
Affects Status Importance Assigned to Milestone
network-manager (Ubuntu)
High
Alexander Sack
Gutsy
Undecided
Unassigned
Hardy
High
Alexander Sack

Bug Description

NetworkManager crashes on my system when I roam from an open network to a WPA-protected one.

To reproduce:
 + suspend/resume often triggers this crash
 + switching AP can trigger this crash as well

please test proposed fix: https://bugs.edge.launchpad.net/ubuntu/+source/network-manager/+bug/145683/comments/15

Backtrace from NM:

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread -1221174384 (LWP 4691)]
0x08074acf in wpa_ctrl_request (ctrl=0x80a1ef8, cmd=0x80b2b50 "SCAN",
    cmd_len=4, reply=0x80ccc38 "$", reply_len=0xb73651e4, msg_cb=0)
    at wpa_ctrl.c:179
179 wpa_ctrl.c: No such file or directory.
        in wpa_ctrl.c
(gdb) bt
#0 0x08074acf in wpa_ctrl_request (ctrl=0x80a1ef8, cmd=0x80b2b50 "SCAN",
    cmd_len=4, reply=0x80ccc38 "$", reply_len=0xb73651e4, msg_cb=0)
    at wpa_ctrl.c:179
#1 0x0806c47a in nm_utils_supplicant_request_with_check (ctrl=0x80a1ef8,
    expected=0x8082502 "OK", func=0x8083968 "nm_device_802_11_wireless_scan",
    err_msg_cmd=<value optimized out>, format=0x808272a "SCAN")
    at NetworkManagerUtils.c:803
#2 0x0805d779 in nm_device_802_11_wireless_scan (user_data=0x80a0028)
    at nm-device-802-11-wireless.c:2120
#3 0xb7d8d8d6 in ?? () from /usr/lib/libglib-2.0.so.0
#4 0x080a0028 in ?? ()
#5 0xb7cf88ac in __pthread_mutex_unlock_usercnt ()
   from /lib/tls/i686/cmov/libpthread.so.0
#6 0xb7d8d11c in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#7 0xb7d9055f in ?? () from /usr/lib/libglib-2.0.so.0
#8 0x0809fdb8 in ?? ()
#9 0x00000000 in ?? ()

Alexander Sack (asac) on 2007-09-27
Changed in network-manager:
assignee: nobody → asac
importance: Undecided → High
status: New → Confirmed
status: Confirmed → Incomplete
Alexander Sack (asac) wrote :

any findings?

Alexander Sack (asac) on 2007-10-02
Changed in network-manager:
status: Incomplete → Fix Committed
Alex Mauer (hawke) wrote :
Tim Hull (thully) wrote :

It seems like my issue intermittently occurs - and occurs most when I'm resuming from suspend. I'm not connecting to any wireless networks when it happens, though there are many in range.

Could we possibly restart NetworkManager on resume from suspend? It seems that this would help somewhat in general.

Alexander Sack (asac) wrote :

network-manager (0.6.5-0ubuntu15) gutsy; urgency=low

  * debian/patches/41z_lp138217_use_timeout_to_schedule_activation.patch,series:
    don't use idle_source to schedule activation, but rest a bit by using a
    timeout_source with 250ms delay (LP: #138217).
  * debian/network-manager.postinst: sleep 2 seconds after ifblacklist_migrate.sh
    (LP: #146757).
  * debian/patches/41w_lp145683_cancel_scan_in_supplicant_cleanup.patch,series: first part
    for lp145683 - cancel pending scans on terminate (LP: #145683).
  * debian/patches/41wa_lp145683_wpa_ctrl_check_select_result_for_error.patch,series:
    second part to fix lp145683; test select result for errors (in case of
    TERMINATE) (LP: #145683).
  * debian/patches/41y_queue_if_dbus_name_is_taken_on_startup.patch,series: make
    restart of network manager more failsafe and even allow to take over name
    ownership. When ownership is taken over (dbus signal |NameLost| received), we
    shutdown cleanly by sending |X| through |nm_shutdown_pipe| (LP: #85113).
  * debian/patches/41x_lp145653_reraise_fatal_signals.patch: re-raise fatal
    signals (LP: #145653).

 -- Alexander Sack <email address hidden> Tue, 02 Oct 2007 13:32:50 +0200

Changed in network-manager:
status: Fix Committed → Fix Released
Tim Hull (thully) wrote :

Since the patch, I am noticing that while NetworkManager doesn't seem to disappear from the system tray spontaneously as before, it does become non-operational (i.e. the nm-applet says "No network Devices have been found"). Thus, if the problem I'm experiencing is indeed a duplicate of this bug (which it was marked as), the bug is not in fact fixed.

Output from daemon.log when NetworkManager "dies":

Oct 5 14:30:01 thully-laptop NetworkManager: <WARN> nm_hal_deinit(): libhal shutdown failed - Connection is closed
Oct 5 14:30:01 thully-laptop NetworkManager: <WARN> nm_signal_handler(): Caught signal 11. Generating backtrace...
Oct 5 14:30:01 thully-laptop NetworkManager: <info> Successfully reconnected to the system bus.
Oct 5 14:30:02 thully-laptop NetworkManager: ******************* START **********************************
Oct 5 14:30:02 thully-laptop NetworkManager: (no debugging symbols found)
Oct 5 14:30:02 thully-laptop NetworkManager: Using host libthread_db library "/lib/tls/i686/cmov/libthread_db.so.1".
Oct 5 14:30:02 thully-laptop NetworkManager: (no debugging symbols found)
Oct 5 14:30:02 thully-laptop last message repeated 12 times
Oct 5 14:30:02 thully-laptop NetworkManager: [Thread debugging using libthread_db enabled]
Oct 5 14:30:02 thully-laptop NetworkManager: [New Thread -1211914576 (LWP 4996)]
Oct 5 14:30:02 thully-laptop NetworkManager: [New Thread -1220310128 (LWP 7382)]
Oct 5 14:30:02 thully-laptop NetworkManager: [New Thread -1211917424 (LWP 7295)]
Oct 5 14:30:02 thully-laptop NetworkManager: (no debugging symbols found)
Oct 5 14:30:02 thully-laptop last message repeated 4 times
Oct 5 14:30:02 thully-laptop NetworkManager: 0xffffe410 in __kernel_vsyscall ()
Oct 5 14:30:02 thully-laptop NetworkManager: ******************* END **********************************

I don't know if this is indeed a dupe, as I simply have wireless on and don't connect to andy networks when this happens. It doesn't happen, however, with my wireless (madwifi) disabled.

Reopening - if it is determined that my bug is separate from this, please reopen mine (140034) and close this again

Changed in network-manager:
status: Fix Released → New
Alexander Sack (asac) wrote :

pleae test the 0.6.5-0ubuntu16~ppa1 package from my ppa:
    http://ppa.launchpad.net/asac/ubuntu/pool/main/n/network-manager/

Thanks,

 - Alexander

Tim Hull (thully) wrote :

I just installed it, and will keep you updated as to whether the problem comes back or disappears...

Tim Hull (thully) wrote :

I just had a crash occur with the newly-updated packages from the PPA. After the crash, nm-applet continues to run, but reports "no network devices found". This just occured out of the blue - I wasn't associated with any networks and didn't suspend-to-RAM, log out, or anything of that sort.

I have attached my daemon.log file when this issue occurred to the bug report - I hope it helps. You can see the crash occur in the log file at 13:15 - at that point the logfile refers to an exception involving NetworkManager, and that's when nm-applet spontaneously stopped seeing networks.

Tim Hull (thully) wrote :

Is there anything else I can do to help resolve this issue? Is my issue different from that originally reported? This is quite annoying, as I have to deal with network-manager randomly crashing on a regular basis...

Alexander Sack (asac) wrote :

Tim, if you can reproduce this, please come to #ubuntu-mozillateam channel on irc.freenode.net and ping me (asac).

Thanks,
 - Alexander

I will try sometime in the next few days - I've been busy...

On 10/11/07, Alexander Sack <email address hidden> wrote:
>
> Tim, if you can reproduce this, please come to #ubuntu-mozillateam
> channel on irc.freenode.net and ping me (asac).
>
> Thanks,
> - Alexander
>
> --
> Network manager crash with WPA
> https://bugs.launchpad.net/bugs/145683
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Alexander Sack (asac) wrote :

well ... time is not on our side ... we release next week ... so please test asap.

anyway ... there are new packages in my ppa:

0.6.5-0ubuntu16~ppa3 ...
    http://ppa.launchpad.net/asac/ubuntu/pool/main/n/network-manager/

Thanks,

 - Alexander

Tim Hull (thully) wrote :

Yes, I know that - this just isn't the greatest time at the moment. I
should have time tomorrow, though - and Monday/Tuesday...
I just installed your new package, and will report if it improves anything.

On 10/12/07, Alexander Sack <email address hidden> wrote:
>
> well ... time is not on our side ... we release next week ... so please
> test asap.
>
> anyway ... there are new packages in my ppa:
>
> 0.6.5-0ubuntu16~ppa3 ...
> http://ppa.launchpad.net/asac/ubuntu/pool/main/n/network-manager/
>
> Thanks,
>
> - Alexander
>
> --
> Network manager crash with WPA
> https://bugs.launchpad.net/bugs/145683
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Alexander Sack (asac) wrote :

thanks a lot.

Alexander Sack (asac) wrote :

Tim?

Tim Hull (thully) wrote :

is this a patch for my issue? If so, could you post a .deb?

On 10/15/07, Alexander Sack <email address hidden> wrote:
>
>
> ** Attachment added: "patch to drop supplicant shutdown feature and its
> followup patches"
> http://launchpadlibrarian.net/10004427/lp145683-proposed.patch
>
> --
> Network manager crash with WPA
> https://bugs.launchpad.net/bugs/145683
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Tim Hull (thully) wrote :

Here's the backtrace info...
Program received signal SIGPIPE, Broken pipe.
[Switching to Thread -1212664144 (LWP 3388)]
0xffffe410 in __kernel_vsyscall ()
(gdb) bt
#0 0xffffe410 in __kernel_vsyscall ()
#1 0xb7c8ddce in writev () from /lib/tls/i686/cmov/libc.so.6
#2 0xb7e9deb6 in ?? () from /usr/lib/libdbus-1.so.3
#3 0x0000000b in ?? ()
#4 0xbfaf742c in ?? ()
#5 0x00000002 in ?? ()
#6 0xb7e940bc in ?? () from /usr/lib/libdbus-1.so.3
#7 0xbfaf74cc in ?? ()
#8 0x00000072 in ?? ()
#9 0xbfaf742c in ?? ()
#10 0x0809fb20 in ?? ()
#11 0x00000088 in ?? ()
#12 0x0809abc0 in ?? ()
#13 0x0000007a in ?? ()
#14 0xb7ea6870 in ?? () from /usr/lib/libdbus-1.so.3
#15 0x080983f8 in ?? ()
#16 0x0000007a in ?? ()
#17 0xbfaf7478 in ?? ()
#18 0xb7e9df17 in ?? () from /usr/lib/libdbus-1.so.3
#19 0x0000000b in ?? ()
#20 0x0809ae9c in ?? ()
#21 0x00000000 in ?? ()
(gdb) bt full
#0 0xffffe410 in __kernel_vsyscall ()
No symbol table info available.
#1 0xb7c8ddce in writev () from /lib/tls/i686/cmov/libc.so.6
No symbol table info available.
#2 0xb7e9deb6 in ?? () from /usr/lib/libdbus-1.so.3
No symbol table info available.
#3 0x0000000b in ?? ()
No symbol table info available.
#4 0xbfaf742c in ?? ()
No symbol table info available.
#5 0x00000002 in ?? ()
No symbol table info available.
#6 0xb7e940bc in ?? () from /usr/lib/libdbus-1.so.3
No symbol table info available.
#7 0xbfaf74cc in ?? ()
No symbol table info available.
#8 0x00000072 in ?? ()
No symbol table info available.
#9 0xbfaf742c in ?? ()
No symbol table info available.
#10 0x0809fb20 in ?? ()
No symbol table info available.
#11 0x00000088 in ?? ()
---Type <return> to continue, or q <return> to quit---
No symbol table info available.
#12 0x0809abc0 in ?? ()
No symbol table info available.
#13 0x0000007a in ?? ()
No symbol table info available.
#14 0xb7ea6870 in ?? () from /usr/lib/libdbus-1.so.3
No symbol table info available.
#15 0x080983f8 in ?? ()
No symbol table info available.
#16 0x0000007a in ?? ()
No symbol table info available.
#17 0xbfaf7478 in ?? ()
No symbol table info available.
#18 0xb7e9df17 in ?? () from /usr/lib/libdbus-1.so.3
No symbol table info available.
#19 0x0000000b in ?? ()
No symbol table info available.
#20 0x0809ae9c in ?? ()
No symbol table info available.
#21 0x00000000 in ?? ()
No symbol table info available.
(gdb) threads apply bt full
Undefined command: "threads". Try "help".
(gdb) thread apply bt full
(gdb) apply threads bt full
Undefined command: "apply". Try "help".
(gdb)

Tim Hull (thully) wrote :

Here's the thread apply all backtrace:

(gdb) thread apply all bt

Thread 3 (Thread -1221059696 (LWP 3394)):
#0 0xffffe410 in __kernel_vsyscall ()
#1 0xb7c8b647 in poll () from /lib/tls/i686/cmov/libc.so.6
#2 0xb7dac593 in ?? () from /usr/lib/libglib-2.0.so.0
#3 0x0809d628 in ?? ()
#4 0x00000001 in ?? ()
#5 0x00000764 in ?? ()
#6 0x0809d628 in ?? ()
#7 0x00000001 in ?? ()
#8 0xb7381344 in ?? ()
#9 0xb7d14541 in pthread_mutex_lock () from /lib/tls/i686/cmov/libpthread.so.0
#10 0xb7dac909 in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#11 0x08057d9e in nm_device_worker (user_data=0x80a0028) at nm-device.c:291
#12 0xb7dcc5af in ?? () from /usr/lib/libglib-2.0.so.0
#13 0x080a0028 in ?? ()
#14 0x0809e050 in ?? ()
#15 0x00000000 in ?? ()

Thread 2 (Thread -1212666992 (LWP 3391)):
#0 0xffffe410 in __kernel_vsyscall ()
#1 0xb7c8b647 in poll () from /lib/tls/i686/cmov/libc.so.6
#2 0xb7dac593 in ?? () from /usr/lib/libglib-2.0.so.0
---Type <return> to continue, or q <return> to quit---
#3 0x0809b0e8 in ?? ()
#4 0x00000001 in ?? ()
#5 0xffffffff in ?? ()
#6 0x0809b0e8 in ?? ()
#7 0x00000001 in ?? ()
#8 0x00000000 in ?? ()

Thread 1 (Thread -1212664144 (LWP 3388)):
#0 0xffffe410 in __kernel_vsyscall ()
#1 0xb7c8ddce in writev () from /lib/tls/i686/cmov/libc.so.6
#2 0xb7e9deb6 in ?? () from /usr/lib/libdbus-1.so.3
#3 0x0000000b in ?? ()
#4 0xbfaf742c in ?? ()
#5 0x00000002 in ?? ()
#6 0xb7e940bc in ?? () from /usr/lib/libdbus-1.so.3
#7 0xbfaf74cc in ?? ()
#8 0x00000072 in ?? ()
#9 0xbfaf742c in ?? ()
#10 0x0809fb20 in ?? ()
#11 0x00000088 in ?? ()
#12 0x0809abc0 in ?? ()
#13 0x0000007a in ?? ()
#14 0xb7ea6870 in ?? () from /usr/lib/libdbus-1.so.3
---Type <return> to continue, or q <return> to quit---
#15 0x080983f8 in ?? ()
#16 0x0000007a in ?? ()
#17 0xbfaf7478 in ?? ()
#18 0xb7e9df17 in ?? () from /usr/lib/libdbus-1.so.3
#19 0x0000000b in ?? ()
#20 0x0809ae9c in ?? ()
#21 0x00000000 in ?? ()

Tim Hull (thully) wrote :
Download full text (4.6 KiB)

Here's the output before the crash...

thully@thully-laptop:/root/network-manager-0.6.5/src$ sudo gdb .libs/lt-NetworkManager
GNU gdb 6.6-debian
Copyright (C) 2006 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB. Type "show warranty" for details.
This GDB was configured as "i486-linux-gnu"...
Using host libthread_db library "/lib/tls/i686/cmov/libthread_db.so.1".
(gdb) run --no-daemon
Starting program: /root/network-manager-0.6.5/src/.libs/lt-NetworkManager --no-daemon
[Thread debugging using libthread_db enabled]
[New Thread -1212664144 (LWP 3388)]
lt-NetworkManager: <info> starting...
lt-NetworkManager: <info> eth0: Device is fully-supported using driver 'sky2'.
[New Thread -1212666992 (LWP 3391)]
lt-NetworkManager: <info> nm_device_init(): waiting for device's worker thread to start
lt-NetworkManager: <info> nm_device_init(): device's worker thread started, continuing.
lt-NetworkManager: <info> Now managing wired Ethernet (802.3) device 'eth0'.
lt-NetworkManager: <info> Deactivating device eth0.
lt-NetworkManager: <info> ath0: Device is fully-supported using driver 'ath_pci'.
[New Thread -1221059696 (LWP 3394)]
lt-NetworkManager: <info> nm_device_init(): waiting for device's worker thread to start
lt-NetworkManager: <info> nm_device_init(): device's worker thread started, continuing.
lt-NetworkManager: <info> Now managing wireless (802.11) device 'ath0'.
lt-NetworkManager: <info> Deactivating device ath0.
lt-NetworkManager: <info> Updating allowed wireless network lists.
lt-NetworkManager: <info> Will activate wired connection 'eth0' because it now has a link.
lt-NetworkManager: <info> SWITCH: no current connection, found better connection 'eth0'.
lt-NetworkManager: <info> Will activate connection 'eth0'.
lt-NetworkManager: <info> Device eth0 activation scheduled...
lt-NetworkManager: <info> Activation (eth0) started...
lt-NetworkManager: <info> Activation (eth0) Stage 1 of 5 (Device Prepare) scheduled...
lt-NetworkManager: <info> Activation (eth0) Stage 1 of 5 (Device Prepare) started...
lt-NetworkManager: <info> Activation (eth0) Stage 2 of 5 (Device Configure) scheduled...
lt-NetworkManager: <info> Activation (eth0) Stage 1 of 5 (Device Prepare) complete.
lt-NetworkManager: <info> Activation (eth0) Stage 2 of 5 (Device Configure) starting...
lt-NetworkManager: <info> Activation (eth0) Stage 2 of 5 (Device Configure) successful.
lt-NetworkManager: <info> Activation (eth0) Stage 3 of 5 (IP Configure Start) scheduled.
lt-NetworkManager: <info> Activation (eth0) Stage 2 of 5 (Device Configure) complete.
lt-NetworkManager: <info> Activation (eth0) Stage 3 of 5 (IP Configure Start) started...
lt-NetworkManager: <info> Activation (eth0) Beginning DHCP transaction.
lt-NetworkManager: <info> Activation (eth0) Stage 3 of 5 (IP Configure Start) complete.
lt-NetworkManager: <info> DHCP daemon state is now 12 (successfully started) for interface eth0
lt-NetworkManager: <info> DHCP daemon state is now ...

Read more...

Ryan Gordon (tikitiki) wrote :

Just wanted to let you know that I'm experiencing the same problems as Tim Hull. I'm on Ubuntu Gusty installed into VMWare - Everything was working fine until I updated and then it gives me the same "No Network Devices Have Been Found" error as Tim.

I can join the IRC channel. I've had some experience but it's limited mostly to the LAMP sector and rudimentary terminal commands so you'll have to walk me through the debugging, applying patches and tracebacks. I have no problem testing code since it's isolated to my VMWare client and I can simply reinstall.

Ryan

Alexander Sack (asac) wrote :

please outline your setup (in vm) and explain how you trigger it ... maybe i can finally reproduce this issue as well.

Tim Hull (thully) wrote :

If you reset your virtual machine, does NetworkManager work for a while
after the reset?

On 10/16/07, Ryan Gordon <email address hidden> wrote:
>
> Just wanted to let you know that I'm experiencing the same problems as
> Tim Hull. I'm on Ubuntu Gusty installed into VMWare - Everything was
> working fine until I updated and then it gives me the same "No Network
> Devices Have Been Found" error as Tim.
>
> I can join the IRC channel. I've had some experience but it's limited
> mostly to the LAMP sector and rudimentary terminal commands so you'll
> have to walk me through the debugging, applying patches and tracebacks.
> I have no problem testing code since it's isolated to my VMWare client
> and I can simply reinstall.
>
> Ryan
>
> --
> Network manager crash with WPA
> https://bugs.launchpad.net/bugs/145683
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Ryan Gordon (tikitiki) wrote :

No, it doesn't work if I reset my virtual machine. I've tried it several times before already.

What I did was:
1) Burn Gusty ISO to a DVD
2) Setup Ubuntu in VM
3) Install VMWare Tools (Note: It still worked after I installed it)
4) Installed Updates
5) Restarted computer
6) No internet connection (The No Network Devices Have Been Found message)

My Ethernet is set to NAT in VMWare

Tim Hull (thully) wrote :

OK, so it probably is a different issue - my problem is that NetworkManager
dies after working properly for a while...

On 10/16/07, Ryan Gordon <email address hidden> wrote:
>
> No, it doesn't work if I reset my virtual machine. I've tried it several
> times before already.
>
> What I did was:
> 1) Burn Gusty ISO to a DVD
> 2) Setup Ubuntu in VM
> 3) Install VMWare Tools (Note: It still worked after I installed it)
> 4) Installed Updates
> 5) Restarted computer
> 6) No internet connection (The No Network Devices Have Been Found message)
>
> My Ethernet is set to NAT in VMWare
>
> --
> Network manager crash with WPA
> https://bugs.launchpad.net/bugs/145683
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Alexander Sack (asac) wrote :

Ryan, please open a new bug and attach your /var/log/syslog

Alexander Sack (asac) wrote :

this is obviously confirmed. any instructions on how to reproduce with the ~ppa3 package still appreciated.

Changed in network-manager:
status: New → Confirmed
Alexander Sack (asac) on 2007-10-18
description: updated
Alex Mauer (hawke) wrote :

ppa3 has been working fine for me for the last 4 days. Will update with results next week.

Alexander Sack (asac) wrote :

if the proposed package in this bugs fixes your crashes as well, please let us know.

Changed in network-manager:
milestone: ubuntu-7.10-rc → gutsy-updates
status: Confirmed → Fix Committed
Rocko (rockorequin) wrote :

I did a test and ppa3 seems to fix my problem as well (mine wasn't related to WPA, but to using nm-applet to change the wired connection to a static address - see bug #153816).

Rocko (rockorequin) wrote :

Maybe I spoke too soon: several hours later network-manager is using about 50% CPU. The main things that have happened in the meantime according to daemon.log are:

* I used vpnc to connect and disconnect to a remote network.
* A virtual network used by vmware-server has been regularly requesting and receiving DHCPREQUEST/DHCPPACK.
* eth0 has also been regularly requesting and receiving DHCPREQUEST/DHCPPACK and re-binding to the same IP address.
* hald mounted and unmounted a USB drive (NetworkManager reports whenever it sees such a drive).

Also, the screen saver has been active.

However, I can't see anything in the log that looks like a network-manager crash, so perhaps this is a separate bug?

Jeremy Nickurak (nickurak) wrote :

Since I switched to ppa3, I haven't seen any cpu spikes, nm crashes, or nm-related suspend/resume issues. Huge step up in reliability.

Rocko (rockorequin) wrote :

I just came back from lunch and NM (ppa3) was using 95% CPU again. However, I can't see any crashes in the log, just various dhcp requests and responses.

Matt Brannock (heisroot) wrote :

I was also having CPU spikes and crashes in NM (requiring a dbus restart to fix), usually when switching wireless networks or interfaces (i.e. wireless to wired). There was also considerable lag in detecting new wireless networks and between when I chose a new network and it actually started connecting.

I installed ppa3, and for the moment, everything seems 100% better. Switching wireless networks begins immediately and everything seems tremendously more responsive.

My only problem is Ubuntu thinks the package is older than (and therefore inferior to) the standard NM package in synaptic. Is this correct?

Ted Carnahan (tedcarnahan) wrote :

Confirm ~ppa3 solves this problem for me as well.

I have had similar problems with ipw3945 causing random crashes as described above. I haven't had any problems since switching from the NEWER 0.6.5-0ubuntu16 to the PPA repository's 0.6.5-0ubuntu16~ppa3, which according to the changelogs has a different set of patches applied. As far as my machine goes, moving those patches to a new release is warranted. Thanks.

Tim Hull (thully) wrote :

Is my problem different from this? Because I know that the latest ppa package does NOT fix it for me - my NetworkManager still randomly crashes...

Fabio FZero (fabio-fzero) wrote :

I'm having a similar issue on Gutsy (release version): NetworkManager doesn't actually crash, but pegs the CPU at 100% and loses the connection. My wi-fi card is an Intel ProSet using open-source drivers on a Centrino notebook (Toshiba M35X S311) .

Mary Gardiner (puzzlement) wrote :

~ppa3 seems to fix the problem for me (I didn't see high CPU loads, just the crashes after resuming from suspend).

However, would it be possible to build a package with a version number that apt does not consider to be a downgrade from the version released in Gutsy? apt, aptitude and update-manager all want to 'upgrade' me from 0.6.5-0ubuntu16~ppa3 back to the Gutsy version 0.6.5-0ubuntu16.

Joss Winn (josswinn) wrote :

I'm still getting this with the latest Gutsy package. My syslog is attached.

This might be the relevant part:

Nov 4 16:03:23 localhost anacron[7018]: Normal exit (0 jobs run)
Nov 4 16:03:24 localhost kernel: [ 6384.580000] ipw3945: Detected geography ABG (13 802.11bg channels, 23 802.11a channels)
Nov 4 16:03:31 localhost NetworkManager: <info> SUP: response was 'TIMEOUT[CLI]'
Nov 4 16:03:31 localhost NetworkManager: <WARN> nm_utils_supplicant_request_with_check(): supplicant_cleanup: supplicant error for 'TERMINATE'. Response: 'TIMEOUT[CLI]'
Nov 4 16:03:31 localhost NetworkManager: <WARN> supplicant_cleanup(): supplicant_cleanup - couldn't terminate wpasupplicant cleanly.
Nov 4 16:03:31 localhost NetworkManager: <WARN> nm_signal_handler(): Caught signal 11. Generating backtrace...
Nov 4 16:03:31 localhost NetworkManager: ******************* START **********************************
Nov 4 16:03:31 localhost NetworkManager: (no debugging symbols found)
Nov 4 16:03:31 localhost NetworkManager: Using host libthread_db library "/lib/tls/i686/cmov/libthread_db.so.1".
Nov 4 16:03:31 localhost NetworkManager: (no debugging symbols found)
Nov 4 16:03:31 localhost last message repeated 12 times
Nov 4 16:03:31 localhost NetworkManager: [Thread debugging using libthread_db enabled]
Nov 4 16:03:31 localhost NetworkManager: [New Thread -1212549456 (LWP 4976)]
Nov 4 16:03:31 localhost NetworkManager: [New Thread -1229337712 (LWP 6227)]
Nov 4 16:03:31 localhost NetworkManager: [New Thread -1220945008 (LWP 5113)]
Nov 4 16:03:31 localhost NetworkManager: (no debugging symbols found)
Nov 4 16:03:31 localhost last message repeated 4 times
Nov 4 16:03:31 localhost NetworkManager: 0xffffe410 in __kernel_vsyscall ()
Nov 4 16:03:31 localhost NetworkManager: ******************* END **********************************

Tormod Volden (tormodvolden) wrote :

joss, please try the 0.6.5-0ubuntu16~ppa3 version from comment #15.

Alexander Sack (asac) on 2007-11-05
Changed in network-manager:
status: New → Fix Committed
Alexander Sack (asac) wrote :

network-manager (0.6.5-0ubuntu17) hardy; urgency=low

  * upload 0.6.5-0ubuntu17 to hardy

network-manager (0.6.5-0ubuntu16.7.10.0) gutsy-proposed; urgency=low

  Release changes from test package previously known as 0.6.5-0ubuntu16~ppa3:
  * drop gracefull supplicant shutdown feature and its followup patches,
    because they cause crashes and a real fix would need more intrusive code
    rewrites: (LP: #145683, LP: #83623, LP: #152098, LP: #151405)
    - debian/patches/41n_graceful_supplicant_shutdown.patch,
      debian/patches/41q_retry_supplicant_cleanup_startup_if_ctrl_interface_connect_failes.patch,
      debian/patches/41v_lp141233-fix-supplicant-cleanup-crashes.patch,
      debian/patches/41w_lp145683_cancel_scan_in_supplicant_cleanup.patch: drop
        patches that belong to the "graveful supplicant feature".
    - debian/patches/41u_custom_timeout_for_some_wpa_ctrl_operations.patch: update
      interleaving patch
    - debian/patches/series: update quilt series accordingly.
  * debian/patches/24pp_svn2604_Add-HAL-based-rfkill-support.patch: use
    gint32 instead of guint32 for getting the killswitch power argument
    (LP: #138794).

 -- Alexander Sack <email address hidden> Mon, 05 Nov 2007 19:14:43 +0100

Changed in network-manager:
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

Accepted into gutsy-proposed, please test.

Fabio FZero (fabio-fzero) wrote :

Testing the gutsy-proposed package:

- Wireless works fine returning from suspend.
- Wireless also works fine returning from hibernation.

Yep, seems to be fixed! At least for me. ;-)

Harald Staub (staub) wrote :

With gutsy's original version, after a few suspend/resume cycles, networking did not wake up (only tried wireless). It worked fine with the ppa3 version, and now, the new version of gutsy-proposed works fine as well.

Rocko (rockorequin) wrote :

With 0.6.5-0ubuntu16.7.10.0, out of three suspend/resume cycles, my *wired* network has only resumed correctly once. Both other times I tried to 'sudo dhclient eth0', but this failed as well. I fixed it both times by using nm-applet to first disable networking and then enable it. I still had to manually do a 'sudo dhclient eth0' command to get an address.

But I haven't seen any CPU spikes (ie no crashes) with the new 0.6.5-0ubuntu16.7.10.0.

I still have this problem with this package (0.6.5-0ubuntu16.7.10.0), but maybe there's another bug, since I don't see the relation to WPA. I just boot and get this 100% cpu. I must kill it in order for the system to function correctly, and use the normal manual networking to connect to wireless/network.

I tried the package from gutsy-proposed, I have had the crash again... here it is:

Nov 26 09:50:41 rukbat NetworkManager: [Thread debugging using libthread_db enabled]
Nov 26 09:50:41 rukbat NetworkManager: [New Thread -1212455248 (LWP 11942)]
Nov 26 09:50:41 rukbat NetworkManager: [New Thread -1229243504 (LWP 11992)]
Nov 26 09:50:41 rukbat NetworkManager: (no debugging symbols found)
Nov 26 09:50:41 rukbat last message repeated 4 times
Nov 26 09:50:41 rukbat NetworkManager: 0xffffe410 in __kernel_vsyscall ()
Nov 26 09:50:41 rukbat NetworkManager: ******************* END **********************************

kill -9 and restart makes it work again. This happened after a resume, switching from wireless without connection to a wired connection. No WPA involved.

Running a 2.6.24-rc3 kernel here, with ndiswrapper (the standard kernel did not resume properly, so I can't test it).

I tried too with the package 0.6.5-0ubuntu16.7.10.0, and so far the suspend/resume seems to work great... I've tested it 4-5 times.

Alexander Sack (asac) on 2007-11-26
description: updated

It is working well now for me too, that first hang seems to be not reproducible.

By the way, there is a trick to install just one gutsy-proposed package without having to enable the repository, did the upgrade of just that one over the 20 or so available there, and then re-disabling it?

Thanks.

Stéphane Graber (stgraber) wrote :

You can turn on the proposed updates, then refresh the list of updates.
Only tick the ones you want and update, then disabled the proposed
updates.

Stéphane

SeG (razahel) wrote :

I tried the 0.6.5 17 package from proposed but I am still not able to connect to my universities 802.1X wpa enterprise network. After this update it is for me also not possible to access the open university network which has a little low signal quality

Martin Pitt (pitti) wrote :

Although the update is not perfect, there have been no reports about apparent regressions, there is some good feedback here, and excellent feedback in bug 83623. Considering verified.

Martin Pitt (pitti) wrote :

Copied to gutsy-updates.

Changed in network-manager:
status: Fix Committed → Fix Released

Just a note, it happened again. It's more difficult to trigger now than before the update, but it's not gone. Switching from wireless to wired across suspends seems to trigger it.
My wireless is ndiswrapper and wired r8169, if this can make a difference.

As I said before, with the new version I still have this problem (but not related to wpa or suspend/resume). When the system boots I get right away 100% cpu and must kill NetworkManager. I tried reinstalling the packages for NM several times and it doesn't work. I'm alone on that boat it seems? Any ideas?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers