PPTP VPN fails to connect in 15.04, but works in 14.04/14.10

Bug #1452941 reported by citizendelta on 2015-05-07
30
This bug affects 6 people
Affects Status Importance Assigned to Milestone
network-manager (Ubuntu)
High
Unassigned

Bug Description

I can create a PPTP VPN connection and connect to a remote network in Ubuntu 14.04/14.10 (Unity live boot DVD) but the connection does not work in Ubuntu 15.04 (Unity live boot USB), even though I am using the exact same GUI configuration settings in the Network-Manager (I have confirmed this several times). In addition to the live boot instances, the PPTP VPN connected without problems for me on my 14.04/14.10 installs, but failed on a fresh harddisk install of Ubuntu MATE 15.04.

The error that I get in a notification pop-up window when trying to connect on 15.04 is: "The VPN connection 'VPN connection 1' failed because the VPN service returned invalid configuration."

ubuntu@ubuntu:~$ lsb_release -rd
Description: Ubuntu 15.04
Release: 15.04

ubuntu@ubuntu:~$ apt-cache policy network-manager
network-manager:
  Installed: 0.9.10.0-4ubuntu15
  Candidate: 0.9.10.0-4ubuntu15
  Version table:
 *** 0.9.10.0-4ubuntu15 0
        500 http://archive.ubuntu.com/ubuntu/ vivid/main amd64 Packages
        100 /var/lib/dpkg/status

ProblemType: Bug
DistroRelease: Ubuntu 15.04
Package: network-manager 0.9.10.0-4ubuntu15
ProcVersionSignature: Ubuntu 3.19.0-15.15-generic 3.19.3
Uname: Linux 3.19.0-15-generic x86_64
ApportVersion: 2.17.2-0ubuntu1
Architecture: amd64
CasperVersion: 1.360
CurrentDesktop: Unity
Date: Thu May 7 22:55:12 2015
IfupdownConfig:
 # interfaces(5) file used by ifup(8) and ifdown(8)
 auto lo
 iface lo inet loopback
IpRoute:
 default via 192.168.0.1 dev wlan0 proto static metric 1024
 169.254.0.0/16 dev wlan0 scope link metric 1000
 192.168.0.0/24 dev wlan0 proto kernel scope link src 192.168.0.20
 207.173.246.134 via 192.168.0.1 dev wlan0 src 192.168.0.20
LiveMediaBuild: Ubuntu 15.04 "Vivid Vervet" - Release amd64 (20150422)
NetworkManager.state:
 [main]
 NetworkingEnabled=true
 WirelessEnabled=true
 WWANEnabled=true
 WimaxEnabled=true
ProcEnviron:
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: network-manager
UpgradeStatus: No upgrade log present (probably fresh install)
nmcli-dev:
 DEVICE TYPE STATE DBUS-PATH CONNECTION CON-UUID CON-PATH
 wlan0 wifi connected /org/freedesktop/NetworkManager/Devices/2 LANbeforetime 1fefef93-2d1c-41eb-ad55-3f6c234d7023 /org/freedesktop/NetworkManager/ActiveConnection/0
 eth0 ethernet unavailable /org/freedesktop/NetworkManager/Devices/1 -- -- --
 lo loopback unmanaged /org/freedesktop/NetworkManager/Devices/0 -- -- --
nmcli-nm: Error: command ['nmcli', '-f', 'all', 'nm'] failed with exit code 2: Error: Object 'nm' is unknown, try 'nmcli help'.

citizendelta (dghallau) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in network-manager (Ubuntu):
status: New → Confirmed
Changed in network-manager (Ubuntu):
importance: Undecided → High
citizendelta (dghallau) wrote :

The work around for this for me has been to delete the IPV4 Route that I had configured.

After looking at some of the recommendations at https://bugzilla.gnome.org/show_bug.cgi?id=733296, I found a solution. In 14.04/14.10, I originally had had to set up an IPV4 Route to get the PPTP VPN to work. In 15.04, deleting that Route from the GUI configuration settings solved the problem. After deleting that route, the VPN has been able to connect.

awal (acwalter) wrote :

Keep your route but use 0.0.0.0 as teh route gateway.

wantlamy (wantlamy) wrote :

pptp vpn works on ubuntu 14.04 with kernel 3.13.x and 3.16.x, but doesn't work with kernel 3.19.x.
And it doesn't work by default, until insmod nf_conntrack_pptp.

Jared Warren (jawarren) wrote :

I needed to load all three of these modules to get it to work: nf_nat_pptp, nf_conntrack_pptp, nf_conntrack_proto_gre

Jared Warren (jawarren) wrote :

Scratch that, loading the modules allows it to work with a *single* IPv4 route, but I get the same error if I try to connect with multiple roots. My NetworkManager output to syslog is attached.

novaBS (novabs) wrote :

This bugs also affects me in Ubuntu 15.10 (network-manager-pptp 0.9.10). Anyone who has an easy workaround to fix? Because I do totally not understand the fix as mentioned above…

Takeuchi (g-takeuchi) wrote :

This bug also affects me. The workaround to remove the gateway from the static routes (leaving it blank) works like a charm!

Basically, just go to your static route configuration (ipv4 tab > Advanced) and leave the gateway blank.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.