network-manager configured to use /usr/sbin/pppoe but does not recommend pppoe

Bug #1446689 reported by Mustafa Muhammad on 2015-04-21
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
network-manager (Debian)
Fix Released
Unknown
network-manager (Ubuntu)
High
Mathieu Trudel-Lapierre

Bug Description

networkmanager switched from using ppp to using pppoe binary for dsl/pppoe connections, I am using pppoe and I can't connect to the Internet unless I install "pppoe" package.

From:
http://cgit.freedesktop.org/NetworkManager/NetworkManager/commit/?h=nm-0-9-10&id=7955806a02db64b20079267743056d7d9d45af3b

"for now, work around this by using the userland pppoe client rather than the kernel code"

One way to fix it is to include pppoe
Another way is to configure --with-pppoe=/usr/sbin/pppd.

I think this is urgent as pppoe/dsl on all vivid machines will be broken out-of-the-box.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in network-manager (Ubuntu):
status: New → Confirmed
Graham Inggs (ginggs) wrote :

> One way to fix it is to include pppoe
> Another way is to configure --with-pppoe=/usr/sbin/pppd.

This is mentioned in the Debian changelog:

network-manager (0.9.10.0-1) unstable; urgency=medium
...
 * Specify the path to the pppd and pppoe binary via the corresponding
    configure switch.
 ...
 -- Michael Biebl <email address hidden> Thu, 10 Jul 2014 06:44:53 +0200

Graham Inggs (ginggs) wrote :

> I think this is urgent as pppoe/dsl on all vivid machines will be broken
> out-of-the-box.

Confirming that this breaks on upgrades too.

summary: - networkmanager requires pppoe but it is not in "requires"
+ network-manager configured to use /usr/sbin/pppoe but does not recommend
+ pppoe
Graham Inggs (ginggs) wrote :

> One way to fix it is to include pppoe
> Another way is to configure --with-pppoe=/usr/sbin/pppd.

Do either or both of these methods work for you?

I have a machine recently upgraded from Utopic to Vivid and PPPoE stopped working.
I have tried 'sudo apt-get install pppoe' and I still cannot establish a PPPoE connection.

Installing pppoe solves the problem for me

Changed in network-manager (Debian):
status: Unknown → New

This still exist in Wily Werewolf beta 1, this is important and the release is approaching.

Could you increase the priority of this bug, maybe even mark it as blocker, its effect is bad and it is easy to fix, just a build flag or added dependency.

Triaged/High; since this affects some users who connect directly through PPPoE. While this may be a relatively low number of people, it's crippling if they cannot retrieve pppoe after the fact due to no network...

This simply needs a cherry-pick of http://cgit.freedesktop.org/NetworkManager/NetworkManager/commit/?id=6fdfb03107138e96e641d12a7c4df5ecfacb5406, which reverts changes that unfortunately landed in vivid too; so should be SRU'd.

As an added benefit, with this patch it is unnecessary to install the pppoe package, everything is handled directly by pppd.

Changed in network-manager (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → High
assignee: nobody → Mathieu Trudel-Lapierre (mathieu-tl)

Just committed the patch in the NM packaging branch; will upload soonish.

Changed in network-manager (Ubuntu):
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package network-manager - 1.0.4-0ubuntu5

---------------
network-manager (1.0.4-0ubuntu5) wily; urgency=medium

  * debian/patches/git_set_vpn_mtu_9736327b.patch: set the MTU for the VPN
    interface. (LP: #1498474)
  * debian/patches/lp1446689_git_use_kernel_pppoe_6fdfb031.patch: use the
    kernel-provided pppoe interfaces rather than requiring the use of rp-pppoe
    to use PPPoE; we switched to rp-pppoe some time ago to workaround a bug in
    detecting disconnects which has seen been fixed and could be worked around
    fairly simply with the right configuration. (LP: #1446689)
  * debian/rules: don't pass --with-pppoe to configure; the option is removed
    by the above patch.

 -- Mathieu Trudel-Lapierre <email address hidden> Wed, 14 Oct 2015 12:33:53 -0400

Changed in network-manager (Ubuntu):
status: In Progress → Fix Released
Rustom (rustompmody) wrote :

Hello
I upgraded vivid to wily yesterday and my networking is broken
Not sure but it looked like this bug?

Machine with vivid upgraded to wily: network not working

$ ip -d route
unicast 117.195.32.1 dev ppp0 proto kernel scope link src 117.195.47.122
unicast 169.254.0.0/16 dev ppp0 proto boot scope link metric 1000 [/code]

By contrast 14.10 booted from usb and pppoe by hand -- network working

$ ip -d route
unicast default dev ppp0 proto boot scope link
unicast 117.195.32.1 dev ppp0 proto kernel scope link src 117.195.40.157
unicast 192.168.1.0/24 dev eth0 proto kernel scope link src 192.168.1.2 metric 1

Some evident issues

- The absence of default is an obvious problem
- The large metric is another problem
- eth0 has become ppp0

As suggested earlier in this thread I downloaded pppoe package and installed it by hand (since apt is down with not networking)
But its not helped

Changed in network-manager (Debian):
status: New → Fix Released
Benoit Grégoire (benoitg) wrote :

I have the exact same problem as Rustom, after upgrading from vivid to wily. pppoe id not setting the default route.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.