[Kubuntu 15.04 beta] can't connect to wifi with Ralink RT2561/RT61 and NetworkManager

Bug #1444226 reported by YAFU on 2015-04-15
48
This bug affects 9 people
Affects Status Importance Assigned to Milestone
network-manager (Ubuntu)
Low
Unassigned

Bug Description

Hello.
I have a Ralink with RT2561/RT61 chip:
$ lspci | grep -i network
05:00.0 Network controller: Ralink corp. RT2561/RT61 802.11g PCI

In Kubuntu 15.04 my connection is very unstable using NetworkManager. Most of the time the connection is not established. And very few times the connection is established but after a few seconds the connection drops. Unfortunately in this new Kubuntu version if you try to uninstall "network-manager" then "plasma-desktop" is requested to be uninstalled (apparently because of "plasma-nm").

WORKAROUND: I installed Wicd from Kubuntu 14.04 using "chroot":
1- Start the system and try not use Network Manager
2- kill network manager
$ sudo pkill -9 NetworkManager
3- Start wicd from "menu" > "internet"

ProblemType: Bug
DistroRelease: Ubuntu 15.04
Package: linux-image-3.19.0-14-generic 3.19.0-14.14
ProcVersionSignature: Ubuntu 3.19.0-14.14-generic 3.19.3
Uname: Linux 3.19.0-14-generic x86_64
ApportVersion: 2.17.1-0ubuntu1
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: nulluser 1308 F.... pulseaudio
 /dev/snd/controlC0: nulluser 1308 F.... pulseaudio
CurrentDesktop: KDE
Date: Tue Apr 14 22:22:23 2015
HibernationDevice: RESUME=UUID=1edec07e-cb6e-4ca2-b03e-29d7ef434bc8
InstallationDate: Installed on 2015-04-12 (2 days ago)
InstallationMedia: Kubuntu 15.04 "Vivid Vervet" - Beta amd64 (20150408)
MachineType: System manufacturer System Product Name
ProcFB: 0 nouveaufb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.19.0-14-generic root=UUID=0f5fd4c5-56a1-494b-9513-074a3e1a11f1 ro quiet splash
RelatedPackageVersions:
 linux-restricted-modules-3.19.0-14-generic N/A
 linux-backports-modules-3.19.0-14-generic N/A
 linux-firmware 1.143
RfKill:
 0: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: no
SourcePackage: linux
UdevLog: Error: [Errno 2] No such file or directory: '/var/log/udev'
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 08/14/2013
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 2204
dmi.board.asset.tag: To be filled by O.E.M.
dmi.board.name: P8Z77-V LX
dmi.board.vendor: ASUSTeK COMPUTER INC.
dmi.board.version: Rev X.0x
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr2204:bd08/14/2013:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKCOMPUTERINC.:rnP8Z77-VLX:rvrRevX.0x:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: System Product Name
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer

YAFU (yafu) wrote :
YAFU (yafu) wrote :

I deleted "WifiSyslog.txt" because it contains sensitive user information. I do not know how Launchpad has not corrected this intromission problem yet. If you need something specific about it, you ask.

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
tags: added: bios-outdated-2501
description: updated
affects: linux (Ubuntu) → network-manager (Ubuntu)
Changed in network-manager (Ubuntu):
importance: Undecided → Low
status: Confirmed → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in network-manager (Ubuntu):
status: New → Confirmed
Owen (owen-ozone) wrote :

Xubuntu here, wireless has been working fine over multi distros and years on this machine, just ran the 15.04 upgrade last night.
Now I have exactly the same problem: initially connects but drops almost immediately and can't reconnect, completely unusable.

$ lspci |grep -i network
04:06.0 Network controller: Ralink corp. RT2561/RT61 rev B 802.11g

Owen (owen-ozone) wrote :

OK, I just found your workaround here YAFU https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1442908/comments/4
This fixed the problem for me too, as wifi is stable using wicd it definitely seems to be a NetworkManager problem.

Tony Bazeley (tonyb-u) wrote :

Same problem here on plain ubuntu - connects OK but drops out.
Sometimes re-connection is possible, but eventually a reboot is needed

05:06.0 Network controller: Ralink corp. RT2561/RT61 rev B 802.11g

dmesg | grep 80211 yields ( abbreviated)
[ 5659.700827] ieee80211 phy0: rt2x00queue_flush_queue: Warning - Queue 2 failed to flush
[ 5705.623098] ieee80211 phy0: rt2x00queue_flush_queue: Warning - Queue 0 failed to flush
[ 5705.783360] ieee80211 phy0: rt2x00queue_flush_queue: Warning - Queue 2 failed to flush
[ 5725.355004] ieee80211 phy0: rt2x00queue_write_tx_frame: Error - Arrived at non-free entry in the non-full queue 0
Please file bug report to http://rt2x00.serialmonkey.com

 http://rt2x00.serialmonkey.com doesn't appear to be active

Same here after upgrading from Ubuntu 14.04.2 -> 14.10 -> 15.04.

Using the Wicd workaround currently to get Wifi to work.

migs (migs1488) wrote :

Same problem and still not fixed. Wifi connection lost after 5-15 minutes and you need to restart machine!
Wicd isn't the best gui in the world, and you cannot see tray icon for it.
Network controller: Ralink corp. RT2561/RT61 rev B 802.11g

dwargo (dwargo30) wrote :

Grrr... RT61 is often a pain but geeze!

At first I thought it was an ipv6 issue as network manager seemed to insist on using it. I disabled ipv6 in the kernel but no fix.

I have now removed the linux-firmware and replaced it with firmware_ralink from the debian repos. Combined with wicd the internet is working much better but still much slower then it should be.

Could this be related? https://bugzilla.kernel.org/show_bug.cgi?id=61621

If anyone is using ndiswrapper on 64 bit as a workaround I'd love to know what device the drivers were for, or a link.

My dmesg: http://pastebin.com/tsBmH328

dwargo (dwargo30) wrote :

A possible fix:

# iw dev wlan0 set power_save off

This has made a WORLD of difference with my setup above. Now getting full speed. I wasn't having the disconnect issue like others just the slowness... my pings to google were around 120ms now 12ms ..

Someone should try this on a fresh install...

Good luck o/

# iwconfig

wlan0 IEEE 802.11bg ESSID:"edit"
          Mode:Managed Frequency:2.412 GHz Access Point: 78:C5:B3:67:43:51
          Bit Rate=54 Mb/s Tx-Power=20 dBm
          Retry short limit:7 RTS thr:off Fragment thr:off
          Encryption key:off
--> Power Management:off
          Link Quality=70/70 Signal level=-38 dBm
          Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
          Tx excessive retries:17 Invalid misc:930 Missed beacon:0

I tried the solution proposed in https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1442908/comments/4 and it worked. You can use wicd-kde instead wicd-gtk; but, besides that, you must follow the instructions. Wicd doesn't recognizes automatically the encryption, so you must try the most common: WEP, WPA (passphrase).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.