IPv6 default route present on ccmni0, even though no address assigned

Bug #1444162 reported by Michał Sawicz on 2015-04-14
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Canonical System Image
High
Tony Espy
network-manager (Ubuntu)
High
Tony Espy
network-manager (Ubuntu RTM)
High
Tony Espy

Bug Description

$ system-image-cli -i
current build number: 171
device name: m75
channel: ubuntu-touch/vivid-proposed
last update: 2015-04-14 22:23:10
version version: 171

Upon boot, my v6 routes include a default via ccmni0:
$ ip -6 route
fe80::/64 dev wlan0 proto kernel metric 256
default dev ccmni0 proto static metric 1024

Even though there's no v6 address on the device:
$ ip -6 addr
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
10: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qlen 1000
    inet6 fe80::3abc:1aff:fe18:b68b/64 scope link
       valid_lft forever preferred_lft forever

This means that hosts that have v6 addresses are tried to be reached via v6, which obviously fails:
> 29% [Connecting to ports.ubuntu.com (2001:67c:1360:8001::18)]

Toggling GSM data loses the default route:

$ ip -6 route
fe80::/64 dev wlan0 proto kernel metric 256

And the connection succeeds via v4.

Attached find a set of logs from network-test-session.

ProblemType: Bug
DistroRelease: Ubuntu 15.04
Package: network-manager 0.9.10.0-4ubuntu13
Uname: Linux 3.10.35+ armv7l
ApportVersion: 2.17-0ubuntu2
Architecture: armhf
CRDA: Error: [Errno 2] No such file or directory: 'iw'
Date: Tue Apr 14 23:45:11 2015
IfupdownConfig:
 # interfaces(5) file used by ifup(8) and ifdown(8)
 # Include files from /etc/network/interfaces.d:
 source-directory /etc/network/interfaces.d
InstallationDate: Installed on 2015-04-14 (0 days ago)
InstallationMedia: Ubuntu Vivid Vervet (development branch) - armhf (20150414-020204)
IpRoute:
 default via 10.2.0.254 dev wlan0 proto static metric 1024
 10.0.0.0/8 via 10.2.0.1 dev wlan0 proto dhcp metric 10
 10.2.0.0/24 dev wlan0 proto kernel scope link src 10.2.0.66
NetworkManager.state:
 [main]
 NetworkingEnabled=true
 WirelessEnabled=true
 WWANEnabled=true
 WimaxEnabled=true
PciNetwork:

SourcePackage: network-manager
SystemImageInfo:
 current build number: 171
 device name: m75
 channel: ubuntu-touch/vivid-proposed
 last update: 2015-04-14 22:23:10
 version version: 171
UpgradeStatus: No upgrade log present (probably fresh install)
mtime.conffile..etc.dbus.1.system.d.org.freedesktop.NetworkManager.conf: 2015-04-14T04:33:56
nmcli-nm: Error: command ['nmcli', '-f', 'all', 'nm'] failed with exit code 2: Error: Object 'nm' is unknown, try 'nmcli help'.

Related branches

Michał Sawicz (saviq) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in network-manager (Ubuntu):
status: New → Confirmed

This causes a problem on QtNetwork nm plugin.

The QtNetwork implementation goes throught the connection list and returns the first connection that is set as default for for ipv4 or ipv6 as you can see on this code [1][2].

Since the gsm connection is always the default for ipv6 it will return the gsm connection as default connection even if you are connected over wifi.

[1] http://paste.ubuntu.com/11812336/
[2] http://paste.ubuntu.com/11812429/

Note.

Just removing the rote does not fix the problem on QNetwork since it checks for nm connection properties.

GENERAL.DEFAULT: no
GENERAL.DEFAULT6: yes

To fix that, the nm should not set the gsm connection as default for IPV6.

Changed in network-manager (Ubuntu):
importance: Undecided → High
Tony Espy (awe) on 2015-08-10
Changed in network-manager (Ubuntu):
assignee: nobody → Tony Espy (awe)
Tony Espy (awe) on 2015-08-10
Changed in network-manager (Ubuntu):
status: Confirmed → In Progress
Tony Espy (awe) wrote :

@Renato

I pushed my first attempt at fixing this to my PPA. The fix involves telling NM that ofono connections should ignore IPv6.

https://launchpad.net/~awe/+archive/ubuntu/ppa

I confirmed that "Default6" is set to false, however it appears that the route still is added. Can you give it a try and see if it resolves the problem for you? If not, I may need to dig deeper into the code.

@Tony
QtNetwork is reporting the correct state after installing your packages.

Thanks

Tony Espy (awe) wrote :

Great, I'll go ahead and prep a merge proposal...

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package network-manager - 0.9.10.0-4ubuntu23

---------------
network-manager (0.9.10.0-4ubuntu23) wily; urgency=medium

  [ Tony Espy ]
  * d/p/lp1444162-add-ip6-config-to-nm-ofono-connections.patch: disable
    IPv6 for ofono connections (LP: #1444162).

 -- Mathieu Trudel-Lapierre <email address hidden> Wed, 12 Aug 2015 15:45:38 -0400

Changed in network-manager (Ubuntu):
status: In Progress → Fix Released
Tony Espy (awe) on 2015-08-14
Changed in network-manager (Ubuntu RTM):
status: New → In Progress
importance: Undecided → High
assignee: nobody → Tony Espy (awe)
Changed in canonical-devices-system-image:
assignee: nobody → Tony Espy (awe)
Tony Espy (awe) wrote :

FixReleased as version 0.9.10.0-4ubuntu15.1.7 to ppa:ci-train-ppa-service/stable-phone-overlay.

Changed in network-manager (Ubuntu RTM):
status: In Progress → Fix Released
Tony Espy (awe) wrote :

Changing Canonical System Image task to FixCommitted as 0.9.10.0-4ubuntu15.1.7 has landed in the latest rc-proposed images ( confirmed on krillin / rc-proposed / #102 which contains ubuntu version '20150818.1' ).

Changed in canonical-devices-system-image:
status: New → Fix Committed
Changed in canonical-devices-system-image:
importance: Undecided → High
status: Fix Committed → Fix Released
To post a comment you must log in.