(1) Creating object for path '/org/freedesktop/NetworkManager/ActiveConnection/0' failed in libnm-glib.

Bug #1438003 reported by Christopher M. Penalver on 2015-03-30
212
This bug affects 42 people
Affects Status Importance Assigned to Milestone
NetworkManager
Confirmed
Critical
network-manager (Ubuntu)
High
Unassigned

Bug Description

While attempting to connect to an SSID for the first time, it fails, and I consistently get:
(1) Creating object for path '/org/freedesktop/NetworkManager/ActiveConnection/0' failed in libnm-glib.

ProblemType: Bug
DistroRelease: Ubuntu 15.04
Package: network-manager 0.9.10.0-4ubuntu11
ProcVersionSignature: Ubuntu 3.19.0-10.10-generic 3.19.2
Uname: Linux 3.19.0-10-generic x86_64
NonfreeKernelModules: wl
ApportVersion: 2.16.2-0ubuntu5
Architecture: amd64
CurrentDesktop: GNOME-Flashback:Unity
Date: Sun Mar 29 23:08:37 2015
IfupdownConfig:
 # interfaces(5) file used by ifup(8) and ifdown(8)
 auto lo
 iface lo inet loopback
InstallationDate: Installed on 2015-03-29 (0 days ago)
InstallationMedia: Ubuntu 15.04 "Vivid Vervet" - Beta amd64 (20150326)
IpRoute:
 default via 192.168.1.1 dev wlan0 proto static metric 1024
 169.254.0.0/16 dev wlan0 scope link metric 1000
 192.168.1.0/24 dev wlan0 proto kernel scope link src 192.168.1.2
NetworkManager.state:
 [main]
 NetworkingEnabled=true
 WirelessEnabled=true
 WWANEnabled=true
 WimaxEnabled=true
SourcePackage: network-manager
UpgradeStatus: No upgrade log present (probably fresh install)
nmcli-dev:
 DEVICE TYPE STATE DBUS-PATH CONNECTION CON-UUID CON-PATH
 wlan0 wifi connected /org/freedesktop/NetworkManager/Devices/4 www.ubuntu.com 71c36534-c491-4479-aa91-9238b10f3945 /org/freedesktop/NetworkManager/ActiveConnection/1
 wlan1 wifi disconnected /org/freedesktop/NetworkManager/Devices/2 -- -- --
 eth0 ethernet unavailable /org/freedesktop/NetworkManager/Devices/1 -- -- --
 lo loopback unmanaged /org/freedesktop/NetworkManager/Devices/0 -- -- --
nmcli-nm: Error: command ['nmcli', '-f', 'all', 'nm'] failed with exit code 2: Error: Object 'nm' is unknown, try 'nmcli help'.

Krupier (krupier123) wrote :

Same here except of my connection dies unexpectably. Cannot recreate it, just happens. Reconnecting brought this:
(1) Creating object for path '/org/freedesktop/NetworkManager/ActiveConnection/61' failed in libnm-glib. Note the number.
Restarting Network Manager makes the system work VERY slow.

Changed in network-manager:
importance: Unknown → Critical
status: Unknown → Confirmed
Faisal Aslam (faisalaslam6309) wrote :

I get the same error but I am trying to connect a DSL connection. I experience this problem in Ubuntu Mate and Xubuntu.

Bram Stolk (b-stolk) wrote :

I'm hitting this after moving to 15.04 while 14.04 was fine.
In the dialog window:
(1) Creating object for path '/org/freedesktop/NetworkManager/ActiveConnection/6' failed in libnm-glib.
In /var/log/syslog:
(nm-applet:1417): libnm-glib-WARNING **: async_got_type: could not read properties for /org/freedesktop/NetworkManager/ActiveConnection/5: Method "Get" with signature "ss" on interface "org.freedesktop.DBus.Properties" doesn't exist

Tkess (tkess) wrote :

Same error on wire connection. Is there any temporary known work-around?

David Baumann (davidbaumann) wrote :

I would really appreciate a workaround, too, as I cannot connect with my mobile router!

Guido I (guidoweb) wrote :

I'm hitting this bug too, and so far working around it by going to Edit connections -> Edit the network you want to connect to -> manually input the WPA2 password in the Wi-Fi Security tab -> Save, then it connects without problems.

Alexandr (zalitko) wrote :

Guidi I, thanks a lot mate!!

micsu (micsu-z) wrote :

Same error for me, when trying to connect to a new DSL connection.
The workaround mentioned in #8 does not work for me. :(
Debian 8.1 Stable
network-manager version 0.9.10.0

Daan Wilmer (o-daan-d) wrote :

I have the same problem that Krupier (krupier123) has: connection dies unexpectedly, and I am unable to reconnect using the Network Manager. Restarting through `service network-manager restart` brings the system down on its knees, until I stop the service.

However, I found a workaround: when I suspend my laptop and wake it up again, the connection is up again.

drwt (6lobe) wrote :

It'd be great if this got fixed. Its getting pretty tiresome to constantly have to reboot laptop and lose data.

Suspending doesnt fix this for me. I wish it would so I wouldnt lose anything.

Vincent Thiele (vincentthiele) wrote :

Same bug on wily

tags: added: wily
Kike (mesaprop) wrote :

Also suffering this issue. Same as Daan Wilmer and Krupier123. Specially if torrent is on (probably excessive connections) but also using browser as usual. Connection stops (even appears connected but can't access the web) then sometimes restarting connection works until a point when restarting the system is the only solution. It's very annoying. Please do something about it!!!

Experiencing the same thing as krupier123 on Ubuntu 14.10. I have tried all workarounds mentioned here. Reinstalling NetworkManager fixes the issue for a couple of minutes, then the connection dies again. Rebooting, suspending, setting managed=true in NetworkManager.conf does not do anything.

lysergik (kbalog313) wrote :

Yep, suspending works for a while, only temporary fixes so far :(
really annoying.

Petr Michalec (epcim) wrote :

I have very similar problem on today\s bionic.

BTW when I use nmcli --ask I found in the UI my password in the field for password - repeated multiple times (concatenated) - (equals the number of attempts I added password to the cli prompt)

Can anyone explain how to test/fix
"could not read properties for /org/freedesktop/NetworkManager/ActiveConnection/5" is it just warning or a critical stop?

Thanks

Petr Michalec, your best bet is to file a new report given the different environment and error message via a terminal:
ubuntu-bug network-manager

I no longer have the original computer that was reproduced with (I was also using two WLAN NICs simultaneously), and was not able to reproduce on later versions of Ubuntu with different hardware. Hence, the issue is likely environment specific.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.