Ubuntu Phone: cellular data did not recover after losing coverage

Bug #1424791 reported by costales on 2015-02-23
64
This bug affects 13 people
Affects Status Importance Assigned to Milestone
NetworkManager
New
Undecided
Unassigned
network-manager (Ubuntu)
Undecided
costales

Bug Description

Hi!

Today I travelled in train and I lost my mobile signal. BUG: After have signal, the cellular data (3G) is not recovering. I have to enter in plane mode and exit from that mode for having 3G again.

Thanks in advance!

summary: - Ubuntu Phone: Not cellular data recovery after no coberture
+ Ubuntu Phone: cellular data did not recover after losing coverage
affects: canonical-devices-system-image → network-manager (Ubuntu)
Changed in network-manager (Ubuntu):
assignee: nobody → Canonical Phone Foundations (canonical-phonedations-team)
Tony Espy (awe) wrote :

@costales

There's insufficient detail in your bug report for us to reproduce this problem.

Can you please add your device, and image details ( RTM? vivid-devel? image #? ).

Changed in network-manager (Ubuntu):
status: New → Incomplete
assignee: Canonical Phone Foundations (canonical-phonedations-team) → costales (costales)
tags: added: connectivity
costales (costales) wrote :

@Tony, yes it's complicate to replicate, but I travelled 2 times in train without mobile cover, and the mobile can't recovery the 3G connection after that.

The terminal it's a BQ Ubuntu 14.10 (r20), last updated 3/19/15.
Best regards!

Tony Espy (awe) wrote :

@costales

Was it only data that didn't recover? Or was voice and SMS also affected?

Also, do you recall whether or not your phone displayed an icon for mobile data ( eg. '3g' or 'H' ), or did it just display the icon that looks like an empty WiFi icon?

Finally, if you do hit this problem again, if you're familiar with adb, could you pull the file /var/log/syslog and attach to this bug?

Tony Espy (awe) wrote :

@costales

One other thing to check... did you have more than one SIM installed in the phone? We've been working on a bug where the mobile-data SIM selection can switch to the wrong SIM after a reboot or operator switch/re-registration ( such as what can happen when signal is lost ).

See bug #1413672 for details. We on-track to have a fix in the next OTA update that addresses this issue.

riccardo (fly3836) wrote :

Hi,
sometimes it happens also on my device but I'm not able to reproduce the error. Moving to a non covered area and move back again on signal 3G the cellular data worked fine, in 2 attempts made yesterday
A similar problem happens also at home, after long inactivity period the connection is lost (also here only sometimes, not understood how the "long inactivity" is, today around 2 hours, yesterday longer). I disconnect mobile data and connect again to fix it.

Device is a BQ Ubuntu 14.10 (r21).
one SIM only, SIM is active, device is able to receive incoming call.
phone displays the icon for mobile (H or 3G) when I lock display, and then when I try to browse after 2, 3 hours.
ifconfig shows only lo interface

Best regards

francesco (francescon651) wrote :

Hi
I have the same problem of all of you in this page. After long inactivity the data mobile is off, althought it is displayed 3G on the top of screen. I have to switch from 2g to 3g in order to have data connection running. It happend every morning.

francesco (francescon651) wrote :

I foeget to tell you that I have BQ Aquaris 4.5 updated r21

riccardo (fly3836) wrote :

Hi
yesterday I upgraded the device (BQ Aquaris 4.5) to r22.
no problem today in switching from 3G to wifi and vice-versa, and recovery celluar data after driving in non covered area.

Cédric Bellegarde (gnumdk) wrote :

Same issue here with meizu mx4 and ota6.

In the train and while driving.

When issue happens, icons for data and signal hang on last connexion values.

Switching plane mode on/off fix the issue.

Happens every days for me.

Cédric Bellegarde (gnumdk) wrote :

Happen today... Switching plane mode on/off doesn't fix issue.

Cédric Bellegarde (gnumdk) wrote :
Cédric Bellegarde (gnumdk) wrote :
Cédric Bellegarde (gnumdk) wrote :

I think the main issue here is list-modems... A have a FAKE modem!!

Cédric Bellegarde (gnumdk) wrote :
Download full text (317.0 KiB)

Here the ofono crash

root@ubuntu-phablet:/var/log/upstart# cat /var/crash/_usr_sbin_ofonod.0.crash
ProblemType: Crash
Architecture: armhf
CrashCounter: 1
Date: Tue Sep 8 08:05:43 2015
DistroRelease: Ubuntu 15.04
ExecutablePath: /usr/sbin/ofonod
ExecutableTimestamp: 1437728295
ProcCmdline: ofonod -P stktest,provision,sap,udev,dun,smart,hfp
ProcCwd: /
ProcEnviron:
 PATH=(custom, no user)
 TERM=linux
ProcMaps:
 00010000-000ed000 r-xp 00000000 b3:0e 85820 /usr/sbin/ofonod
 000fd000-000fe000 r--p 000dd000 b3:0e 85820 /usr/sbin/ofonod
 000fe000-00109000 rw-p 000de000 b3:0e 85820 /usr/sbin/ofonod
 00109000-0010e000 rw-p 00000000 00:00 0
 00bac000-00bcd000 rw-p 00000000 00:00 0 [heap]
 00bcd000-00beb000 rw-p 00000000 00:00 0 [heap]
 b6c00000-b6c02000 r-xp 00000000 b3:0e 121013 /usr/lib/arm-linux-gnueabihf/gconv/UTF-16.so
 b6c02000-b6c12000 ---p 00002000 b3:0e 121013 /usr/lib/arm-linux-gnueabihf/gconv/UTF-16.so
 b6c12000-b6c13000 r--p 00002000 b3:0e 121013 /usr/lib/arm-linux-gnueabihf/gconv/UTF-16.so
 b6c13000-b6c14000 rw-p 00003000 b3:0e 121013 /usr/lib/arm-linux-gnueabihf/gconv/UTF-16.so
 b6c14000-b6c5e000 r-xp 00000000 b3:0e 70540 /lib/arm-linux-gnueabihf/libpcre.so.3.13.1
 b6c5e000-b6c6d000 ---p 0004a000 b3:0e 70540 /lib/arm-linux-gnueabihf/libpcre.so.3.13.1
 b6c6d000-b6c6e000 r--p 00049000 b3:0e 70540 /lib/arm-linux-gnueabihf/libpcre.so.3.13.1
 b6c6e000-b6c6f000 rw-p 0004a000 b3:0e 70540 /lib/arm-linux-gnueabihf/libpcre.so.3.13.1
 b6c6f000-b6c7f000 r-xp 00000000 b3:0e 70782 /lib/arm-linux-gnueabihf/libpthread-2.21.so
 b6c7f000-b6c80000 r--p 00010000 b3:0e 70782 /lib/arm-linux-gnueabihf/libpthread-2.21.so
 b6c80000-b6c81000 rw-p 00011000 b3:0e 70782 /lib/arm-linux-gnueabihf/libpthread-2.21.so
 b6c81000-b6c83000 rw-p 00000000 00:00 0
 b6c83000-b6d5c000 r-xp 00000000 b3:0e 70822 /lib/arm-linux-gnueabihf/libc-2.21.so
 b6d5c000-b6d6b000 ---p 000d9000 b3:0e 70822 /lib/arm-linux-gnueabihf/libc-2.21.so
 b6d6b000-b6d6d000 r--p 000d8000 b3:0e 70822 /lib/arm-linux-gnueabihf/libc-2.21.so
 b6d6d000-b6d6e000 rw-p 000da000 b3:0e 70822 /lib/arm-linux-gnueabihf/libc-2.21.so
 b6d6e000-b6d71000 rw-p 00000000 00:00 0
 b6d71000-b6d73000 r-xp 00000000 b3:0e 70895 /lib/arm-linux-gnueabihf/libdl-2.21.so
 b6d73000-b6d82000 ---p 00002000 b3:0e 70895 /lib/arm-linux-gnueabihf/libdl-2.21.so
 b6d82000-b6d83000 r--p 00001000 b3:0e 70895 /lib/arm-linux-gnueabihf/libdl-2.21.so
 b6d83000-b6d84000 rw-p 00002000 b3:0e 70895 /lib/arm-linux-gnueabihf/libdl-2.21.so
 b6d84000-b6dae000 r-xp 00000000 b3:0e 70897 /lib/arm-linux-gnueabihf/libdbus-1.so.3.8.9
 b6dae000-b6dbd000 ---p 0002a000 b3:0e 70897 /lib/arm-linux-gnueabihf/libdbus-1.so.3.8.9
 b6dbd000-b6dbe000 r--p 00029000 b3:0e 70897 /lib/arm-linux-gnueabihf/libdbus-1.so.3.8.9
 b6dbe000-b6dbf000 rw-p 0002a000 b3:0e 70897 /lib/arm-linux-gnueabihf/libdbus-1.so.3.8.9
 b6dbf000-b6e84000 r-xp 00000000 b3:0e 70824 /lib/arm-linux-gnueabihf/libglib-2.0.so.0.4400.1
 b6e84000-b6e93000 ---p 000c5000 b3:0e 70824 /lib/arm-linux-gnueabihf/libglib-2.0.so.0.4400.1
 b6e93000-b6e94000 r--p 000c40...

Cédric Bellegarde (gnumdk) wrote :
Kevin Macphail (kevie) wrote :

I'm noticing that this bug is a few months old, however since the OTA-8 update it has become significantly worse for me. I'm using a BQ phone E5HD model and I'm in an area with generally patchy coverage. I get reasonable coverage at my house and very good coverage at my place of work, however the coverage on route is poor, often losing signal completely. Every time I reach work or home I have signal and can send/receive both sms and phone calls, however the data signal does not return. Puling down on the signal tells me that I have signal and 3G, but on the top of the screen the data connection is nil (completely blank in the wi-fi shape). I have tried leaving the phone to see if the data comes back on, but the only way to get it is to switch into airplane mode and then switch it off again or rebooting the phone. This happens to me about 3-4 times a day which is incredibly frustrating.

I do not normally like posting on old threads, however this bug is affecting me, it was posted in February, it is now December and is still rated as incomplete/undecided.

Please let me know if there is any more details that I could post to help improve information about this bug.

Kevin Macphail (kevie) wrote :

As I said in the previous post, this happens multiple times a day. I've attached a screenshot showing that a data is available and detected, but not connected.

Kazord (kazord) wrote :

have the probleme too, though it was orange/free probleme (as i'm free user with orange roaming)
home -> work, connection drop
work -> home, same

having mx4 lastest patch, french free carrier

H (deflektor) wrote :

Hi all!

I experience this problem every day. Cellphone connections is great but data is not available, although within the cellphone settings I can see the Edge symbol. On top bar the data indicator is left empty.

Putting the phone in flight mode, and back solves the problem.

Latest release - on Meizu Mx4.

Benediktus Olschok (dixman) wrote :

Hi,

my phone is affected by exactly the same problem as described by H(deflector). Probably since the last update. Aqaris EQ4.5 20160524.1.

Greetings,
Benediktus

Josué (j2g2rp) wrote :

sometimes it happens to me, it loses the connection (in the top bar icons appear like connected), but if I try to access to network (webbrowser, ping etc) I haven't any access.
What do you need to track the bug?
In my case the phone is bq 4.5 ubuntu edition with OTA 11.

H (deflektor) wrote :

Found following solution working on OTA-12:

Within Terminal:
/usr/share/ofono/scripts
./test-network-registration /ril_0 default

Switches back to hsdpa if available without disconnection from the network.

Testing with
ping 8.8.8.8

If there is no reply the network manager service hangs, then following solves the problem
sudo service network-manager restart

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers