1814:0301 RT2x00/rt61pci disconnects since update to 15.04

Bug #1393744 reported by plucky on 2014-11-18
90
This bug affects 17 people
Affects Status Importance Assigned to Milestone
network-manager (Ubuntu)
Medium
Unassigned

Bug Description

lsb_release -rd :Description: Ubuntu Vivid Vervet (development branch)
                             Release: 15.04

wi-fi disconnects and unable to reconnect since updates on 13-11-2014.

Also affects Lubuntu 15.04 on same machine.

Ubuntu 12.04.1 on same machine does not disconnect.

ProblemType: Bug
DistroRelease: Ubuntu 15.04
Package: network-manager 0.9.8.8-0ubuntu34
ProcVersionSignature: Ubuntu 3.16.0-24.32-generic 3.16.4
Uname: Linux 3.16.0-24-generic i686
ApportVersion: 2.14.7-0ubuntu10
Architecture: i386
CurrentDesktop: XFCE
Date: Tue Nov 18 11:12:23 2014
IfupdownConfig:
 # interfaces(5) file used by ifup(8) and ifdown(8)
 auto lo
 iface lo inet loopback
InstallationDate: Installed on 2014-01-14 (307 days ago)
InstallationMedia: Xubuntu 14.04 LTS "Trusty Tahr" - Alpha i386 (20140114)
IpRoute:

RfKill:
 0: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: no
SourcePackage: network-manager
UpgradeStatus: No upgrade log present (probably fresh install)
nmcli-con:
 NAME UUID TYPE TIMESTAMP TIMESTAMP-REAL AUTOCONNECT READONLY DBUS-PATH
 Petersberg d473a136-74dc-4695-aac3-1fffc9cc8095 802-11-wireless 1416308390 Tue 18 Nov 2014 10:59:50 GMT yes no /org/freedesktop/NetworkManager/Settings/2
 BTWifi-with-FON a2b63b98-159a-49f4-9247-d46a0d67ed41 802-11-wireless 0 never yes no /org/freedesktop/NetworkManager/Settings/1
 Petersberg 1 4fc01379-d340-479e-a016-9af1ab717c83 802-11-wireless 1416303120 Tue 18 Nov 2014 09:32:00 GMT yes no /org/freedesktop/NetworkManager/Settings/0
nmcli-dev:
 DEVICE TYPE STATE DBUS-PATH
 wlan0 802-11-wireless disconnected /org/freedesktop/NetworkManager/Devices/0
nmcli-nm:
 RUNNING VERSION STATE NET-ENABLED WIFI-HARDWARE WIFI WWAN-HARDWARE WWAN
 running 0.9.8.8 disconnected enabled enabled enabled enabled disabled
---
ApportVersion: 2.14.7-0ubuntu10
Architecture: i386
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: peter 1938 F.... pulseaudio
CurrentDesktop: XFCE
DistroRelease: Ubuntu 15.04
HibernationDevice: RESUME=UUID=ffe4c76c-645c-4847-ba8c-b2323517a10f
InstallationDate: Installed on 2014-01-14 (318 days ago)
InstallationMedia: Xubuntu 14.04 LTS "Trusty Tahr" - Alpha i386 (20140114)
MachineType: VIA Technologies, Inc. VT8363
Package: linux (not installed)
ProcFB: 0 nouveaufb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.16.0-25-generic root=UUID=ed3144cc-8873-40a1-9670-bb2bfc9190a5 ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 3.16.0-25.33-generic 3.16.7
RelatedPackageVersions:
 linux-restricted-modules-3.16.0-25-generic N/A
 linux-backports-modules-3.16.0-25-generic N/A
 linux-firmware 1.138
Tags: vivid
Uname: Linux 3.16.0-25-generic i686
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
_MarkForUpload: True
dmi.bios.date: 08/01/2000
dmi.bios.vendor: Award Software International, Inc.
dmi.bios.version: 6.00 PG
dmi.board.name: 8363-686A
dmi.chassis.type: 3
dmi.modalias: dmi:bvnAwardSoftwareInternational,Inc.:bvr6.00PG:bd08/01/2000:svnVIATechnologies,Inc.:pnVT8363:pvr:rvn:rn8363-686A:rvr:cvn:ct3:cvr:
dmi.product.name: VT8363
dmi.sys.vendor: VIA Technologies, Inc.

plucky (pwlmail) wrote :

plucky, thank you for taking the time to report this bug and helping to make Ubuntu better. Please execute the following command, as it will automatically gather debugging information, in a terminal:
apport-collect 1393744

affects: network-manager (Ubuntu) → linux (Ubuntu)
Changed in linux (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
plucky (pwlmail) wrote : AlsaInfo.txt

apport information

tags: added: apport-collected
description: updated

apport information

plucky (pwlmail) wrote : CRDA.txt

apport information

apport information

plucky (pwlmail) wrote : IwConfig.txt

apport information

plucky (pwlmail) wrote : Lspci.txt

apport information

plucky (pwlmail) wrote : Lsusb.txt

apport information

apport information

apport information

apport information

apport information

apport information

plucky (pwlmail) wrote : RfKill.txt

apport information

plucky (pwlmail) wrote : UdevDb.txt

apport information

plucky (pwlmail) wrote : UdevLog.txt

apport information

apport information

Hope this is ok.Wi-fi disconnected first time I ran apport-collect so I had to connect using a USB wi-fi adapter which I use to install updates.The USb adapter does not disconnect.

plucky, could you please test the latest upstream kernel available from the very top line at the top of the page (the release names are irrelevant for testing, and please do not test the daily folder) following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional upstream developers to examine the issue.

If the test did not allow you to test to the issue (ex. you couldn't boot into the OS) please make a comment in your report about this, and continue to test the next most recent kernel version until you can test to the issue. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested. If this bug is fixed in the mainline kernel, please add the following tags:
kernel-fixed-upstream
kernel-fixed-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested exactly shown as:
kernel-fixed-upstream-3.18-rc6

This can be done by clicking on the yellow circle with a black pencil icon next to the word Tags located at the bottom of the bug description.

If the mainline kernel does not fix this bug, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-VERSION-NUMBER

Once testing of the upstream kernel is complete, please mark this bug's Status as Confirmed. Please let us know your results. Thank you for your understanding.

summary: - RT2x00/rt61pci disconnects since update on13-11-2014 for 15.04
+ 1814:0301 RT2x00/rt61pci disconnects since update to 15.04
Changed in linux (Ubuntu):
importance: Low → Medium
plucky (pwlmail) on 2014-11-30
tags: added: kernel-bug-exists-upstream-3.18.0-031800rc6-generic-
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
plucky (pwlmail) wrote :

Installed latest kernel as requested linux-image-3.18.0-031800rc6-generic_3.18.0-031800rc6.201411231935_i386.deb
The linux-headers failed to install due to dependency errors.
The wireless again disconnected whilst using the new kernel

uname -a
Linux Xub-Vivid 3.18.0-031800rc6-generic #201411231935 SMP Mon Nov 24 00:57:52 UTC 2014 i686 athlon i686 GNU/Linux

plucky, if you boot into a kernel from prior to the upgrade, does the issue stop?

tags: added: kernel-bug-exists-upstream-3.18-rc6
removed: kernel-bug-exists-upstream-3.18.0-031800rc6-generic-
tags: added: kernel-bug-exists-upstream
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
plucky (pwlmail) wrote :

Booted into 3.16.0-24-generic which was the kernel before the current kernel and problem occurred, the wi-fi disconnected.

This problems started the day after updates were run on 13th November 2014 when the wi-fi disconnection started.

I don't think it is a kernel problem.

Added dmesg.txt

plucky, for userspace regression testing purposes, could you please test http://releases.ubuntu.com/utopic/ (live environment is fine) and advise to the results?

plucky (pwlmail) wrote :

This is my test machine and is not powerful enough to run Ubuntu 14.10 as it will not support compiz.

It will however run Xubuntu 14.10 and Lubuntu 14.10 and it has done so for the last six months until this problem with the wi-fi cropped up on the 14th November using 15.04. I can however re-install Xubuntu 14.10 if required.

It also has the same problem with Lubuntu 15.04,but it doesn't have the problem with Ubuntu 12.04 all on a triple boot on this system.

What further testing would you like me to do?

Installing Ubuntu 14.10 is not an option.

tags: added: regression-release

plucky, no need to do a reinstall at this point. What was needed was information regarding which release did the regression occur between. Given that the issue didn't occur in Utopic, but did in Vivid, this has been identified.

According to https://launchpad.net/ubuntu/+source/network-manager given how going from Utopic to Vivid didn't change the version of network-manager, but only the downstream (Ubuntu) patches changed, this would appear to be a downstream issue versus an upstream one. However, I'll let a developer make the determining call.

Thank you for your understanding.

affects: linux (Ubuntu) → network-manager (Ubuntu)
Changed in network-manager (Ubuntu):
status: Incomplete → Triaged
grabaldam (grabaldam) wrote :

I have a device that uses rt61pci and when it manages to connect to a WiFi network, it stops working after a few seconds only.

Relevant line from lspci:
05:00.0 Network controller: Ralink corp. RT2600 802.11 MIMO

Relevant output from dmesg:
ieee80211 phy0: rt2x00queue_flush_queue: Warning - Queue 0 failed to flush
ieee80211 phy0: rt2x00queue_flush_queue: Warning - Queue 2 failed to flush

Do you guys still need a test on utopic live cd to see if it works fine?

PS: device works fine under Windows, so it's not a hardware issue on my side.

grabaldam (grabaldam) wrote :

Working all good on Ubuntu 14.10 livecd.

Still having those things from dmesg:
ieee80211 phy0: rt2x00queue_flush_queue: Warning - Queue 0 failed to flush
ieee80211 phy0: rt2x00queue_flush_queue: Warning - Queue 2 failed to flush

But the thing has stayed connected to a WiFi network for a good 30++mn with no issues.

Lagopus (sauli-sarre) wrote :

I made some testing with this problem and I wrote script to enable rt61pci wifi connection temporarily.:
rmmod -v rt61pci
rmmod -v rt2x00mmio
rmmod -v rt2x00pci
rmmod -v rt2x00lib
sleep 1
modprobe -v rt61pci nohwcrypt=y

After I ran that script is started pinging some random host for awhile and connection stayed up as long as ping was running. After I stopped pinging, wifi disconnected in 1-2 minutes and couldn't connect any more.

One line in syslog was interesting:
kernel: [ 4129.010595] ieee80211 phy6: wlan0: No probe response from AP 02:1a:11:fe:c8:19 after 500ms, disconnecting.

Linux lagopus 3.19.0-15-generic #15-Ubuntu SMP Thu Apr 16 23:32:37 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

modprobe -v rt61pci nohwcrypt=y did the job for me...

seems to be quite stable now..

I'm still testing is the connection keeps running.

bad news...
even with these commands, the connection is rather unstable...

John Erling Blad (jeblad) wrote :

Same problem here. Some notes about what happen.
Sorry for not providing complete logs.
This is my notes which is not very readable, not even for me.. :)

The machine has been continuously updated since 13.10.
Updated from 14.04 to 15.04 by going through 14.10.
All done yesterday. Problem detected when arriving at 15.04.

Usually either a
1: ... rt2x00queue_write_tx_frame: Error - Arrived at non-free entry in the non-full queue 0.
2: ... rt2x00mmio_regbusy_read() Indirect register access failed: offset=0x0000308c, value=0x00010400
  this is followed by: ieee80211 phy0: wlan0: No probe response from AP .... after 500ms, disconnecting
3: ... rt2x00queue_flush_queue: Warning - Queue 0 failed to flush

After turning on nohwcrypt error 1 went away, and was replaced by 2 and 3.
With nohwcrypt turned off I got 2 and then 3, leading to a time out.

1 alone gives failing network

2 and 3, or 3 alone, later gives
... authenticate with ...
... direct probe to ... (try 1/3)
... direct probe to ... (try 2/3)
... direct probe to ... (try 3/3)
... authentication with ... timed out

and then network fails

$ lspci | fgrep 'Ralink'
03:07.0 Network controller: Ralink corp. RT2561/RT61 802.11.g PCI

Some additional info
  Chipset detected - rt: 2661, rf: 0003, rev: 000b
  Selected rate control algorithm 'minstrel_ht'
  Firmware .. 0.8

It ia an AMD triple core proc

$ uname -a
Linux hydra 3.19.0-17-generic #17-Ubuntu SMP Wed May 6 16:46:12 UTC 2015 x86-64 x86_64 x86_64 GNU/Linux

Just to verify that the module is in fact the latest one. I've compiled them at one point so just to make sure they are provided by the distro.

$ cat /sys/module/rt2x00*/version
2.3.0 (reported three times)

John Erling Blad (jeblad) wrote :

An other computer is connected through the same wifi extender, and that too uses Ubuntu 15.04. This computer reports "Intel(R) Centrino(R) Wireless-N 2230 BGN, REV=0xC8". There is no similar error reports in dmsg on this machine.

mhotze (m-hotze) wrote :

Having the same issue here as well (although I'm on Arch with 3.16 kernel). Interestingly, on the same computer running Mint (3.13 kernel), there is no issue. With 3.16 kernel, RT61PCI works for some minutes, then disconnects, and unable to reconnect again.

Note: both distro's use version 2.3.0 of RT61PCI.

dmesg on 3.16 kernel:
ieee80211 phy0: rt2x00queue_flush_queue: Warning - Queue 0 failed to flush

mhotze (m-hotze) wrote :

Update: did some regression testing;
- fallback to 3.14 kernel but using same version of network-manager and wifi drivers did not solve the issue
- removed network-manager package, and used netctl for managing wifi, and the problem is gone

Tino (tino-a) wrote :

Same here: Removing network-manager and using plain wpa_supplicant commands lead to perfectly stable wifi.

Petr Šplíchal (psss) wrote :

It seems that turning off wlan0 power management can help. I'm
using the following command as a temporary workaround:

    sudo iwconfig wlan0 power off

As restoring the kernel/driver does not fix the issue, could the
problem be that NetworkManager incorrectly sets up the interface?

James Stone (jamesmstone) wrote :

I can confirm that removing network-manager and using plain wpa_supplicant fixes this problem.

mike (mike5346874) wrote :

sigh, it's still broken.
It still behaves the same way...

Changed in network-manager (Ubuntu):
status: Triaged → Confirmed
mike (mike5346874) wrote :

If some one wants to post a workaround?

mike (mike5346874) wrote :

In 2017

It seams there's some problem with network-manager and also power management in the driver.

Workaround:

Don't use network-manager. I'm using trinity, with out network-manager.

I also deactivated power management for wifi, and it works correctly.

sudo nano /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf

change "wifi.powersave = 3" to "wifi.powersave = 2"

don't forget to save :P

.... then restart the network, or just reboot.

To post a comment you must log in.