[arale/krillin] Toggling wifi on/off causes media playback to hiccup

Bug #1388201 reported by Jim Hodapp on 2014-10-31
40
This bug affects 10 people
Affects Status Importance Assigned to Milestone
Canonical System Image
Undecided
Unassigned
Network Menu
Invalid
High
Unassigned
network-manager (Ubuntu)
Medium
Unassigned

Bug Description

1. Play a song with music-app
2. Switch wifi off, notice that music-app playback pauses for a moment
3. Switch wifi on, notice that music-app playback pauses for a moment
4. Watch the CPU usage with top while toggling wifi and notice that the usage spikes to 100%

Expected results:

Music or video keeps playing without pausing while toggling wifi on/off

Jussi Pakkanen (jpakkane) wrote :

The same bug was filed a long time ago. Because this bug can be reproduced without touching indicator-network (by sending the wifi disable commands from the command line) it was reassigned, but I can't for the life of me find what project it was assigned to.

I would assign this bug as a duplicate of that one, but as I can't find it now I'm just going to close this. If you can find a sequence of steps where this occurs only when doing the toggle in indicator-network but not when doing the same from the command line, feel free to reopen.

Changed in indicator-network:
status: New → Invalid
Jim Hodapp (jhodapp) wrote :

I would like to make sure that this is still assigned in a different project and still planned on being fixed. Can you think of someone else to ask who might know where this bug report actually lives?

Jim Hodapp (jhodapp) wrote :

I got this bug filed in the appropriate place now.

Matthew Paul Thomas (mpt) wrote :

I found it.

Pete Woods (pete-woods) wrote :
Changed in indicator-network:
importance: Undecided → High
Changed in network-manager (Ubuntu):
importance: Undecided → High
Simos Xenitellis  (simosx) wrote :

There are more details in the duplicate #1447077.

Pete Woods (pete-woods) on 2015-08-20
Changed in canonical-devices-system-image:
status: New → Confirmed
Changed in network-manager (Ubuntu):
importance: High → Medium
Tony Espy (awe) on 2015-08-21
Changed in network-manager (Ubuntu):
status: New → Incomplete
Tony Espy (awe) wrote :

This bug is specific to arale, krillin, and most likely vegatta ( although as I don't have once, I haven't been able to test ). It's related to the fact that on devices using MTK's Wi-Fi driver, we're forced to use hybris for power control of the Wi-Fi radios. This leverages the Android HAL functions wifi_load/unload_driver(). On systems configured without kernel modules, this results in a driver command to start/stop Wi-Fi ( this is accomplished by writing the string "0" or "1" to the character device ( /dev/wmtWiFi ).

I just checked mako ( rc-proposed, #222 ) and no stuttering occurs when Wi-Fi is enabled or disabled.

Also re-checked arale ( rc-proposed, #88 ) and krillin ( rc-proposed, #104 ) and both still skip/stutter when Wi-Fi is toggled.

Bug #1487529 reported for arale.

summary: - Toggling wifi on/off causes media playback to hiccup
+ [arale/krillin] Toggling wifi on/off causes media playback to hiccup
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers