network manager disconnects and cannot reconnect after update

Bug #138442 reported by Anish Bhatt on 2007-09-09
4
Affects Status Importance Assigned to Milestone
network-manager (Ubuntu)
Undecided
josevillavi85

Bug Description

Binary package hint: network-manager

after a few minutes, network manager keeps disconnecting and cannot reconnect without a restart. it used to disconnect before, but frequency has drastically increased after update on the 7th of september. I have the intel 495 card.

tried using the live cd snapshot from 8th september, network manager simply refuses to connect although earlier live cd's had no problem connecting.

Alexander Sack (asac) wrote :

Thanks for your report,

could you please restart your system, try to connect and attach parts of your /var/log/syslog that covers the timespan starting with boot and ending when network manager gives up?

 - Alexander

Changed in network-manager:
status: New → Incomplete
Alexander Sack (asac) wrote :

can you test this on latest gutsy please?

Anish Bhatt (anish7) wrote :

Still unable to connect to a wireless network that i had no problems with in earlier releases. Will try to test the reconnection part today, and give a syslog output. Will also check if the install makes a difference. Among other weirdness, connecting an ethernet cable causes half the wireless networks to disappear. Did connect to an unsecured network though, maybe its a wpa_supplicant problem ?

Alexander Sack (asac) wrote :

please test the wpasupplicant package available here:

http://ppa.launchpad.net/asac/ubuntu/pool/main/w/wpasupplicant/

Anish Bhatt (anish7) wrote :

syslog output as follows, trying the newer wpa_supplicant after this

Anish Bhatt (anish7) wrote :

same problem after updating wpa_supplicant, syslog output pretty much the same.

Please note, with the live cd for the past week or so, I am no longer able to connect in the first place, so this the syslog output I get when I try to connect to my wireless network, and NOT when it disconnects. Maybe it should be a new bug ?

Alexander Sack (asac) wrote :

is your applet running?

Anish Bhatt (anish7) wrote :

This might be a really stupid question, but how do I check that ? I never had to explicitly get it running in the previous gutsy releases, so I assumed that it is.

On Mon, Sep 24, 2007 at 04:13:39PM -0000, anish wrote:
> This might be a really stupid question, but how do I check that ? I
> never had to explicitly get it running in the previous gutsy releases,
> so I assumed that it is.
>

in terminal try:

ps -eaf | grep nm-applet

if a process is found its still running.

 - Alexander

josevillavi85 (josevillavi85) wrote :

hi, i was having the same problem, i tried a lot of things, and only thing that works, was to remove network-manager

I thought this output from dmsg command was something important, but not:

ath1: no IPv6 routers present
Failure registering capabilities with primary security module.

but another output, i dont remember exactly the output, but it said:

networkmanager disabled the card

or something like that, and it said that i disabled it, but that is not true.

So then i remove NM and yeahhh, my wireless had not fall in 2 days, before it tooks less than a day.

Now, i am gonna describe my laptop:

its a XPS M1330 with an Intel PRO/Wireless 3945ABG

and i connect to a Dlink DIR-365

I havent tested it with other kind of router, so i can not confirm if it is just with this router.

I hope this help, if you need some other info, pleasse ask.

Thanks a lot for your support.

josevillavi85 (josevillavi85) wrote :

I must confirm this issue, cause removing network-manager solve the problem.

Changed in network-manager:
status: Incomplete → Confirmed
josevillavi85 (josevillavi85) wrote :

I confirmed this bug, and I said that disabling networkmanager was te solution, but i was FAULT. Hopefully for those that have this problem, the solution is to download the new intel iwlwifi drivers. Just follow this instructions

 http://intellinuxwireless.org/?p=iwlwifi&n=howto-iwlwifi

In the page says that you do not need to remove the ipw3945 drivers, but i did it cause that driver was still assigned to my card, an not the new ones.

My machine has:
Intel Pro Wireless 3945ABG

After follow the instructions, i am using:
iwlwifi-3945-ucode-2.14.4
iwlwifi-1.2.0

Hope in a kernel update packagers include the new drivers, cause that was a big problem.

Changed in network-manager:
status: Confirmed → Invalid
assignee: nobody → josevillavi85
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers