wifi becomes unstable upgrading from ubuntu 12.04 to ubuntu 14.04

Bug #1374863 reported by paolode on 2014-09-27
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
network-manager (Ubuntu)
Undecided
Unassigned

Bug Description

wifi becomes unstable upgrading from ubuntu 12.04 to ubuntu 14.04 for many users using intel wifi card (as described in thid thread: http://forum.ubuntu-it.org/viewtopic.php?p=4587552), maybe a driver/kernel issue.

slved via:
sudo modprobe -rv iwl3945
sudo modprobe -v iwl3945 swcrypto=1
cat /etc/hosts
sudo rmmod iwl3945
sudo modprobe iwl3945

Intel signaled a previous problem of compatibility between driver and some kernels.

I updated recently from ubuntu 12.04 to xubuntu 14.04. the problem didn't existed when I updated via 'update-manager -d', but appeared when I reinstalled new xubuntu from live dvd.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: network-manager 0.9.8.8-0ubuntu7 [modified: usr/bin/nm-online usr/bin/nm-tool usr/bin/nmcli usr/lib/NetworkManager/nm-avahi-autoipd.action usr/lib/NetworkManager/nm-dhcp-client.action usr/lib/NetworkManager/nm-dispatcher.action usr/sbin/NetworkManager]
ProcVersionSignature: Ubuntu 3.13.0-35.62-generic 3.13.11.6
Uname: Linux 3.13.0-35-generic x86_64
ApportVersion: 2.14.1-0ubuntu3.4
Architecture: amd64
CurrentDesktop: XFCE
Date: Sat Sep 27 23:47:32 2014
IfupdownConfig:
 # interfaces(5) file used by ifup(8) and ifdown(8)
 auto lo
 iface lo inet loopback
InstallationDate: Installed on 2014-09-12 (15 days ago)
InstallationMedia: Xubuntu 14.04 LTS "Trusty Tahr" - Alpha amd64 (20140310)
IpRoute:
 default via 192.168.1.254 dev wlan0 proto static
 192.168.1.0/24 dev wlan0 proto kernel scope link src 192.168.1.128 metric 9
NetworkManager.state:
 [main]
 NetworkingEnabled=true
 WirelessEnabled=true
 WWANEnabled=true
 WimaxEnabled=true
SourcePackage: network-manager
UpgradeStatus: No upgrade log present (probably fresh install)
nmcli-con:
 NAME UUID TYPE TIMESTAMP TIMESTAMP-REAL AUTOCONNECT READONLY DBUS-PATH
 Connessione via cavo 1 b4fb3004-8943-4f93-818b-eaa081e97aa6 802-3-ethernet 1411820971 sab 27 set 2014 14:29:31 CEST yes no /org/freedesktop/NetworkManager/Settings/1
 FASTWEB-1-zMohBACjWHjt fad5a9fd-124b-49d1-a0e1-11f0f0b17f67 802-11-wireless 1411854271 sab 27 set 2014 23:44:31 CEST yes no /org/freedesktop/NetworkManager/Settings/0
nmcli-dev:
 DEVICE TYPE STATE DBUS-PATH
 eth0 802-3-ethernet unavailable /org/freedesktop/NetworkManager/Devices/1
 wlan0 802-11-wireless connected /org/freedesktop/NetworkManager/Devices/0
nmcli-nm:
 RUNNING VERSION STATE NET-ENABLED WIFI-HARDWARE WIFI WWAN-HARDWARE WWAN
 running 0.9.8.8 connected enabled enabled enabled enabled disabled

paolode (paolo-debortoli) wrote :
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers