wifi no longer works in 14.04 after upgrade from 13.10

Bug #1374689 reported by George Ingram on 2014-09-27
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
network-manager (Ubuntu)
Undecided
Unassigned

Bug Description

wifi worked briefly after upgrade to 14.04, but died. The wifi icon has also disappeared from the system tray. Using the preferences network settings window can't achieve anything
In previous releases, it would always wait with something like 'network configuration not found' then waiting 60 more seconds' I've been zoning through it for 18 monhts so o can't remember exact wording.
the wifi would come up with sudo service network-manager restart, which I eventually put in rc.local.
I really don't fancy reinstalling 13.10 as it's a pentiumM system and the process is tedious to say the least.

in 14.04. I cannot get wifi to function at all

pictsidhe@X40:~$ /etc/init.d/wpasupplicant start
bash: /etc/init.d/wpasupplicant: No such file or directory
pictsidhe@X40:~$ iwlist scan
irda0 Interface doesn't support scanning.

Description: Ubuntu 14.04.1 LTS
Release: 14.04

lo Interface doesn't support scanning.

eth0 Interface doesn't support scanning.

eth1 No scan results

pictsidhe@X40:~$ iwconfig
irda0 no wireless extensions.

lo no wireless extensions.

eth0 no wireless extensions.

eth1 IEEE 802.11bg ESSID:off/any
          Mode:Managed Channel:0 Access Point: Not-Associated
          Bit Rate:0 kb/s Tx-Power=20 dBm Sensitivity=8/0
          Retry limit:7 RTS thr:off Fragment thr:off
          Power Management:on
          Link Quality:0 Signal level:0 Noise level:0
          Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
          Tx excessive retries:0 Invalid misc:0 Missed beacon:0

/etc/network/interfaces

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
auto eth0
iface eth0 inet dhcp

I tried it with eth1 entries in addition to eth0 and instead of but no change

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: ubuntu-release-upgrader-core 1:0.220.5
ProcVersionSignature: Ubuntu 3.13.0-36.63-generic 3.13.11.6
Uname: Linux 3.13.0-36-generic i686
ApportVersion: 2.14.1-0ubuntu3.4
Architecture: i386
CrashDB: ubuntu
CurrentDesktop: LXDE
Date: Sat Sep 27 06:20:43 2014
PackageArchitecture: all
SourcePackage: ubuntu-release-upgrader
Symptom: dist-upgrade
UpgradeStatus: Upgraded to trusty on 2014-09-27 (0 days ago)

George Ingram (pictsidhe) wrote :
George Ingram (pictsidhe) wrote :

And for reasons that elude me, it's come back to life. I'd been using ethernet as a temporary measure. It decided to connect wifi at some point. Wifi has been rock solid in 13.10, as long as I had sudo service network-manager restart in rc.local. Which is still there.

affects: ubuntu-release-upgrader (Ubuntu) → network-manager (Ubuntu)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers