3G gets enabled on returning from Flight mode

Bug #1349871 reported by Omer Akram on 2014-07-29
This bug affects 2 people
Affects Status Importance Assigned to Milestone
network-manager (Ubuntu)
ofono (Ubuntu)
Alfonso Sanchez-Beato
ubuntu-system-settings (Ubuntu)

Bug Description

Most probably I have selected the wrong package.

1. disable 3G
2. switch to flight mode
3. switch off flight mode

What happens:
3G gets enabled automatically

ProblemType: Bug
DistroRelease: Ubuntu 14.10
Package: ubuntu-system-settings 0.3+14.10.20140725.4-0ubuntu1
Uname: Linux 3.4.0-5-mako armv7l
ApportVersion: 2.14.4-0ubuntu2
Architecture: armhf
Date: Tue Jul 29 19:08:28 2014
InstallationDate: Installed on 2014-07-29 (0 days ago)
InstallationMedia: Ubuntu Utopic Unicorn (development branch) - armhf (20140729-052958)
SourcePackage: ubuntu-system-settings
UpgradeStatus: No upgrade log present (probably fresh install)

Omer Akram (om26er) wrote :
Tony Espy (awe) on 2014-07-31
Changed in ubuntu-system-settings (Ubuntu):
status: New → Confirmed
Tony Espy (awe) wrote :

I actually find this to be intermittent, sometimes it fails, sometimes it works.

I also tried disabling and rebooting, and it worked fine ( ie. 3g was still disabled ).

When it comes back and reports that 3g is still enabled, ofono's RadioSettings 'TechnologyPreference' property is set to "any", as opposed to "gsm". Looking at the ofono rilmodem radio-settings code this shouldn't happen. This *may* be an ofono bug, but can't tell without more testing.

Changed in ubuntu-system-settings (Ubuntu):
importance: Undecided → High
Changed in ofono (Ubuntu):
assignee: nobody → Alfonso Sanchez-Beato (alfonsosanchezbeato)

I can easily reproduce the problem following Omer's steps (mako).

Some debugging in ofono shows that org.ofono.ConnectionManager.Powered property is being set from NetworkManager after flight modem is switched off, so this is not an ofono bug (Powered property is 0 right after onlining the modem when switching off flight mode).

Also, if we stop network-manager upstart job after setting flight mode, and then switch off flight mode, org.ofono.ConnectionManager.Powered value will be 0.

Changed in ofono (Ubuntu):
status: New → Invalid
no longer affects: ubuntu-system-settings
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in network-manager (Ubuntu):
status: New → Confirmed
Tony Espy (awe) on 2014-08-05
Changed in network-manager (Ubuntu):
importance: Undecided → High
assignee: nobody → Mathieu Trudel-Lapierre (mathieu-tl)
Tony Espy (awe) wrote :

ubuntu-system-settings isn't really involved here, so marking the task as Invalid.

Changed in ubuntu-system-settings (Ubuntu):
status: Confirmed → Invalid

I think we fixed this a long time ago with urfkill, unassigning myself (though this should still be confirmed).

Changed in network-manager (Ubuntu):
assignee: Mathieu Trudel-Lapierre (mathieu-tl) → nobody
Aron Xu (happyaron) on 2016-12-20
tags: added: nm-touch
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers