Network manager stopped scanning for wifi networks

Bug #1332904 reported by Dima Ryazanov on 2014-06-22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
network-manager (Ubuntu)

Bug Description

After I resumed my laptop from suspend, it would not connect to wifi. For a while, it seemed confused about its connection state, then it displayed "disconnected", and showed that there were no wifi networks available (which is not true).

To debug the problem, I ran "nmcli d wifi list", which showed no results.
Then I ran "iwlist scan", which also showed no results.
Then I tried "sudo iwlist scan" - which showed all the wifi networks, and actually caused the network manager to start working again. It connected to a network successfully, and so on.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: network-manager
ProcVersionSignature: Ubuntu 3.13.0-30.54-generic
Uname: Linux 3.13.0-30-generic x86_64
ApportVersion: 2.14.1-0ubuntu3.2
Architecture: amd64
CurrentDesktop: KDE
Date: Sat Jun 21 22:12:35 2014
EcryptfsInUse: Yes
 # interfaces(5) file used by ifup(8) and ifdown(8)
 auto lo
 iface lo inet loopback
InstallationDate: Installed on 2013-04-05 (443 days ago)
InstallationMedia: Kubuntu 12.10 "Quantal Quetzal" - Release amd64 (20121017.1)
 default via dev wlan0 proto static dev wlan0 proto kernel scope link src metric 9
SourcePackage: network-manager
UpgradeStatus: Upgraded to trusty on 2014-05-14 (39 days ago)
 wlan0 802-11-wireless connected /org/freedesktop/NetworkManager/Devices/0
 running connected enabled enabled enabled enabled disabled

Dima Ryazanov (dima-gmail) wrote :
goliy (musor-zdes) wrote :

It happens not very often with me, usually when I reboot Access Point and Ubuntu just don't want to find AP again. When I turn off and turn on wifi - no networks at all.
Whank you for temp solution: "sudo iwlist scan" works much better then reboot =)

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in network-manager (Ubuntu):
status: New → Confirmed
teo1978 (teo8976) wrote :

I have also observed this. And it was not after suspending and resuming. I hadn't suspended/resumed since the previous boot which was just a few minutes before.

It is NOT systematic.

Usually, when I turn off and on wifi in the hardware as a workaround for bug #1491612, it does force a rescan.
This time, however, it wouldn't, even after retrying several times.

Since I didn't know about the command "iwlist scan", I had to reboot.

teo1978 (teo8976) wrote :

Sorry, when I say "I turn off and on wifi in the hardware" I mean I do it with Fn+F3 on my laptop. I'm not sure how much it is really "hardware"

Shaun Crampton (fasaxc) wrote :

I have the same symptom (wifi ends up disconnected after resume, cured by running a scan manually) but I'm seeing this after upgrading to 16.04.

One oddity is that network-manager often shows that it thinks it is connected to an AP after resume but it's not the correct one. It seems to think it is connected to my neighbour's AP, for example. I wondered if the APs had swapped channels due to autodetection or something.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers