NetworkManager cannot connect to encrypted wireless networks

Bug #1332772 reported by Karl Kastner on 2014-06-21
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
network-manager (Ubuntu)
Undecided
Unassigned

Bug Description

NetworkManager is unable to connect to WEP/WPA encrypted wireless networks on my system, but connection to unencrypted networks works fine. When initiating a new connection, immediately "You are now disconnected" is displayed by nm-applet. nmcli gets a dbus error message and then loops infinitely:

nmcli --pretty con up uuid f8386874-62ba-4844-9ee5-a402506f055e
** Message: Remote error from secret service: org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.secrets was not provided by any .service files
\ disconnected

Thought this bug initially to be #1104476, which was fixed with network-manger 0.9.8.8-0ubuntu7. However, after upgrading to trusty and having the patched package installed, the problem still persists.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: network-manager 0.9.8.8-0ubuntu7
ProcVersionSignature: Ubuntu 3.13.0-30.54-generic 3.13.11.2
Uname: Linux 3.13.0-30-generic x86_64
ApportVersion: 2.14.1-0ubuntu3.2
Architecture: amd64
CRDA: Error: [Errno 2] No such file or directory: 'iw'
CurrentDesktop: XFCE
Date: Sat Jun 21 12:51:38 2014
IpRoute:
 default via 10.42.0.1 dev wlan3 proto static
 10.42.0.0/24 dev wlan3 proto kernel scope link src 10.42.0.61 metric 9
NetworkManager.state:
 [main]
 NetworkingEnabled=true
 WirelessEnabled=true
 WWANEnabled=true
 WimaxEnabled=true
SourcePackage: network-manager
UpgradeStatus: Upgraded to trusty on 2014-06-20 (0 days ago)
nmcli-dev:
 DEVICE TYPE STATE DBUS-PATH
 wlan3 802-11-wireless connected /org/freedesktop/NetworkManager/Devices/0
nmcli-nm:
 RUNNING VERSION STATE NET-ENABLED WIFI-HARDWARE WIFI WWAN-HARDWARE WWAN
 running 0.9.8.8 connected enabled enabled enabled enabled disabled

Karl Kastner (kastner-karl) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in network-manager (Ubuntu):
status: New → Confirmed
Quijote Shin (quijote-shin) wrote :

Yesterday (or this morning)
I upgrade base system with via upgrade manager
Today I can't connect to my prime wifi, but easy connect to my unprotected wifi.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers