mobile broadband passwords and pin not stored in keyring

Bug #1320557 reported by Wolf Rogner on 2014-05-17
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
network-manager (Ubuntu)
Undecided
Unassigned

Bug Description

Ubuntu 14.04:

creating a new mobile broadband connection works fine.
When connecting a usb stick to access the mobile network a PIN is requested. There is the option to store the PIN permanently.
However, the key is not stored (queried after each insert) and seahorse does not show any entries.

In the configuration dialog I can enter a PIN as well but this is not stored either.

(This incident happened on a different machine so do not take machine information from the upload)

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: network-manager 0.9.8.8-0ubuntu7
ProcVersionSignature: Ubuntu 3.13.0-27.50-generic 3.13.11
Uname: Linux 3.13.0-27-generic x86_64
NonfreeKernelModules: nvidia wl
ApportVersion: 2.14.1-0ubuntu3.2
Architecture: amd64
CurrentDesktop: Unity
Date: Sat May 17 23:49:25 2014
IfupdownConfig:
 # interfaces(5) file used by ifup(8) and ifdown(8)
 auto lo
 iface lo inet loopback
InstallationDate: Installed on 2013-05-17 (365 days ago)
InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Release amd64+mac (20130424)
IpRoute:
 default via 10.1.0.254 dev wlan0 proto static
 10.0.0.0/8 dev wlan0 proto kernel scope link src 10.1.0.154 metric 9
 192.168.97.0/24 dev vmnet8 proto kernel scope link src 192.168.97.1
 192.168.204.0/24 dev vmnet1 proto kernel scope link src 192.168.204.1
NetworkManager.state:
 [main]
 NetworkingEnabled=true
 WirelessEnabled=true
 WWANEnabled=true
 WimaxEnabled=true
SourcePackage: network-manager
UpgradeStatus: Upgraded to trusty on 2014-04-20 (27 days ago)
nmcli-dev:
 DEVICE TYPE STATE DBUS-PATH
 wlan0 802-11-wireless connected /org/freedesktop/NetworkManager/Devices/0
nmcli-nm:
 RUNNING VERSION STATE NET-ENABLED WIFI-HARDWARE WIFI WWAN-HARDWARE WWAN
 running 0.9.8.8 connected enabled enabled enabled enabled enabled

Wolf Rogner (war-rsb) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in network-manager (Ubuntu):
status: New → Confirmed
Blümchen Blau (bluemchen-blau) wrote :

Same applies to built in WWAN-Card (Ericsson in Lenovo).
Ubuntu (32-bit, 3.13.0-29-generic)
BB

Same here on my T430 and my Ericsson H5321 module.

Blümchen Blau (bluemchen-blau) wrote :

Any ideas how to fix that issue. It is definitely annoying!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers