No WiFi detected

Bug #1307322 reported by Elbarbudo on 2014-04-14
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
network-manager (Ubuntu)
Undecided
Unassigned

Bug Description

I am not sure wether it is a driver issue or a NM issue.

The Wifi is detected by lspci, but does not appear in NM

00:0b.0 Network controller: Broadcom Corporation BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller (rev 02)

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: network-manager 0.9.8.8-0ubuntu7
ProcVersionSignature: Ubuntu 3.13.0-23.45-generic 3.13.8
Uname: Linux 3.13.0-23-generic i686
NonfreeKernelModules: wl
ApportVersion: 2.14.1-0ubuntu2
Architecture: i386
CurrentDesktop: XFCE
Date: Mon Apr 14 08:31:35 2014
IfupdownConfig:
 # interfaces(5) file used by ifup(8) and ifdown(8)
 auto lo
 iface lo inet loopback
InstallationDate: Installed on 2014-04-10 (3 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Daily i386 (20140409)
IpRoute:
 default via 192.168.0.254 dev eth0 proto static
 192.168.0.0/24 dev eth0 proto kernel scope link src 192.168.0.31 metric 1
IwConfig:
 lo no wireless extensions.

 eth0 no wireless extensions.
NetworkManager.state:
 [main]
 NetworkingEnabled=true
 WirelessEnabled=true
 WWANEnabled=true
 WimaxEnabled=true
RfKill:

SourcePackage: network-manager
UpgradeStatus: No upgrade log present (probably fresh install)
nmcli-con:
 NAME UUID TYPE TIMESTAMP TIMESTAMP-REAL AUTOCONNECT READONLY DBUS-PATH
 Connexion filaire 1 3fce440c-3a27-43dc-9c06-f50d442b5c50 802-3-ethernet 1397457009 lun. 14 avril 2014 08:30:09 CEST yes no /org/freedesktop/NetworkManager/Settings/0
nmcli-dev:
 DEVICE TYPE STATE DBUS-PATH
 eth0 802-3-ethernet connected /org/freedesktop/NetworkManager/Devices/0
nmcli-nm:
 RUNNING VERSION STATE NET-ENABLED WIFI-HARDWARE WIFI WWAN-HARDWARE WWAN
 running 0.9.8.8 connected enabled enabled enabled enabled disabled

Elbarbudo (patricearnal) wrote :
Elbarbudo (patricearnal) wrote :

Adding an external USB WiFi key SMC EZConnect works fine.

Driver problem

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in network-manager (Ubuntu):
status: New → Confirmed
Elbarbudo (patricearnal) wrote :

Very strange :

I wiped out Ubuntu 14.04 to install Xubuntu 14.04 (no GPU on this machine hence Ubuntu is unusable)

I added the linux-kernel-non-free in order to get the WiFi card detected and usable, and Presto! everything is running fine...

What are the differences between Xubuntu kernel and regular Ubuntu kernel?

i've never contributed to any bug reports, but fwiw, i'm running 14.04 as well, and had a similar issue with my asus p8z77-i deluxe mini itx motherboard with a broadcom bcm43228 chipset. upon installing ubuntu 13.10 OR 14.04, the wifi drivers aren't detected or installed. i can see the chip via lspci, however, it wont list any wifi APs. i solved this issue, by navigating through my 13.10 usb stick, going into the /pool/main/d/dkms/ folder and installing the dkms.deb file in there, then go to /pool/restricted/b/bcmwl directory and installing that .deb file in there. after these steps, the wifi card is detected and all is well. i dont know the technical aspects of linux too well to help you any farther, but that worked for me, and may work for others too.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers