Network-manager fails to retrieve VPN secrets when no password was necessary before

Bug #1298047 reported by Franck on 2014-03-26
34
This bug affects 6 people
Affects Status Importance Assigned to Milestone
network-manager (Ubuntu)
Undecided
Unassigned

Bug Description

I have several VPN configurations, that used to work some days (wekks ?) ago.
Now, most of them fail, using several VPN software (vpnc and openvpn at least).

The error seems to be the same in each case:

<error> [1395865654.87082] [nm-vpn-connection.c:1374] get_secrets_cb(): Failed to request VPN secrets #2: (6) No agents were available for this request.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: network-manager 0.9.8.8-0ubuntu5
ProcVersionSignature: Ubuntu 3.13.0-19.40-generic 3.13.6
Uname: Linux 3.13.0-19-generic x86_64
ApportVersion: 2.13.3-0ubuntu1
Architecture: amd64
CurrentDesktop: Unity
Date: Wed Mar 26 21:27:24 2014
InstallationDate: Installed on 2013-02-16 (402 days ago)
InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Alpha amd64 (20130216)
IpRoute:
 default via 10.0.1.1 dev wlan0 proto static
 10.0.1.0/24 dev wlan0 proto kernel scope link src 10.0.1.10 metric 9
 192.168.122.0/24 dev virbr0 proto kernel scope link src 192.168.122.1
NetworkManager.state:
 [main]
 NetworkingEnabled=true
 WirelessEnabled=true
 WWANEnabled=true
 WimaxEnabled=true
SourcePackage: network-manager
UpgradeStatus: Upgraded to trusty on 2014-01-22 (63 days ago)
mtime.conffile..etc.NetworkManager.NetworkManager.conf: 2014-01-18T13:13:34.565032
nmcli-dev:
 DEVICE TYPE STATE DBUS-PATH
 wlan0 802-11-wireless connected /org/freedesktop/NetworkManager/Devices/1
 eth0 802-3-ethernet unavailable /org/freedesktop/NetworkManager/Devices/0
nmcli-nm:
 RUNNING VERSION STATE NET-ENABLED WIFI-HARDWARE WIFI WWAN-HARDWARE WWAN
 running 0.9.8.8 connected enabled enabled enabled enabled enabled

Franck (alci) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in network-manager (Ubuntu):
status: New → Confirmed
Franck (alci) wrote :

Ok, I changed the title as I noticed something: the exact same vpn config (openvpn in that case), that was failing with "No agents were available for this request.", started worked when I was connected in another place.

Then back to home, it does not work anymore. The main difference I see is that at home, I use a plain open no password wifi connection, whereas in the other place, the wifi was password protected. I suspect I can narrow the bug down to: Network-manager fails to retrieve VPN secrets if no secret was initialy used to connect to the network.

Does itmake sense regarding the way it's coded ?

summary: - Network-manager fails to retrieve VPN secrets
+ Network-manager fails to retrieve VPN secrets when no password was
+ necessary before

I think this bug is a duplicate of #1247682 and #1297849.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers