8086:1502 [Fujitsu D3076-S1x] Ethernet disconnecting at boot and later

Bug #1268556 reported by Sergey Spiridonov on 2014-01-13
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
network-manager (Ubuntu)
Medium
Unassigned

Bug Description

Fresh install XUbuntu 12.04. After boot network interface is down. After unplugging and plugging back network cable, network is up and running again. Later (randomly) it may go off again. Again, unplugging and plugging back network cable helps.

Ethernet card is onboard Intel.
Mainboard: FUJITSU D3076-S1

Same problem happens with onboard ethernet with Intel mainboard DH61BE.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: linux-image-3.2.0-58-generic 3.2.0-58.88
ProcVersionSignature: Ubuntu 3.2.0-58.88-generic 3.2.53
Uname: Linux 3.2.0-58-generic x86_64
NonfreeKernelModules: nvidia
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 2.0.1-0ubuntu17.6
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: PCH [HDA Intel PCH], device 0: CONEXANT Analog [CONEXANT Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: user 1641 F.... xfce4-volumed
                      user 1718 F.... pulseaudio
 /dev/snd/controlC0: user 1641 F.... xfce4-volumed
                      user 1718 F.... pulseaudio
CRDA: Error: [Errno 2] Datei oder Verzeichnis nicht gefunden
Card0.Amixer.info:
 Card hw:0 'PCH'/'HDA Intel PCH at 0xfb220000 irq 50'
   Mixer name : 'Conexant CX20642'
   Components : 'HDA:14f150a2,173411b0,00100100'
   Controls : 19
   Simple ctrls : 9
Card1.Amixer.info:
 Card hw:1 'NVidia'/'HDA NVidia at 0xfb080000 irq 17'
   Mixer name : 'Nvidia GPU 42 HDMI/DP'
   Components : 'HDA:10de0042,10de094a,00100100'
   Controls : 12
   Simple ctrls : 2
Date: Mon Jan 13 12:02:04 2014
HibernationDevice: RESUME=UUID=324bb3ce-d9ee-4142-a94d-1382ec436191
InstallationMedia: Xubuntu 12.04.3 LTS "Precise Pangolin" - Release amd64 (20130822)
IwConfig:
 lo no wireless extensions.

 eth1 no wireless extensions.

 eth0 no wireless extensions.
MachineType: FUJITSU D3076-S1
MarkForUpload: True
ProcFB:

ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-58-generic root=UUID=2d4ccd09-d6c3-47ee-80ad-14977144d770 ro quiet splash
RelatedPackageVersions:
 linux-restricted-modules-3.2.0-58-generic N/A
 linux-backports-modules-3.2.0-58-generic N/A
 linux-firmware 1.79.9
RfKill:

SourcePackage: linux
StagingDrivers: mei
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 09/20/2012
dmi.bios.vendor: FUJITSU // American Megatrends Inc.
dmi.bios.version: V4.6.4.0 R1.12.0 for D3076-S1x
dmi.board.name: D3076-S1
dmi.board.vendor: FUJITSU
dmi.board.version: S26361-D3076-S1
dmi.chassis.type: 6
dmi.chassis.vendor: FUJITSU
dmi.modalias: dmi:bvnFUJITSU//AmericanMegatrendsInc.:bvrV4.6.4.0R1.12.0forD3076-S1x:bd09/20/2012:svnFUJITSU:pnD3076-S1:pvr:rvnFUJITSU:rnD3076-S1:rvrS26361-D3076-S1:cvnFUJITSU:ct6:cvr:
dmi.product.name: D3076-S1
dmi.sys.vendor: FUJITSU

Sergey Spiridonov (sena-hurd) wrote :

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed

Sergey Spiridonov, thank you for reporting this and helping make Ubuntu better. Could you please confirm this issue exists with the latest development release of Ubuntu? ISO images are available from http://cdimage.ubuntu.com/daily-live/current/ . If the issue remains, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p linux REPLACE-WITH-BUG-NUMBER

If reproducible, could you also please test the latest upstream kernel available (not the daily folder) following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional upstream developers to examine the issue. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested. If this bug is fixed in the mainline kernel, please add the following tags:
kernel-fixed-upstream
kernel-fixed-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested. For example:
kernel-fixed-upstream-v3.13-rc7

This can be done by clicking on the yellow circle with a black pencil icon next to the word Tags located at the bottom of the bug description. As well, please remove the tag:
needs-upstream-testing

If the mainline kernel does not fix this bug, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-VERSION-NUMBER

As well, please remove the tag:
needs-upstream-testing

Once testing of the upstream kernel is complete, please mark this bug's Status as Confirmed. Please let us know your results. Thank you for your understanding.

tags: added: latest-bios-09-20-2012 needs-trusty-test
tags: added: needs-upstream-testing
removed: needs-trusty-test
Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete
summary: - e1000e disconnecting at boot time and later (mainboard FUJITSU
- D3076-S1 and mainboard Intel DH61BE
+ 8086:1502 [Fujitsu D3076-S1x] Ethernet disconnecting at boot and later
Sergey Spiridonov (sena-hurd) wrote :

I just installed Ubuntu and bug is gone. The difference is that Ubuntu has kernel 3.8 with e1000e driver 2.4 and Xubuntu has kernel 3.2 with e1000 driver 1.5

How can I install kernel from Ubuntu in Xubuntu? Why do they utilize different kernels anyway?????

Sergey Spiridonov (sena-hurd) wrote :

Latest development release of Ubuntu works too.

Sergey Spiridonov (sena-hurd) wrote :

Tested with development version of Ubuntu and kernel from mainstream of Ubuntu. Bug seems to be fixed in newer version of e1000e driver.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Sergey Spiridonov (sena-hurd) wrote :

Sorry, I was not clear in my previous message: I tested development version of Ubuntu, Ubuntu version 12 and Xubuntu version 12.

Ubuntu 12 and Xubuntu 12 use different kernels: Ubuntu 12 has kernel 3.8 (with e1000e 2.4) and Xubuntu 12 has kernel 3.2 (with e1000e 1.5).

After the Ubuntu 12 was isntalled it seems that probelm was gone. Just few minutes ago I updated Ubuntu 12 and now I have same problem on Ubuntu 12 too. I will do futher checks tomorrow!

I am not sure if problem appears after I run apt-get upgrage, so I will try to reinstall Ubuntu 12 from scratch again and test if problem appears before upgrade, then I will perform upgrade and test again.

Sergey Spiridonov, would you need a backport to a release prior to Trusty Xubuntu, or would you want to utilize it via http://xubuntu.org/news/help-us-test-xubuntu-14-04-lts/ and this may be marked Status Invalid?

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Sergey Spiridonov (sena-hurd) wrote :

I found package which is the source of the problem!

Problem appears after upgrading network-manager package 0.9.4.0-0ubuntu4.2 to 0.9.4.0-0ubuntu4.3

So it seems to be not kernel bug, but it is a bug of the network-manager!

Next step is to find out which changes were made to the network-manager package!

Sergey Spiridonov (sena-hurd) wrote :

Tested now in Ubuntu 14. The bug is not present there.

So the fix will be - either backport network manager from Ubutnu 14 or downgrade network-manager from 0.9.4.0-0ubuntu4.3 to 0.9.4.0-0ubuntu4.2.

Please ask me if you need additional tests or more information.

Of course, we need the fix in this stable release. Next stable release will be in half a year!!! I see this bug affecting already 3 different hosts. The only common they have - Intel network cards.

Changed in linux (Ubuntu):
status: Incomplete → Opinion
status: Opinion → Invalid
status: Invalid → Confirmed

Sending to network-manager (Ubuntu) given regression noted for it.

description: updated
affects: linux (Ubuntu) → network-manager (Ubuntu)
Changed in network-manager (Ubuntu):
status: Confirmed → New
Sergey Spiridonov (sena-hurd) wrote :

I want to update the very first bug description. I wrote:

> After boot network interface is down. After unplugging and plugging back network cable, network is up and running again.

Network interface is not really down, it is up, but does not have IP4 address.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers