[gutsy] network-manager too verbose in syslog and daemon.log

Bug #125534 reported by Alexander Sack on 2007-07-12
12
Affects Status Importance Assigned to Milestone
network-manager (Ubuntu)
High
Alexander Sack
Gutsy
High
Alexander Sack
network-manager (tuXlab)
Undecided
Unassigned

Bug Description

Binary package hint: network-manager

the patch 25_lp90267-dont-tear-down-upped-interfaces.patch contains lot of verbose debug output. Those should be removed before final gutsy release

Alexander Sack (asac) wrote :

we need this until after beta in case there are issues when new network-manager is exposed to the masses

Changed in network-manager:
assignee: nobody → asac
importance: Undecided → High
status: New → Triaged
David R. Hedges (p14nd4) wrote :

I have difficulty accepting that it's "necessary" to spam two log files with the following two lines every five seconds:

Sep 7 16:11:05 dixon NetworkManager: <info> nm_policy_device_change_check:: old_dev has_link? 1
Sep 7 16:11:05 dixon NetworkManager: <info> nm_policy_device_change_check:: old_dev && new_dev!!

You'll be writing about 6.5 MiB/day of identical lines (except for the date/time) in most cases (i.e. when things are working).

A good solution would be to make the verbosity runtime-configurable either via a config file option (/etc/NetworkManager/conf or something) or something in gconf. That way when someone actually *wants* this information, they can enable it, but the rest of us aren't spinning our hard drives constantly to keep writing this information that is of no use to us in a working configuration.

On Fri, Sep 07, 2007 at 09:19:17PM -0000, David R. Hedges wrote:
> I have difficulty accepting that it's "necessary" to spam two log files
> with the following two lines every five seconds:
>
> Sep 7 16:11:05 dixon NetworkManager: <info> nm_policy_device_change_check:: old_dev has_link? 1
> Sep 7 16:11:05 dixon NetworkManager: <info> nm_policy_device_change_check:: old_dev && new_dev!!

Those line should not be written in latest network manager anymore.

 - Alexander

Added bug 121652 (https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/121652) as a duplicate of this bug, guess this problem is solved when Gutsy is released.

Alexander Sack (asac) wrote :

this has been fixed a while back. I will add a debug config mechanism for gutsy+1.

Changed in network-manager:
status: Triaged → Fix Released

Jonathan Carter, Is this still an open issue for tuXlab?

Changed in network-manager (tuXlab):
status: New → Incomplete
Changed in network-manager (tuXlab):
status: Incomplete → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers