WiFi connections not re-established

Bug #1252106 reported by James Tait on 2013-11-17
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
network-manager (Ubuntu)
Undecided
Unassigned

Bug Description

If I boot my phone at home, it happily connects to my wireless network. If I leave home and have Cellular Data enabled, it will establish a 3G connection. If I then return home, it remains on 3G instead of switching back to the wireless network. Even if I disable Cellular data, the wireless connection is not re-established.

I have tried restarting network-manager and wpasupplicant, to no avail. The only way I have been able to get it to reconnect to the wireless network is to reboot the phone. The logs suggest that the wireless authentication fails, but the reboot doesn't prompt for new credentials.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: network-manager 0.9.8.4-0ubuntu3
Uname: Linux 3.4.0-3-mako armv7l
ApportVersion: 2.12.6-0ubuntu1
Architecture: armhf
CRDA: Error: [Errno 2] No such file or directory: 'iw'
Date: Sun Nov 17 17:19:14 2013
IfupdownConfig:
 # interfaces(5) file used by ifup(8) and ifdown(8)
 # Include files from /etc/network/interfaces.d:
 source-directory /etc/network/interfaces.d
InstallationDate: Installed on 2013-11-15 (2 days ago)
InstallationMedia: Ubuntu Trusty Tahr (development branch) - armhf (20131115)
IpRoute:
 default via 217.169.7.97 dev wlan0 proto static
 217.169.7.96/27 dev wlan0 proto kernel scope link src 217.169.7.115 metric 9
MarkForUpload: True
NetworkManager.state:
 [main]
 NetworkingEnabled=true
 WirelessEnabled=true
 WWANEnabled=true
 WimaxEnabled=true
PciNetwork:

SourcePackage: network-manager
UpgradeStatus: No upgrade log present (probably fresh install)
mtime.conffile..etc.dbus.1.system.d.org.freedesktop.NetworkManager.conf: 2013-11-11T17:26:39
nmcli-con:
 NAME UUID TYPE TIMESTAMP TIMESTAMP-REAL AUTOCONNECT READONLY DBUS-PATH
 wyrddreams 83361e0b-c649-40bb-a06b-b9dfdf8e9b88 802-11-wireless 1384708569 Sun 17 Nov 2013 05:16:09 PM GMT yes no /org/freedesktop/NetworkManager/Settings/2
 robsnetwork1a 35fd68ec-6692-4257-a1fb-2b1a5d6f5c0b 802-11-wireless 1384635695 Sat 16 Nov 2013 09:01:35 PM GMT yes no /org/freedesktop/NetworkManager/Settings/1
 /234304102840004/context1 f7e681eb-f938-6eb7-7d28-0ccde53ac6ff gsm 1384653566 Sun 17 Nov 2013 01:59:26 AM GMT yes yes /org/freedesktop/NetworkManager/Settings/0
 the mickleover 84355cc1-a50d-44d6-b761-873d4cde3e56 802-11-wireless 0 never yes no /org/freedesktop/NetworkManager/Settings/3
nmcli-dev:
 DEVICE TYPE STATE DBUS-PATH
 /ril_0 gsm disconnected /org/freedesktop/NetworkManager/Devices/1
 wlan0 802-11-wireless connected /org/freedesktop/NetworkManager/Devices/0
nmcli-nm:
 RUNNING VERSION STATE NET-ENABLED WIFI-HARDWARE WIFI WWAN-HARDWARE WWAN
 running 0.9.8.4 connected enabled enabled enabled enabled disabled

James Tait (jamestait) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in network-manager (Ubuntu):
status: New → Confirmed
To post a comment you must log in.