Phone does not reliably switch to cellular data

Bug #1225393 reported by Rick Spencer on 2013-09-14
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
network-manager (Ubuntu)
Critical
Mathieu Trudel-Lapierre

Bug Description

Steps:

1. Have a Sim card with data in a Nexus 4
2. Be in your office connected to wifi
3. Send some texts to confirm that you are receiving signals
4. Leave your office to go meet someone
5. After leaving, get a bit lost and activate the web browser to look up a map

Result:
You are now lost because there is no 3g data, though you can text and call

Expected:
The phone switches to data for you

Note that sometimes it does switch to 3g data

tags: added: avengers
Changed in telephony-service:
status: New → Confirmed
Julien Funk (jaboing) wrote :

Just tried this and found that I had no trouble switching wifi/3g and sending receiving sms.

Julien Funk (jaboing) on 2013-09-16
Changed in telephony-service:
importance: Undecided → Critical
Julien Funk (jaboing) on 2013-09-17
Changed in telephony-service:
status: Confirmed → Incomplete
Changed in telephony-service:
status: Incomplete → Triaged
affects: telephony-service → touch-preview-images
Changed in touch-preview-images:
assignee: nobody → Mathieu Trudel-Lapierre (mathieu-tl)
Changed in network-manager (Ubuntu):
status: New → Triaged
importance: Undecided → Critical
assignee: nobody → Mathieu Trudel-Lapierre (mathieu-tl)
Julien Funk (jaboing) wrote :

I am now seeing this consistently. I haven't been able to connect to 3g since yesterday.

no longer affects: touch-preview-images
Tony Espy (awe) wrote :

I just confirmed that JB4.3 on a Galaxy Nexus handles this flawlessly. Connected to my home Wi-Fi network, then left and went to the lobby downstairs without first de-activating Wi-Fi. By the time I'd gotten to the end of the hallway ( ~100 meters ), the Wi-Fi connection had dropped and the phone switched over to the mobile network. Almost no gap in being able to browse the web.

I will try and confirm this on Touch later today.

@Julien

Not connecting to 3G at all ( especially if Wi-Fi is disabled ) is a separate bug. There's a new version of NM in -proposed that fixes what we believe to be the remaining issues with initial mobile data connection setup.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package network-manager - 0.9.8.0-0ubuntu21

---------------
network-manager (0.9.8.0-0ubuntu21) saucy; urgency=low

  * debian/patches/provisioning_wait_ofono_properties.patch: rework when we
    get the IP config from oFono as to get the values prior to transitioning
    to stage 3 (IP Configuration), so that we don't risk missing some of the
    settings. (LP: #1226071, #1225393)
 -- Mathieu Trudel-Lapierre <email address hidden> Tue, 24 Sep 2013 12:40:07 -0400

Changed in network-manager (Ubuntu):
status: Triaged → Fix Released
Tony Espy (awe) wrote :

I can confirm that the fix works with this package.

Charles Redman (charles-redman) wrote :

I have a similar bug to this although does not involve WiFi. If i am driving/travelling through an area that does not have reception from my mobile network. 3G/data does not come back when the phone has reception again. I can text and make calls but cannot use data. I have to power my N4 off and back on again to resolve this. Toggling the Data switch in the cellular settings does nothing. I would love to file a bug for this but wouldn't have a clue where to do so...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers