no network with dhcp set up

Bug #121566 reported by LGB [Gábor Lénárt] on 2007-06-21
14
Affects Status Importance Assigned to Milestone
network-manager (Ubuntu)
Medium
Alexander Sack

Bug Description

After upgrading from feisty to gutsy, no network configuration is done with DHCP anymore. Command 'ifconfig' shows no IP address configured on eth0 at all. According to 'top', processes NetworkManager, NetworkManagerDispatcher, dbus-daemon and syslogd takes up all idle CPU while memory usage of NetworkManagerDispatcher is increasing. After killing NetworkManager and NetworkManagerDispatcher processes, and do ifdown eth0 then ifup eth0 I got IP address without any problem.

dbus 1.0.2-5ubuntu1
dhcdbd 2.0-5ubuntu1
dhcp3-client 3.0.4-14ubuntu1
network-manager 0.6.5-0ubuntu2

Linux orion 2.6.22-6-generic #1 SMP Fri Jun 1 19:24:12 GMT 2007 i686 GNU/Linux

/var/log/syslog

Jun 21 12:10:37 orion NetworkManager: <info> Activation (eth0) Stage 2 of 5 (Device Configure) scheduled...
Jun 21 12:10:37 orion NetworkManager: <info> Activation (eth0) Stage 1 of 5 (Device Prepare) complete.
Jun 21 12:10:37 orion NetworkManager: <info> Activation (eth0) Stage 2 of 5 (Device Configure) starting...
Jun 21 12:10:37 orion NetworkManager: <info> Activation (eth0) Stage 2 of 5 (Device Configure) successful.
Jun 21 12:10:37 orion NetworkManager: <info> Activation (eth0) Stage 3 of 5 (IP Configure Start) scheduled.
Jun 21 12:10:37 orion NetworkManager: <info> Activation (eth0) Stage 2 of 5 (Device Configure) complete.
Jun 21 12:10:37 orion NetworkManager: <info> Activation (eth0) Stage 3 of 5 (IP Configure Start) started...
Jun 21 12:10:37 orion NetworkManager: <WARN> nm_dhcp_manager_begin_transaction(): dhcdbd not running!
Jun 21 12:10:37 orion NetworkManager: <info> Activation (eth0) failure scheduled...
Jun 21 12:10:37 orion NetworkManager: <info> Activation (eth0) Stage 3 of 5 (IP Configure Start) complete.
Jun 21 12:10:37 orion NetworkManager: <info> Activation (eth0) failed.
Jun 21 12:10:37 orion NetworkManager: <info> Deactivating device eth0.
Jun 21 12:10:37 orion NetworkManager: <info> SWITCH: no current connection, found better connection 'eth0'.
Jun 21 12:10:37 orion NetworkManager: <WARN> nm_dhcp_manager_get_state_for_device(): dhcdbd not running!
Jun 21 12:10:37 orion NetworkManager: <info> Will activate connection 'eth0'.
Jun 21 12:10:37 orion NetworkManager: <info> Device eth0 activation scheduled...
Jun 21 12:10:37 orion NetworkManager: <info> Activation (eth0) started...
Jun 21 12:10:37 orion NetworkManager: <info> Activation (eth0) Stage 1 of 5 (Device Prepare) scheduled...
Jun 21 12:10:37 orion NetworkManager: <info> Activation (eth0) Stage 1 of 5 (Device Prepare) started...
Jun 21 12:10:37 orion NetworkManager: <info> Activation (eth0) Stage 2 of 5 (Device Configure) scheduled...
Jun 21 12:10:37 orion NetworkManager: <info> Activation (eth0) Stage 1 of 5 (Device Prepare) complete.
Jun 21 12:10:37 orion NetworkManager: <info> Activation (eth0) Stage 2 of 5 (Device Configure) starting...
Jun 21 12:10:37 orion NetworkManager: <info> Activation (eth0) Stage 2 of 5 (Device Configure) successful.
Jun 21 12:10:37 orion NetworkManager: <info> Activation (eth0) Stage 3 of 5 (IP Configure Start) scheduled.
Jun 21 12:10:37 orion NetworkManager: <info> Activation (eth0) Stage 2 of 5 (Device Configure) complete.
Jun 21 12:10:37 orion NetworkManager: <info> Activation (eth0) Stage 3 of 5 (IP Configure Start) started...
Jun 21 12:10:37 orion NetworkManager: <WARN> nm_dhcp_manager_begin_transaction(): dhcdbd not running!
Jun 21 12:10:37 orion NetworkManager: <info> Activation (eth0) failure scheduled...
Jun 21 12:10:37 orion NetworkManager: <info> Activation (eth0) Stage 3 of 5 (IP Configure Start) complete.
Jun 21 12:10:37 orion NetworkManager: <info> Activation (eth0) failed.
Jun 21 12:10:37 orion NetworkManager: <info> Deactivating device eth0.
Jun 21 12:10:37 orion NetworkManager: <info> SWITCH: no current connection, found better connection 'eth0'.
Jun 21 12:10:37 orion NetworkManager: <WARN> nm_dhcp_manager_get_state_for_device(): dhcdbd not running!
Jun 21 12:10:37 orion NetworkManager: <info> Will activate connection 'eth0'.

[..etc...]

Erik Andrén (erik-andren) wrote :

I have the same issue

Changed in network-manager:
status: New → Confirmed
Till Kamppeter (till-kamppeter) wrote :

I have also such a problem, NetworkManager taking 100% CPU all the time, making it impossible to do CPU-intensive tasks like compiling. I can access the wired only after choosing manual configuration in the left-click menu of the NM tray applet and setting the wired network to DHCP/automatic there.

Gutsy can really not get released this way.

My current /etc/network/interfaces file:

----------
auto lo
iface lo inet loopback

iface eth0 inet dhcp
address 192.168.1.65
netmask 255.255.255.0
gateway 192.168.1.254

auto eth0

----------

Strange is that my wireless card (eth1) does not appear here.

Changed in network-manager:
importance: Undecided → Critical
Erik Andrén (erik-andren) wrote :

I do not suffer from this issue anymore.

Alexander Sack (asac) wrote :

the initial issue reported should be fixed now, because we don't try to activate as agressivley as before since 0.6.5-0ubuntu15.

Till, your interfaces file will stop your eth0 from being network-manager managed.

Anyway, I need your /var/log/syslog as well.

Changed in network-manager:
assignee: nobody → asac
importance: Critical → High
status: Confirmed → Incomplete
Alexander Sack (asac) on 2007-10-04
Changed in network-manager:
importance: High → Medium
Craigus (craigusoz) wrote :

Oops - I submitted another bug report: https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/149187

The problem in /var/syslog seems to be related to:

<WARN> nm_dhcp_manager_begin_transaction(): dhcdbd not running!

Till Kamppeter (till-kamppeter) wrote :
Till Kamppeter (till-kamppeter) wrote :
Till Kamppeter (till-kamppeter) wrote :
Till Kamppeter (till-kamppeter) wrote :

Alexander, added my syslog. The problem shows most probably in the last one ("Earlier syslog of yesterday"). Later yesterday I have replaced my /etc/network/interfaces by the standard one of my Feisty box and the problem disappeared. It seems that Network Manager gets irritated a lot when one uses a manual configuration temporarily. Is there no possibility to cleanly get back to automatic using the GUI tools?

Alexander Sack (asac) wrote :

Till, just go to gnome network configuration dialog and disable/mark the interfaces for roaming.

Alexander Sack (asac) wrote :

... please don't gzip your attachments :)

Alexander Sack (asac) wrote :

please reproduce the issue and attach just the syslog that captured that testcase.
Thanks,
 - Alexander

Alexander Sack (asac) wrote :

... and be sure to use the latest network-manager 0.6.5-0ubuntu15

Alexander Sack (asac) wrote :

Craigus, your issue should be fixed in 0.6.5-0ubuntu15

Craigus (craigusoz) wrote :

Alexander - thanks, but, no, the issue still occurs. Everything is updated; I have 0.6.5-0ubuntu15 installed.

syslog attached.

On Sat, Oct 06, 2007 at 12:23:04PM -0000, Craigus wrote:
> Alexander - thanks, but, no, the issue still occurs. Everything is
> updated; I have 0.6.5-0ubuntu15 installed.
>
> syslog attached.

Can you please test the package from my ppa (version:
0.6.5-0ubuntu16~ppa1):

  http://ppa.launchpad.net/asac/ubuntu/pool/main/n/network-manager/

Thanks,

 - Alexander

Craigus (craigusoz) wrote :

Alexander, the same problem occurs with 0.6.5-0ubuntu16~ppa1.

Syslog attached.

Alexander Sack (asac) wrote :

Craigus, I see that eth0 connects successfully ... hmmm. So what is your exact problem?

Craigus (craigusoz) wrote :

I can ping my router, but nothing else on my LAN, or on the external internet - there is a network unreachable error. Choosing connection information in the NM applet shows apparently normal IP and DNS information.

This all started to happen some time ago, but did not happen with my original clean Tribe 4 install.

Uncommenting the eth0 iface line in /etc/network/interfaces makes the problem go away.

Thanks for your help.

Alexander Sack (asac) wrote :

Craigus, please post your /etc/network/interfaces as well as the output of:

route -n

and

ifconfig

when you can only ping your router.

Thanks,

 - Alexander

Alexander Sack (asac) wrote :

Craigus, if eth0 is defined in /etc/network/interfaces, then eth0 is not managed by network manager.

Please post your /etc/network/interfaces as welll as the output of:

 route -n

and

 ifconfig

Craigus (craigusoz) wrote :

"if eth0 is defined in /etc/network/interfaces, then eth0 is not managed by network manager."

Yes, I know - that's why I think it was a NM issue. The problem would only occur when eth0 was not defined.

Anyway .... after updates today, I cannot reproduce the problem; it works correctly. I even uninstalled 0.6.5-0ubuntu16~ppa1 and went back to 0.6.5-0ubuntu15. It now works.

I'll post again if the problem returns.

Alexander Sack (asac) wrote :

please reopen if you see this issue in the next days.

Changed in network-manager:
status: Incomplete → Fix Released
Craigus (craigusoz) wrote :
Download full text (3.5 KiB)

Hmm. It's back. I just booted and no connectivity other than to my router.

The not working configuration:

/etc/network/interfaces:

auto lo
iface lo inet loopback

auto eth0
#iface eth0 inet dhcp

auto eth1
#iface eth1 inet dhcp

auto eth2
#iface eth2 inet dhcp

auto ath0
#iface ath0 inet dhcp

auto wlan0
#iface wlan0 inet dhcp

ifconfig:

eth0 Link encap:Ethernet HWaddr 00:00:E2:74:4D:B1
          inet addr:192.168.1.88 Bcast:192.168.1.255 Mask:255.255.255.0
          inet6 addr: fe80::200:e2ff:fe74:4db1/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
          RX packets:53 errors:0 dropped:0 overruns:0 frame:0
          TX packets:29 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:6701 (6.5 KB) TX bytes:4973 (4.8 KB)

lo Link encap:Local Loopback
          inet addr:127.0.0.1 Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING MTU:16436 Metric:1
          RX packets:360 errors:0 dropped:0 overruns:0 frame:0
          TX packets:360 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:30236 (29.5 KB) TX bytes:30236 (29.5 KB)

vmnet1 Link encap:Ethernet HWaddr 00:50:56:C0:00:01
          inet addr:192.168.1.1 Bcast:192.168.1.255 Mask:255.255.255.0
          inet6 addr: fe80::250:56ff:fec0:1/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:135 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

route -n:

Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.1.0 0.0.0.0 255.255.255.0 U 0 0 0 vmnet1
192.168.1.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0
169.254.0.0 0.0.0.0 255.255.0.0 U 1000 0 0 eth0

The working configuration (after defining eth0 in /etc/network/interfaces):

auto lo
iface lo inet loopback

auto eth0
iface eth0 inet dhcp

auto eth1
#iface eth1 inet dhcp

auto eth2
#iface eth2 inet dhcp

auto ath0
#iface ath0 inet dhcp

auto wlan0
#iface wlan0 inet dhcp

ifconfig:

eth0 Link encap:Ethernet HWaddr 00:00:E2:74:4D:B1
          inet addr:192.168.1.88 Bcast:192.168.1.255 Mask:255.255.255.0
          inet6 addr: fe80::200:e2ff:fe74:4db1/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
          RX packets:27 errors:0 dropped:0 overruns:0 frame:0
          TX packets:70 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:3492 (3.4 KB) TX bytes:9179 (8.9 KB)

lo Link encap:Local Loopback
          inet addr:127.0.0.1 Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING MTU:16436 Metric:1
          RX packets:68 errors:0 dropped:0 overruns:0 frame:0
          TX packets:68 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:5492 (5.3 KB) TX bytes:5492 (5.3 KB)

r...

Read more...

Craigus (craigusoz) wrote :

Further: Disabling NAT in VMWare player seems to have fixed the issue. It appears that I was not pinging my router at 192.168.1.1, but the vmnet service.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers