Invalid locale in /etc/default/locales halts boot

Bug #1192514 reported by TomasHnyk on 2013-06-19
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
mountall (Ubuntu)
Medium
Unassigned
network-manager (Ubuntu)
Undecided
Unassigned

Bug Description

Step to reproduce:
1. Set invalid locale to /etc/default/locale by:
sudo update-locale LC_TIME=" cs_CZ.UTF-8"
(notice the blank between " and cs)
2. Reboot

What happens:
The boot hangs with messages (after pressing escape) about invalid locale

What should happen:
I guess some default locale should be used instead, not booting is not cool.

How to recover:
Boot in recovery mode, mount partition by selecting fsck, then drop to root console and edit /etc/default/locale with vim (delete the blank in C_TIME=" cs_CZ.UTF-8")

I am not sure if this is againsta the kernel or some other part of the boot process.
---
ApportVersion: 2.9.2-0ubuntu8.1
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: drew 1594 F.... pulseaudio
DistroRelease: Ubuntu 13.04
EcryptfsInUse: Yes
InstallationDate: Installed on 2013-05-03 (46 days ago)
InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Release amd64 (20130424)
MachineType: LENOVO 20828VG
MarkForUpload: True
Package: linux (not installed)
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.8.0-25-generic root=UUID=8277281a-1fbc-4c61-8477-50dc9ec804cf ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 3.8.0-25.37-generic 3.8.13
RelatedPackageVersions:
 linux-restricted-modules-3.8.0-25-generic N/A
 linux-backports-modules-3.8.0-25-generic N/A
 linux-firmware 1.106
Tags: raring
Uname: Linux 3.8.0-25-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo vboxusers
dmi.bios.date: 03/13/2009
dmi.bios.vendor: LENOVO
dmi.bios.version: 7VET64WW (2.12 )
dmi.board.name: 20828VG
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr7VET64WW(2.12):bd03/13/2009:svnLENOVO:pn20828VG:pvrThinkPadT500:rvnLENOVO:rn20828VG:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 20828VG
dmi.product.version: ThinkPad T500
dmi.sys.vendor: LENOVO

TomasHnyk (sup) on 2013-06-19
affects: postgresql-common (Ubuntu) → linux (Ubuntu)

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1192514

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
TomasHnyk (sup) wrote : AlsaInfo.txt

apport information

tags: added: apport-collected raring
description: updated
TomasHnyk (sup) wrote : BootDmesg.txt

apport information

TomasHnyk (sup) wrote : CRDA.txt

apport information

apport information

apport information

TomasHnyk (sup) wrote : IwConfig.txt

apport information

TomasHnyk (sup) wrote : Lspci.txt

apport information

TomasHnyk (sup) wrote : Lsusb.txt

apport information

apport information

apport information

apport information

apport information

apport information

TomasHnyk (sup) wrote : RfKill.txt

apport information

TomasHnyk (sup) wrote : UdevDb.txt

apport information

TomasHnyk (sup) wrote : UdevLog.txt

apport information

apport information

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Martin Pitt (pitti) wrote :

There is not enough description here to be sure, but tentatively moving to mountall. /etc/init/mountall.conf and /etc/init/network-manager.conf both source /etc/default/locale. You can try commenting out this block in /etc/init/mountall.conf and see whether that works around the problem:

    # set $LANG so that messages appearing in plymouth are translated
    if [ -r /etc/default/locale ]; then
        . /etc/default/locale
        export LANG LANGUAGE LC_MESSAGES LC_ALL
    fi

affects: linux (Ubuntu) → mountall (Ubuntu)
TomasHnyk (sup) wrote :

Yeah, I think you spotted it. Commenting this out makes the system boot but network manager does not start.

Steve Langasek (vorlon) on 2013-06-19
Changed in mountall (Ubuntu):
status: Confirmed → Triaged
Steve Langasek (vorlon) on 2013-06-19
Changed in mountall (Ubuntu):
importance: Undecided → Medium
TomasHnyk (sup) wrote :

BTW: should not network manager be listed as affected too? (per comment #19)

Steve Langasek (vorlon) on 2013-06-29
Changed in mountall (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mountall - 2.49

---------------
mountall (2.49) unstable; urgency=low

  [ James Hunt ]
  * apport/mountall.py: add a mountall apport hook.

  [ Steve Langasek ]
  * Ignore parse errors in /etc/default/rcS or /etc/default/locale; these
    problems shouldn't be allowed to prevent the system from booting.
    LP: #1192514.

 -- Steve Langasek <email address hidden> Tue, 02 Jul 2013 15:51:12 -0700

Changed in mountall (Ubuntu):
status: Fix Committed → Fix Released
TomasHnyk (sup) wrote :

Thanks for the fix. Should I open this againt networkmanager as well?

TomasHnyk (sup) wrote :

Hm, it seems Network Manager has the same problem as mountall in this file: http://bazaar.launchpad.net/~ubuntu-branches/ubuntu/saucy/network-manager/saucy/view/head:/debian/network-manager.upstart

Line 18 . /etc/default/locale
shoud be changed to
 . /etc/default/locale || true

I tried downloading the bazaar branch of network-manager but it is out of date and I am not on Saucy so I could not test it and I gave up, but this does not seem to be hard to fix.

I wonder if there are other packages affected by the same bug, is there a way to somehow grep over all of ubuntu's archive?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers