Ubuntu

DUN via bluetooth with a password fails

Reported by Ritesh Khadgaray on 2013-05-31
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
NetworkManager
Fix Released
Medium
network-manager (Ubuntu)
High
Mathieu Trudel-Lapierre
Precise
High
Unassigned
Quantal
High
Unassigned
Raring
High
Mathieu Trudel-Lapierre

Bug Description

[Impact]

 * Unable to connect to a DUN n/w via bluetooth .

[Test Case]

 * Create a bluetooth connection via DUN capable device ( Nokia 6680) using bluetooth settings from gnome-control-center .
 * I have posted a sample connection created below, with username and password keyed in manually

$ cat /etc/NetworkManager/system-connection/example
[connection]
id=Mobil-BT connection
uuid=c57749ea-92fb-4297-8db4-875b66b3319a
type=bluetooth
autoconnect=false

[bluetooth]
bdaddr=00:16:4E:24:EA:2F
type=dun

[gsm]
number=*99#
apn=apn.example.com
username=userexample
password=secret

[serial]
baud=115200

 * Click on the connection from network icon in panel

[Regression Potential]

 * I dont see any regression potential with the patch for precise/raring/saucy.
 * This looks good as per upstream
 * Fixes issue with dun connection, and works fine with PAN (bt) and phone as modem.

[Other Info]

 * Upstream - https://bugzilla.gnome.org/show_bug.cgi?id=701507 .

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in network-manager (Ubuntu):
status: New → Confirmed
Changed in network-manager:
importance: Unknown → Medium
status: Unknown → New
description: updated
Changed in network-manager:
status: New → In Progress
Adam Stokes (adam-stokes) wrote :

Ritesh,

We need a quantal debdiff for this SRU as well could you please try to have that done by tomorrow?

Thanks
Adam

Let's wait for this patch to be landed in upstream master tree, then I'll happily push it to saucy and raring... for precise and quantal it may require some rework.

I've notified Jiri that I'm curious how ready the patch is to get merged.

Changed in network-manager (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → High
assignee: nobody → Mathieu Trudel-Lapierre (mathieu-tl)
Changed in network-manager (Ubuntu Precise):
status: New → Triaged
Changed in network-manager (Ubuntu Quantal):
status: New → Triaged
Changed in network-manager (Ubuntu Raring):
status: New → Triaged
Changed in network-manager (Ubuntu Precise):
importance: Undecided → High
Changed in network-manager (Ubuntu Quantal):
importance: Undecided → High
Changed in network-manager (Ubuntu Raring):
importance: Undecided → High
assignee: nobody → Mathieu Trudel-Lapierre (mathieu-tl)
Ritesh Khadgaray (khadgaray) wrote :
Ritesh Khadgaray (khadgaray) wrote :
Changed in network-manager:
status: In Progress → Fix Released
Iain Lane (laney) wrote :

I pushed this to n-m's bzr but I won't upload - Mathieu can do that if he's happy. Also didn't do anything with the SRU. Thanks for the fix :-)

Changed in network-manager (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package network-manager - 0.9.8.0-0ubuntu22

---------------
network-manager (0.9.8.0-0ubuntu22) saucy; urgency=low

  [ Ritesh Khadgaray ]
  * debian/patches/bluetooth.patch: DUN via bluetooth fails (lp: #1186273)

  [ Mathieu Trudel-Lapierre ]
  * debian/patches/track_ip_settings_post_connection.patch: Track IP Settings
    in an oFono schema; so that we're notified and can properly bring down a
    connection when bad things happen.
 -- Mathieu Trudel-Lapierre <email address hidden> Fri, 04 Oct 2013 11:57:41 -0400

Changed in network-manager (Ubuntu):
status: Fix Committed → Fix Released
Ritesh Khadgaray (khadgaray) wrote :
Ritesh Khadgaray (khadgaray) wrote :
Marc Deslauriers (mdeslaur) wrote :

Thanks for the precise, quantal and raring debdiffs. They look good, ACK.

I've uploaded them for processing by the SRU team, with a minor change in the version number to prevent collisions.

Thanks!

Hello Ritesh, or anyone else affected,

Accepted network-manager into raring-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/network-manager/0.9.8.0-0ubuntu6.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in network-manager (Ubuntu Raring):
status: Triaged → Fix Committed
tags: added: verification-needed
Changed in network-manager (Ubuntu Quantal):
status: Triaged → Fix Committed
Stéphane Graber (stgraber) wrote :

Hello Ritesh, or anyone else affected,

Accepted network-manager into quantal-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/network-manager/0.9.6.0-0ubuntu7.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in network-manager (Ubuntu Precise):
status: Triaged → Fix Committed
Stéphane Graber (stgraber) wrote :

Hello Ritesh, or anyone else affected,

Accepted network-manager into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/network-manager/0.9.4.0-0ubuntu4.4 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

As a part of the Stable Release Updates quality process a search for Launchpad bug reports using the version of network-manager from precise-proposed was performed and bug 1255592 was found. Please investigate this bug report to ensure that a regression will not be created by this SRU. In the event that this is not a regression remove the "verification-failed" tag from this bug report and tag 1255592 "bot-stop-nagging". Thanks!

tags: added: verification-failed

Hi Ritesh, can you confirm the patch works for precise?
the package is still in precise-propsed queue!

Ritesh Khadgaray (khadgaray) wrote :

Hi

  Sorry, I do not have the h/w to test this. The code does seem fine to me ( does not touch ipv6) , and is straight backport of the upstream.

- ritz

Chris J Arges (arges) on 2014-01-13
summary: - DUN via bluetooth fails
+ DUN via bluetooth with a password fails
Chris J Arges (arges) wrote :

This bug is difficult to verify because it requires a DUN capable handset as well as an APN that uses a username and password. If it cannot be verified perhaps it should be rejected so that other fixes can be SRUed for stable releases.

This code is a backport from upstream, I don't think there is a real need to test it again, it is part of the new network-manager so far, and work without any issues.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package network-manager - 0.9.8.0-0ubuntu6.1

---------------
network-manager (0.9.8.0-0ubuntu6.1) raring; urgency=low

  * debian/patches/bluetooth.patch: DUN via bluetooth fails (lp: #1186273)
 -- Ritesh Khadgaray <email address hidden> Tue, 08 Oct 2013 21:51:50 +0530

Changed in network-manager (Ubuntu Raring):
status: Fix Committed → Fix Released
Jonathan Davies (jpds) on 2014-02-04
tags: added: verification-done
removed: verification-failed verification-needed
Chris Halse Rogers (raof) wrote :

@jpds - What releases have you tested this on? Is it verification-done for precise and quantal?

tags: added: verification-needed
removed: verification-done

As a part of the Stable Release Updates quality process a search for Launchpad bug reports using the version of network-manager from precise-proposed was performed and bug 1255592 was found. Please investigate this bug report to ensure that a regression will not be created by this SRU. In the event that this is not a regression remove the "verification-failed" tag from this bug report and tag 1255592 "bot-stop-nagging". Thanks!

tags: added: verification-failed
tags: removed: verification-failed
Adam Conrad (adconrad) wrote :

Removing the precise and quantal SRUs for this, as no one's stepped up to verify these, and they're blocking further network-manager SRUs. If someone comes forward to do some testing, we can re-upload this patch over the newer uploads.

Changed in network-manager (Ubuntu Precise):
status: Fix Committed → Confirmed
Changed in network-manager (Ubuntu Quantal):
status: Fix Committed → Confirmed
tags: added: verification-done
removed: verification-needed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.