NetworkManager[14155]: <warn> nl_recvmsgs() error: (-33) Dump inconsistency detected, interrupted

Bug #1118446 reported by Robbie Williamson on 2013-02-07
468
This bug affects 95 people
Affects Status Importance Assigned to Milestone
network-manager (Ubuntu)
High
Unassigned

Bug Description

I see the following messages in /var/log/syslog:
  NetworkManager[14155]: <warn> nl_recvmsgs() error: (-33) Dump inconsistency detected, interrupted

When it goes down, I have to bounce network-manager to resolve it.

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: network-manager 0.9.7.995+git201301311547.17123fc-0ubuntu1
ProcVersionSignature: Ubuntu 3.8.0-4.8-generic 3.8.0-rc6
Uname: Linux 3.8.0-4-generic x86_64
ApportVersion: 2.8-0ubuntu4
Architecture: amd64
Date: Thu Feb 7 08:59:00 2013
IfupdownConfig:
 # interfaces(5) file used by ifup(8) and ifdown(8)
 auto lo
 iface lo inet loopback
InstallationDate: Installed on 2013-01-26 (12 days ago)
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Release amd64 (20121017.5)
IpRoute:
 default via 10.0.1.1 dev wlan0 proto static
 10.0.1.0/24 dev wlan0 proto kernel scope link src 10.0.1.11 metric 9
 169.254.0.0/16 dev wlan0 scope link metric 1000
MarkForUpload: True
NetworkManager.state:
 [main]
 NetworkingEnabled=true
 WirelessEnabled=true
 WWANEnabled=true
 WimaxEnabled=true
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: network-manager
UpgradeStatus: Upgraded to raring on 2013-01-26 (11 days ago)
nmcli-con:
 NAME UUID TYPE TIMESTAMP TIMESTAMP-REAL AUTOCONNECT READONLY DBUS-PATH
 Ubuntu ac3b296c-3250-4464-8ee0-ebd6e5d8e9ca 802-11-wireless 1360249035 Thu 07 Feb 2013 08:57:15 AM CST yes no /org/freedesktop/NetworkManager/Settings/2
 Palms 2e5ef890-c77c-466e-92ee-d9dcb777cf12 802-11-wireless 1359750784 Fri 01 Feb 2013 02:33:04 PM CST yes no /org/freedesktop/NetworkManager/Settings/1
 MIA-WiFi ea25a58d-9cb8-48a8-843a-2dc3231a1e17 802-11-wireless 1359754973 Fri 01 Feb 2013 03:42:53 PM CST yes no /org/freedesktop/NetworkManager/Settings/0
nmcli-dev:
 DEVICE TYPE STATE DBUS-PATH
 wlan0 802-11-wireless connected /org/freedesktop/NetworkManager/Devices/0
nmcli-nm:
 RUNNING VERSION STATE NET-ENABLED WIFI-HARDWARE WIFI WWAN-HARDWARE WWAN
 running 0.9.7.995 connected enabled enabled enabled enabled enabled

Robbie Williamson (robbiew) wrote :
Changed in network-manager (Ubuntu):
status: New → Confirmed
Robbie Williamson (robbiew) wrote :

I'm going to disable 11n to see if this is just the same old Intel-can't-do-11n-well issue we've had for a few releases.

Robbie Williamson (robbiew) wrote :

So no drops since I enabled the 11n_disable option. It appears iwlwifi support for 11n hasn't progressed as much as I'd hope. :/

Changed in network-manager (Ubuntu):
status: Confirmed → Invalid

Let's keep this bug open to track that specific netlink message though, I want to get that fixed as soon as possible, or at least we need to be very sure it doesn't break things.

So far, I certainly haven't noticed any adverse effects, and it's been showing up for a while, but since it's netlink, we need to either fix whatever bug there may be there, so silence the unnecessary warning.

summary: - Network Manager randomly dropping wifi
+ NetworkManager[14155]: <warn> nl_recvmsgs() error: (-33) Dump
+ inconsistency detected, interrupted
Changed in network-manager (Ubuntu):
status: Invalid → Triaged
importance: Undecided → High
assignee: nobody → Mathieu Trudel-Lapierre (mathieu-tl)
Robbie Williamson (robbiew) wrote :

So, I'm still seeing this message with 11n disabled, just not as often...I've also noticed that name resolution temporarily stops working immediately after the message gets logged.

Steve Magoun (smagoun) wrote :

I just saw this on a MacbookPro3,1 with Atheros wireless (AR5418 Wireless Network Adapter [AR5008E 802.11(a)bgn]). I'm running 13.04, and I have the 3.8.0-8.17 kernel.

I'm connected to an 802.11 network in the 5GHz spectrum. Similar to comment #5 I lost name resolution. Other than "Dump inconsistency" message in syslog, there is no indication in dmesg or syslog that something is amiss. Unloading/reloading the ath9k driver worked around the problem for me.

The AP I'm connected to is a Cisco of some sort; I can get details if necessary.

Seth Arnold (seth-arnold) wrote :

I see these messages too:

Apr 4 16:03:56 hunt NetworkManager[1321]: <warn> nl_recvmsgs() error: (-33) Dump inconsistency detected, interrupted

Connected to 2.4ghz wifi using:
03:00.0 Network controller: Intel Corporation Centrino Wireless-N 2200 (rev c4)

I've also got a (usually disconnected) ethernet:
00:19.0 Ethernet controller: Intel Corporation 82579LM Gigabit Network Connection (rev 04)

I've experienced several small "stalls", where networking cut out for a short while, but I sadly did not check logs at the time, and cannot say if these log messages are related or unrelated.

I'd be happy to provide whatever details I can. Thanks.

I have the same problem, follow the details

Jun 8 13:11:12 - NetworkManager[1016]: <warn> nl_recvmsgs() error: (-33) Dump inconsistency detected, interrupted

Connected to 802.11bg 2.4ghz wifi using:
03:00.0 Network controller: Intel Corporation Centrino Wireless-N 1030 [Rainbow Peak] (rev 34)

Another error that appears always:
iwlwifi 0000:03:00.0: fail to flush all tx fifo queues

Ubuntu 13.04
Kernel 3.8.0-23-generic #34-Ubuntu SMP Wed May 29 20:22:58 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

Anders Hall (a.hall) wrote :

confirmed

kernel
Linux boll 3.8.0-25-generic #37-Ubuntu SMP Thu Jun 6 20:47:07 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

syslog
Jun 11 14:08:30 boll ntpdate[11386]: adjust time server 91.189.94.4 offset 0.014650 sec
Jun 11 14:08:38 boll NetworkManager[1246]: <warn> nl_recvmsgs() error: (-33) Dump inconsistency detected, interrupted
Jun 11 14:08:38 boll NetworkManager[1246]: <warn> nl_recvmsgs() error: (-33) Dump inconsistency detected, interrupted
Jun 11 14:08:39 boll NetworkManager[1246]: <info> (wlan0): IP6 addrconf timed out or failed.
Jun 11 14:08:39 boll NetworkManager[1246]: <info> Activation (wlan0) Stage 4 of 5 (IPv6 Configure Timeout) scheduled...
Jun 11 14:08:39 boll NetworkManager[1246]: <info> Activation (wlan0) Stage 4 of 5 (IPv6 Configure Timeout) started...
Jun 11 14:08:39 boll NetworkManager[1246]: <info> Activation (wlan0) Stage 4 of 5 (IPv6 Configure Timeout) complete.

card
03:00.0 Network controller: Intel Corporation Centrino Advanced-N 6205 [Taylor Peak] (rev 34)

Waqas Ashraf (waqas7ashraf) wrote :

uname -a
Linux wcomp 3.8.0-25-generic #37-Ubuntu SMP Thu Jun 6 20:47:30 UTC 2013 i686 i686 i686 GNU/Linux

syslog after changing network manager log to debug

Jul 9 00:01:21 wcomp NetworkManager[6880]: <debug> [1373292081.248767] [nm-ip6-manager.c:1340] netlink_notification(): netlink event type 16
Jul 9 00:01:21 wcomp NetworkManager[6880]: <debug> [1373292081.248824] [nm-ip6-manager.c:1301] process_newlink(): ignoring netlink message family 0
Jul 9 00:01:21 wcomp NetworkManager[6880]: <debug> [1373292081.248864] [nm-netlink-monitor.c:164] link_msg_handler(): netlink link message: iface idx 3 flags 0x11043
Jul 9 00:01:21 wcomp NetworkManager[6880]: <debug> [1373292081.254649] [nm-device-wifi.c:518] get_active_ap(): (wlan0): active BSSID:
Jul 9 00:01:21 wcomp NetworkManager[6880]: <debug> [1373292081.254741] [nm-device-wifi.c:528] get_active_ap(): (wlan0): active SSID: '<myssid>'
Jul 9 00:01:21 wcomp NetworkManager[6880]: <debug> [1373292081.254834] [nm-device-wifi.c:538] get_active_ap(): Pass #1
Jul 9 00:01:21 wcomp NetworkManager[6880]: <debug> [1373292081.254858] [nm-device-wifi.c:554] get_active_ap(): AP: 'Belkin.******'
Jul 9 00:01:21 wcomp NetworkManager[6880]: <debug> [1373292081.254873] [nm-device-wifi.c:562] get_active_ap(): BSSID mismatch
Jul 9 00:01:21 wcomp NetworkManager[6880]: <debug> [1373292081.254891] [nm-device-wifi.c:554] get_active_ap(): AP: 'Belkin.****'
Jul 9 00:01:21 wcomp NetworkManager[6880]: <debug> [1373292081.254904] [nm-device-wifi.c:562] get_active_ap(): BSSID mismatch
Jul 9 00:01:21 wcomp NetworkManager[6880]: <debug> [1373292081.254921] [nm-device-wifi.c:554] get_active_ap(): AP: 'BigPond*****'
Jul 9 00:01:21 wcomp NetworkManager[6880]: <debug> [1373292081.254933] [nm-device-wifi.c:562] get_active_ap(): BSSID mismatch
Jul 9 00:01:21 wcomp NetworkManager[6880]: <debug> [1373292081.254949] [nm-device-wifi.c:554] get_active_ap(): AP: '<myrouterconnection>'
Jul 9 00:01:21 wcomp NetworkManager[6880]: <debug> [1373292081.254970] [nm-device-wifi.c:594] get_active_ap(): matched
Jul 9 00:01:21 wcomp NetworkManager[6880]: <warn> nl_recvmsgs() error: (-33) Dump inconsistency detected, interrupted

Quite often when this happens, my mouse also loses control, is if its a hacking attempt, or as if my computer has been successfully hijacked for a little while. Don't see anything else wrong with the system. Have been updating the system as the ubuntu updates have become available. I started investigating this problem, because my mouse would start running on its own.

Would really like to know the solution to this problem.

Waqas

tmccool (tjmcwiz-y) wrote :

Same issue here

Jul 9 14:32:04 Machine NetworkManager[982]: <warn> nl_recvmsgs() error: (-33) Dump inconsistency detected, interrupted
Jul 9 15:16:04 Machine NetworkManager[982]: <warn> nl_recvmsgs() error: (-33) Dump inconsistency detected, interrupted

uname -a

Linux Machine 3.8.0-26-generic #38-Ubuntu SMP Mon Jun 17 21:43:33 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

Same issue here as well

Jul 11 09:07:36 trinity NetworkManager[1142]: <warn> nl_recvmsgs() error: (-33) Dump inconsistency detected, interrupted
Jul 11 09:10:41 trinity NetworkManager[1142]: <warn> nl_recvmsgs() error: (-33) Dump inconsistency detected, interrupted

I loose all network connectivity (to an eduroam/WPA2 Enterprise wirless network) after the first log message occurs

uname - a

Linux trinity 3.8.0-27-generic #40-Ubuntu SMP Tue Jul 9 00:17:05 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

lspci |grep -i network

03:00.0 Network controller: Intel Corporation Centrino Advanced-N 6205 [Taylor Peak] (rev 34)

Artur Krysiak (ventharin) wrote :

The same here. It occurs almost every time after resuming from suspension.

errors from syslog:
Jul 12 18:01:40 cuguar NetworkManager[1067]: <warn> nl_recvmsgs() error: (-33) Dump inconsistency detected, interrupted
Jul 12 18:13:54 cuguar kernel: [10316.008485] usbhid: probe of 3-4:1.0 failed with error -71
Jul 12 18:23:40 cuguar kernel: [10352.931683] usbhid: probe of 3-4:1.0 failed with error -71

uname -a
Linux cuguar 3.8.0-26-generic #38-Ubuntu SMP Mon Jun 17 21:43:33 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

lspci |grep -i network
03:00.0 Network controller: Intel Corporation Centrino Advanced-N 6205 [Taylor Peak] (rev 96)

Which logs may I provide to help resolving this issue?

Paul Abrahams (abrahams) wrote :

I'm running Kubuntu 12.04. How do I disable 11n?

Brad Johnson (johnsonbrad1) wrote :

I too am running into this, and can confirm the mouse lag as reported above, although this is rare for me. I have also been running speedtests, and have noticed that the download speed seems to be the only one impacted by this.

ping(ms) down(Mbps) up(Mbps)
33 .1 1.2
19 .35 3.92
22 .71 3.76
18 .51 4.57

Linux mint 15

uname -a
Linux brad-laptop 3.8.0-29-generic #42-Ubuntu SMP Tue Aug 13 19:40:39 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

lspci | grep -i network
00:19.0 Ethernet controller: Intel Corporation 82567LM Gigabit Network Connection (rev 03)

syslog

Sep 26 23:18:56 brad-laptop NetworkManager[1204]: <warn> nl_recvmsgs() error: (-33) Dump inconsistency detected, interrupted
Sep 26 23:35:37 brad-laptop wpa_supplicant[2367]: wlan0: WPA: Group rekeying completed with 10:6f:3f:02:af:cd [GTK=TKIP]
Sep 26 23:38:56 brad-laptop NetworkManager[1204]: <warn> nl_recvmsgs() error: (-33) Dump inconsistency detected, interrupted

Lehel (gladia2r) wrote :

I'm seeing this as well in LinuxMint 15 | Dell XPS 15

Oct 4 12:40:06 lehel-Dell NetworkManager[1568]: <warn> nl_recvmsgs() error: (-33) Dump inconsistency detected, interrupted
-
Linux my-Dell 3.8.0-26-generic #38-Ubuntu SMP Mon Jun 17 21:43:33 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
-
03:00.0 Network controller: Intel Corporation Centrino Wireless-N 1030 [Rainbow Peak] (rev 34)

Boris (boris-woerner) wrote :

This started appearing after the upgrade to Ubuntu 13.10, before it didn't happen here.
Connected to 2.4GHz wireless, AP is ASUS RT-AC66U.
un-/reloading ath9k* modules doesn't help.

Oct 18 15:57:42 schlepptop NetworkManager[1166]: <warn> nl_recvmsgs() error: (-33) Dump inconsistency detected, interrupted

Linux schlepptop 3.11.0-12-generic #19-Ubuntu SMP Wed Oct 9 16:20:46 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

03:00.0 Network controller: Qualcomm Atheros AR9485 Wireless Network Adapter (rev 01)
 Subsystem: AzureWave Device 2c97

Sicco van Sas (sicco) wrote :

I am experiencing this error as well on Ubuntu 13.10. Afaik this didn't happen before upgrading in 13.04. The error appears exactly every two minutes!

Same problem since updating Linux Mint Debian Edition from a wheezy based to a jessie based distribution.

$ uname -a
Linux lilas 3.10-2-amd64 #1 SMP Debian 3.10.5-1 (2013-08-07) x86_64 GNU/Linux

Majestyx (majestyx) wrote :

nl_recvmsgs() error

Maybe it helps: i have exactly the same problems on a debian distri (at the moment i use only ubuntu servers, no ubu desktop is running on this LAN at the moment) i think it is problem whit nm-manager?!

Linux debian 3.10-3-amd64 #1 SMP Debian 3.10.11-1 (2013-09-10) x86_64 GNU/Linux

Majestyx (majestyx) wrote :

ok, sorry... now i have read full title... networkmanager....

mea culpa! (can't edit my last comment)

Me too.. :/

>Same problem since updating Linux Mint Debian Edition from a wheezy based to a jessie based distribution.

John Kerpel (john-kerpel) wrote :

I get this when I try to access RStudio server from a remote device (like a smartphone via browser) or from a laptop at Starbucks:

NetworkManager[825]: <warn> nl_recvmsgs() error: (-33) Dump inconsistency detected, interrupted

I didn't have this problem with 12.10, but it started with 13.04 and persists with 13.10. I'm trying to access RStudio server on my linux box via a browser on another device.

I'm a noob to Ubuntu - but I'd though I'd share. Thx!

Alessandro Polverini (polve) wrote :

I have the same problem on a Asus K53SC, this is the hardware as reported by lspci

03:00.0 Network controller: Qualcomm Atheros AR9285 Wireless Network Adapter (PCI-Express) (rev 01)

Jerry Ablan (lucifurious) wrote :

+1

0d:00.0 Network controller: Qualcomm Atheros AR9462 Wireless Network Adapter (rev 01)

Jan 7 13:51:41 jablan NetworkManager[1145]: <warn> nl_recvmsgs() error: (-33) Dump inconsistency detected, interrupted
Jan 7 13:51:43 jablan whoopsie[1355]: online
Jan 7 13:52:44 whoopsie[1355]: last message repeated 9 times
Jan 7 13:53:49 whoopsie[1355]: last message repeated 11 times
Jan 7 13:55:03 whoopsie[1355]: last message repeated 12 times
Jan 7 13:56:03 whoopsie[1355]: last message repeated 16 times
Jan 7 13:57:04 whoopsie[1355]: last message repeated 6 times
Jan 7 13:57:41 whoopsie[1355]: last message repeated 4 times
Jan 7 13:57:41 jablan NetworkManager[1145]: <warn> nl_recvmsgs() error: (-33) Dump inconsistency detected, interrupted
Jan 7 13:57:41 jablan NetworkManager[1145]: <warn> nl_recvmsgs() error: (-33) Dump inconsistency detected, interrupted
Jan 7 13:57:43 jablan whoopsie[1355]: online
Jan 7 13:58:44 whoopsie[1355]: last message repeated 12 times
Jan 7 13:59:41 whoopsie[1355]: last message repeated 7 times
Jan 7 13:59:41 jablan NetworkManager[1145]: <warn> nl_recvmsgs() error: (-33) Dump inconsistency detected, interrupted
Jan 7 13:59:41 jablan NetworkManager[1145]: <warn> nl_recvmsgs() error: (-33) Dump inconsistency detected, interrupted
Jan 7 13:59:43 jablan whoopsie[1355]: online

Same as the above, on 13.10 with
02:00.0 Network controller: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter (rev 01)

Also afected by this in Archlinux with 08:00.0 Network controller: Qualcomm Atheros AR9462 Wireless Network Adapter (rev 01) with network manager under cinnamon desktop.

anewguy (anewguy) wrote :

I also get these messages, and was told to report it and the following here:

dave@dave8500:~$ uname -a
Linux dave8500 3.11.0-15-generic #23-Ubuntu SMP Mon Dec 9 18:16:27 UTC 2013 i686 i686 i686 GNU/Linux
dave@dave8500:~$ lspci | grep -i network
02:03.0 Network controller: Intel Corporation PRO/Wireless 2200BG [Calexico2] Network Connection (rev 05)
dave@dave8500:~$

anewguy (anewguy) wrote :

Previous post was from my old laptop. This is the data from my desktop, where I continue getting the message also:

dave@davePC:~$ uname -a
Linux davePC 3.11.0-15-generic #23-Ubuntu SMP Mon Dec 9 18:17:04 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
dave@davePC:~$ lspci | grep -l network
dave@davePC:~$ lsusb
Bus 003 Device 003: ID 0d49:7100 Maxtor OneTouch II 300GB External Hard Disk
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 009 Device 002: ID 1058:1140 Western Digital Technologies, Inc. My Book Essential USB3.0
Bus 009 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 008 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 003: ID 0cf2:6230 ENE Technology, Inc.
Bus 002 Device 018: ID 13fe:4100 Kingston Technology Company Inc.
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 002: ID 148f:3072 Ralink Technology, Corp. RT3072 Wireless Adapter
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 002: ID 046d:c52e Logitech, Inc.
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
dave@davePC:~$

BadOmen (badomen02) wrote :

I do not disconnect when i get this <warn> nl_recvmsgs() error: (-33) Dump inconsistency detected, interrupted.
but I can see that a lot of them hapen on the same second(not minute).

I checked the wifisyslog.txt that was attached to this bug and it is also occurring at the same second most of the times.

uname -a
Linux jonas-E1 3.11.0-15-generic #23-Ubuntu SMP Mon Dec 9 18:17:04 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

part of lspci:
01:00.0 Ethernet controller: Broadcom Corporation NetXtreme BCM57786 Gigabit Ethernet PCIe (rev 01)
01:00.1 SD Host controller: Broadcom Corporation BCM57765/57785 SDXC/MMC Card Reader (rev 01)
02:00.0 Network controller: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter (rev 01)

part of systemlog:
2014-01-16 18.29.48 jonas-E1 NetworkManager[1084] <warn> nl_recvmsgs() error: (-33) Dump inconsistency detected, interrupted
2014-01-16 18.33.48 jonas-E1 NetworkManager[1084] <warn> nl_recvmsgs() error: (-33) Dump inconsistency detected, interrupted
2014-01-16 18.37.48 jonas-E1 NetworkManager[1084] <warn> nl_recvmsgs() error: (-33) Dump inconsistency detected, interrupted
2014-01-16 18.40.47 jonas-E1 wpa_supplicant[1122] wlan0: WPA: Group rekeying completed with bc:ee:7b:c3:53:28 [GTK=CCMP]
2014-01-16 18.45.48 jonas-E1 NetworkManager[1084] <warn> nl_recvmsgs() error: (-33) Dump inconsistency detected, interrupted
2014-01-16 18.49.48 jonas-E1 NetworkManager[1084] <warn> nl_recvmsgs() error: (-33) Dump inconsistency detected, interrupted
2014-01-16 18.57.48 jonas-E1 NetworkManager[1084] <warn> nl_recvmsgs() error: (-33) Dump inconsistency detected, interrupted
2014-01-16 19.01.48 jonas-E1 NetworkManager[1084] <warn> nl_recvmsgs() error: (-33) Dump inconsistency detected, interrupted
2014-01-16 19.09.48 jonas-E1 NetworkManager[1084] <warn> nl_recvmsgs() error: (-33) Dump inconsistency detected, interrupted
2014-01-16 19.15.48 jonas-E1 NetworkManager[1084] <warn> nl_recvmsgs() error: (-33) Dump inconsistency detected, interrupted
2014-01-16 19.17.01 jonas-E1 CRON[5228] (root) CMD ( cd / && run-parts --report /etc/cron.hourly)
2014-01-16 19.19.48 jonas-E1 NetworkManager[1084] <warn> nl_recvmsgs() error: (-33) Dump inconsistency detected, interrupted
2014-01-16 19.25.48 jonas-E1 NetworkManager[1084] <warn> nl_recvmsgs() error: (-33) Dump inconsistency detected, interrupted
2014-01-16 19.29.48 jonas-E1 NetworkManager[1084] <warn> nl_recvmsgs() error: (-33) Dump inconsistency detected, interrupted
2014-01-16 19.31.48 jonas-E1 NetworkManager[1084] <warn> nl_recvmsgs() error: (-33) Dump inconsistency detected, interrupted
2014-01-16 19.33.48 jonas-E1 NetworkManager[1084] <warn> nl_recvmsgs() error: (-33) Dump inconsistency detected, interrupted
2014-01-16 19.40.47 jonas-E1 wpa_supplicant[1122] wlan0: WPA: Group rekeying completed with bc:ee:7b:c3:53:28 [GTK=CCMP]
2014-01-16 19.43.48 jonas-E1 NetworkManager[1084] <warn> nl_recvmsgs() error: (-33) Dump inconsistency detected, interrupted

Paul (wegsehen) wrote :

Same here.

Linux arch 3.12.7-2-ARCH #1 SMP PREEMPT Sun Jan 12 13:09:09 CET 2014 x86_64 GNU/Linux

09:00.0 Network controller: Qualcomm Atheros AR9462 Wireless Network Adapter (rev 01)

DiegoV (diegofcviegas) wrote :

Some here.

02:00.0 Network controller: Qualcomm Atheros AR9285 Wireless Network Adapter (PCI-Express) (rev 01)

LaM (l.a.m.) wrote :

Same here....

Network: Card-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8169 ver: 2.3LK-NAPI port: d000 bus-ID: 05:00.0
           IF: eth0 state: down
           Card-2: Qualcomm Atheros AR9485 Wireless Network Adapter driver: ath9k bus-ID: 04:00.0
           IF: wlan0 state: up

Linux 3.11.0-14-generic #21-Ubuntu SMP Tue Nov 12 17:04:55 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

BadOmen (badomen02) wrote :

After I upgraded to kernel 3.13 I have not had this " <warn> nl_recvmsgs() error: (-33) Dump inconsistency detected, interrupted" problem any more. I am now using 3.14 and it also works great.

So see if it works for you too.

BTW after changing kernel from 3.11 to 3.13 and 3.14 I max out my internet connection 100/100 Mbps :D
Network controller: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter (rev 01)

Alex Turbov (zaufi) wrote :

root@gentop〉/etc/NetworkManager〉uname -r
3.13.3-gentoo-z1

root@gentop〉/etc/NetworkManager〉lspci | grep -i network
03:00.0 Network controller: Qualcomm Atheros AR9285 Wireless Network Adapter (PCI-Express) (rev 01)

--
net-misc/networkmanager-0.9.8.8, I still see this message. Connection (was) still alive after that...
A day ago (I've reboot my laptop after a week and a bunch of updates in gentoo), NM started to disconnect w/ "Reason 7" every 10 (or sometimes less) minutes...

Sasa Stamenkovic (umpirsky) wrote :

Same issue here.

$ lspci |grep -i network
02:00.0 Network controller: Qualcomm Atheros AR9485 Wireless Network Adapter (rev 01)

$ tail /var/log/syslog
Mar 19 12:54:52 asus whoopsie[1017]: online
Mar 19 12:56:02 whoopsie[1017]: last message repeated 2 times
Mar 19 12:57:02 whoopsie[1017]: last message repeated 3 times
Mar 19 12:58:05 asus whoopsie[1017]: online
Mar 19 12:59:32 whoopsie[1017]: last message repeated 2 times
Mar 19 13:00:32 whoopsie[1017]: last message repeated 3 times
Mar 19 13:01:20 asus whoopsie[1017]: online
Mar 19 13:02:32 whoopsie[1017]: last message repeated 2 times
Mar 19 13:02:50 asus NetworkManager[762]: <warn> nl_recvmsgs() error: (-33) Dump inconsistency detected, interrupted
Mar 19 13:02:59 asus whoopsie[1017]: online

Boskote (boskote) wrote :

I have also been getting these same log warning. As others have mentioned, the warnings all occur on the same second (though which second it is changes occasionally). Furthermore, in my case the minutes at which they occur have some regularity. The warnings are always an even number of minutes apart. In other words, the time between each one is always either 2, 4, 6, 8, 10, 12, or 14 minutes. 14 is the longest gap I have seen, and it seems to be most often 2, 4 or 6 minute gaps. I haven't noticed any detrimental impact on the wireless connection, but this shows up very regularly in my logs so I'm curious what is causing it.

[boskote@hp ~]$ uname -r
3.13.6-1-ARCH

[boskote@hp ~]$ lspci | grep -i network
03:00.0 Network controller: Ralink corp. RT5390 Wireless 802.11n 1T/1R PCIe

[boskote@hp ~]$ sudo journalctl -f
Mar 23 00:04:48 hp NetworkManager[276]: <warn> nl_recvmsgs() error: (-33) Dump inconsistency detected, interrupted
Mar 23 00:10:48 hp NetworkManager[276]: <warn> nl_recvmsgs() error: (-33) Dump inconsistency detected, interrupted
Mar 23 00:14:48 hp NetworkManager[276]: <warn> nl_recvmsgs() error: (-33) Dump inconsistency detected, interrupted
Mar 23 00:16:48 hp NetworkManager[276]: <warn> nl_recvmsgs() error: (-33) Dump inconsistency detected, interrupted
Mar 23 00:22:48 hp NetworkManager[276]: <warn> nl_recvmsgs() error: (-33) Dump inconsistency detected, interrupted
Mar 23 00:34:48 hp NetworkManager[276]: <warn> nl_recvmsgs() error: (-33) Dump inconsistency detected, interrupted
Mar 23 00:40:48 hp NetworkManager[276]: <warn> nl_recvmsgs() error: (-33) Dump inconsistency detected, interrupted
Mar 23 00:42:48 hp NetworkManager[276]: <warn> nl_recvmsgs() error: (-33) Dump inconsistency detected, interrupted
Mar 23 00:48:48 hp NetworkManager[276]: <warn> nl_recvmsgs() error: (-33) Dump inconsistency detected, interrupted
Mar 23 00:52:48 hp NetworkManager[276]: <warn> nl_recvmsgs() error: (-33) Dump inconsistency detected, interrupted
Mar 23 00:54:48 hp NetworkManager[276]: <warn> nl_recvmsgs() error: (-33) Dump inconsistency detected, interrupted

Nick Leverton (nick-leverton) wrote :

Seems from the linked commit that this message is officially benign, but will be fixed in a forthcoming
release.
http://cgit.freedesktop.org/NetworkManager/NetworkManager/commit/?id=e0a972461156c12ad1be40f4a4ed84705c4603aa

This warning disapeared after I removed "dnsmasq 2.59-4ubuntu0.1 ".

serj (serjfrolov) wrote :

I also have this problem.
After this error my wi-fi disconnected and can not connect for a long time.
Please, fix this bug quickly.

tail -f /var/log/syslog
Oct 31 16:27:26 ASUS NetworkManager[821]: <warn> nl_recvmsgs() error: (-33) Dump inconsistency detected, interrupted

serj@ASUS:~$ uname -a
Linux ASUS 3.13.0-24-generic #47-Ubuntu SMP Fri May 2 23:30:00 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

lspci | grep -i network
04:00.0 Network controller: Ralink corp. RT3290 Wireless 802.11n 1T/1R PCIe

Julian Stecklina (js-alien8) wrote :

Seeing this on Fedora 20 as well:

 NetworkManager-0.9.9.0-46.git20131003.fc20.x86_64
 Linux 3.17.2

Gannet (ken20001) on 2014-12-19
Changed in network-manager (Ubuntu):
status: Triaged → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in network-manager (Ubuntu):
status: New → Confirmed
RevEggplant (rrclark) wrote :

I can also add a report of similar conditions. I'm using a Toshiba Satellite C75D-A7370 with Realtek Semiconductor Co., Ltd. RTL8188EE Wireless Network Adapter (rev 01) aboard. I'm seeing the same errors after an initial Mint 17.1 installation. I'm authenticating wireless connection with a Linksys E1200 router with latest big set of dd-wrt firmware installed. I have no ipv6 enabled on the routing equipment. When I have ipv4 and ipv6 enabled in the wireless connection settings, I encounter network stoppages that recover when I cycle on/off the wireless card. When I disable ipv6 in the wireless connection settings, the problem is resolved and I run fine. Please check your connection settings, folks, and if you're not routing ipv6, turn off the ipv6 setting on your network connection settings.

Love, Reverend Egg Plant

Joseph Lust (lifeoflust) wrote :

Similar problem. Twice in last week ThinkPad X220 4287-2VU has frozen and restarted. Tracing back through syslog, this is the final entry.

Feb 18 16:54:18 jorge wpa_supplicant[1534]: wlan0: CTRL-EVENT-SCAN-STARTED
Feb 18 16:54:18 jorge wpa_supplicant[1534]: nl80211: send_and_recv->nl_recvmsgs failed: -33
Feb 18 16:56:18 jorge wpa_supplicant[1534]: wlan0: CTRL-EVENT-SCAN-STARTED
Feb 18 16:56:18 jorge wpa_supplicant[1534]: nl80211: send_and_recv->nl_recvmsgs failed: -33
Feb 18 16:58:18 jorge wpa_supplicant[1534]: wlan0: CTRL-EVENT-SCAN-STARTED
Feb 18 16:58:18 jorge wpa_supplicant[1534]: nl80211: send_and_recv->nl_recvmsgs failed: -33
Feb 18 17:00:18 jorge wpa_supplicant[1534]: wlan0: CTRL-EVENT-SCAN-STARTED
Feb 18 17:00:18 jorge wpa_supplicant[1534]: nl80211: send_and_recv->nl_recvmsgs failed: -33
Feb 18 17:02:18 jorge wpa_supplicant[1534]: wlan0: CTRL-EVENT-SCAN-STARTED
Feb 18 17:02:18 jorge wpa_supplicant[1534]: nl80211: send_and_recv->nl_recvmsgs failed: -33
Feb 18 17:02:50 jorge NetworkManager[1350]: <warn> nl_recvmsgs() error: (-33) Dump inconsistency detected, interrup$

Ubuntu 14.04.1 LTS. Intel Chipset. Note: I do have a ipv6 address from this AP.

Manufacturer of wlan0: 74:e5:0b (Intel)
Manufacturer of AP: C4:14:3C (Cisco)

This message appearing has been fixed in 15.04.

As for those of you who are having issues with wifi performance, stalls and whatnot, please file your own separate bug: this is important so we can address all issues individually, and so that we have all the information necessary to fix *your* bug.

Since the message is benign (ie. it wouldn't be the cause of stalls or anything like that), I'm tempted *not* to fix this as SRU since it both takes time and has the risk of introducing regressions; unless we find another critical bug in the same release that might fit well with it. If you feel strongly about it being fixed for a particular release, please follow the steps at http://wiki.ubuntu.com/StableReleaseUpdates to request an update.

Changed in network-manager (Ubuntu):
status: Confirmed → Fix Released
assignee: Mathieu Trudel-Lapierre (mathieu-tl) → nobody
Vibhav Chaddha (vibhav05) wrote :

Is this issue fixed? And where will I get that fix from?

peitian (foxbryant) wrote :

I want to know which versifon fixed the bug. I installed network-manager 0.9.8.8-0ubuntu7.3 but still occurs this issue.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers