network-manager unreliable with multiple APs

Bug #111502 reported by Erik on 2007-05-01
132
This bug affects 24 people
Affects Status Importance Assigned to Milestone
NetworkManager
Expired
High
network-manager (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: network-manager

Ubuntu 7.04 (PPC)
Broadcom 4306 (bcm43xx driver)

Network manager is totally unreliable when I use it at my University, where there are multiple APs.

It drops the connection all the time, and when (more like if) it manages to reconnect it doesn't re-establish the lost VPN connection. I am trying to connect to this one wireless network, "central" - there is one AP on channel 1 and one on channel 11. It works fine if I configure my device manually through iwconfig to channel 1, maybe n-m tries to keep switching between the two or something, then occasionally it just randomly roams to a completely different network for no reason. This should be apparent from my daemon.log.

All the APs are of similar strength, and as I said they work fine configured manually without n-m which has been a complete pain in the backside ever since it was included in Feisty.

Erik (echakr) wrote :
Erik (echakr) wrote :

I will add that network-manager usually works OK when at home where there is just one strong signal from my own AP, perhaps because there are no others that it could try to roam to as others in the area are WEP encrypted.

If network-manager is roaming around between open networks treating them all as equal this is nonsense logic. It is not always preferable to be on the strongest open network - why can't network manager just accept that I want to connect to *this one* and just configure my card for that and leave it be until I tell it to change?

Kai-Uwe Widany (kwidany) wrote :

I have similar Problems. Connection drops from time to time on Networks with many access points. Because my system is a bit different (Ubuntu 7.04 (i386), ipw2200), I think this problem may be related to network-manager.

Alexander Sack (asac) wrote :

could you please check if this issue is still present in latest gutsy network-manager 0.6.5-0ubuntu15 or above?

Thanks,
 - Alexander

Changed in network-manager:
importance: Undecided → Medium
status: New → Incomplete
Alexander Sack (asac) on 2007-10-18
Changed in network-manager:
status: Incomplete → New
Alexander Sack (asac) wrote :

could you please check if this issue is still present in latest gutsy network-manager?

Changed in network-manager:
status: New → Incomplete
Stefano Rivera (stefanor) wrote :

I have been seeing similar problems in gutsy, but not necessarily with the latest version. I will go to my university library (with many APs) and test...

Uroš Gaber (uros-gaber) on 2007-11-10
Changed in network-manager:
status: Incomplete → Confirmed
Dave Kristol (dmk-launchpad) wrote :

[Ubuntu Hardy]

My home WiFi network comprises two access points. One of them broadcasts its SSID (only because it has no provision to turn that off) and the other does not. I have used Network Manager to configure a static IP address for my laptop. "iwlist scan" seems to be erratic as to which of the APs it sees, if any, even when iwconfig shows I'm connected to an access point, and even when I'm sitting right next to one of the APs.

I expect to be able to roam between the APs, but that does not seem to work. When I move around the house, my connection seems to stay associated, or tries to stay associated, with the access point I first connected to when I resume the laptop from suspend. If I move from near one AP to the other, and the signal strength shifts, the system does not change its association. If I move out of range of the first AP but well within range of the second, the system still does not assocate with the second one.

If I'm sitting next to the non-broadcasting AP and do "ifdown wlan0;ifup wlan0", the system does not pick up the closer (and stronger) AP.

I have to add that Fedora Core 6 handled these transitions quite nicely (albeit with a different laptop).

Alexander Sack (asac) wrote :

could someone please try to reproduce this in intrepid? and attach a complete syslog after reproducing if the problem still exists there? Thanks.

Alexander Sack (asac) wrote :

need a confirm if this still happens. If this only happens with some drivers then its most likely a driver bug.

Changed in network-manager:
status: Confirmed → Incomplete
Madko (madko) wrote :

same problem here in intrepid.

Alexander Sack (asac) wrote :

Madko, please give us more info about the driver/chipset you are using please. Also attach the complete syslog taken after reproducing the "multiple AP" unstability.

 We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in network-manager:
status: Incomplete → Invalid
xrayA4T (xraya4t) wrote :

I have the following situation on Intrepid.

I will be logged into the wifi network at the office and suspend my laptop to go home. When I get home and turn on the laptop I get the connecting network manager icon with one green dot and spinning like it is trying to get a DHCP IP address. If I then click on the connecting icon I get a list of wiifi networks including all the work wifi negtworks and my home wifi network, all with a signal level. The list shows that I am connected to the work wifi network still. I then need to click on my home network to connect.

What do I need to run to collect relevant data to help solve this problem? Is a possible solution to restart networking on resume?
Thanks
Ray

xrayA4T (xraya4t) wrote :

bug was marked as closed as no one was sending data to assist on solving the issue. I am willing to help gather data.
Ray

Changed in network-manager:
status: Invalid → Incomplete

xrayA4t, thanks for helping us. Could you please add the /var/log/syslog to your bug report as an attachment after reproducing the "multiple AP" unstability? Also you can submit more information for it by looking to https://wiki.ubuntu.com/DebuggingNetworkManager; especially the driver log may be important in this case, Thanks in advance.

xrayA4T (xraya4t) wrote :

Hi, I've attached my syslog. I unfortunately did not have debugging on which I have now done and will submit an updated one when this happens again.

In the log there are two connection events. On Feb 11 after 8pm (there is a gap in log times before that) I unsuspended my laptop having been at work on the "315" AP. The machine asked from the gnome screensaver password and connected fine to the "barbour" AP. On Feb 12 after 6am (again there is a gap in log times before that) I again unsuspended my laptop having been on the "barbour" AP. It should have tried to connect to the "315" but attempted to connect to "barbour". It then prompted me to re-enter my WPA key which I left waiting. I then grabbed the syslog. While I was check up on a separate machine on what else to capture I noticed the network connect. It connected to the "315" AP successfully. I captured the syslog again a bit later but there is a gap between the two.

xrayA4T (xraya4t) wrote :

second syslog

xrayA4T (xraya4t) wrote :

Hi, Just got home and tried again and has similar issues. I've attached the syslog. I waited a couple of minutes between resuming the laptop and entering in the screen-saver password to see if that made a difference. It appears from the log that when it fails to connect to the AP it assumes that the key is wrong rather than that the AP is no longer there and prompts for a new key. In this case I cancelled the key and it then appears it tries to connect to the next AP in the list which is my work list and attempted to connect to "absa_connectivity1" (or something) I then selected the correct AP from the list and successfully connected to that.

One possible solution would be to rescan for APs on resume and then attempt to connect to the known networks it can now find. This might slow down reconnection to the same AP if you just suspend the machine and try and reconnect on resume. It might be an option to have a quick reconnect option that will use the current behaviour where it tries to reconnect to the same AP on resume if you hardly ever connect to other APs but if you do like I do, one at work and one at home a rescan option might be preferable.
Ray

Jeremy Nickurak (nickurak) wrote :
Download full text (26.6 KiB)

I've been seeing this for ages with intrepid, and now jaunty.

Occasionaly, telling network-manager to reconnect by just re-selecting the ESSID again, or killing wpa_supplicant helps.

It frequently tries to connect to non-ideal AP's. In fact, looking at wpa_supplicant.log, it appears to never be trying any of the strongest AP's available.

The ESS ID i'm trying to connect to is UWS. The strengths of the various AP's are as follows:

UWS: 25/100 00:1E:7A:A7:5B:EE
UWS: 43/100 00:1E:7A:A7:5B:E1
UWS: 49/100 00:1E:4A:56:97:F1
UWS: 49/100 00:1E:7A:A7:53:01
UWS: 55/100 00:1E:4A:56:8E:B1
UWS: 65/100 00:1E:7A:A7:58:6E
UWS: 71/100 00:1E:7A:A7:58:61
UWS: 72/100 00:1E:7A:A7:58:41

I'm attaching syslog, wpa_supplicant.log, and the output from sudo iwlist scanning is below:

wlan0 Scan completed :
          Cell 01 - Address: 00:1E:7A:A7:58:61
                    ESSID:"UWS"
                    Mode:Master
                    Channel:1
                    Frequency:2.412 GHz (Channel 1)
                    Quality=71/100 Signal level:-63 dBm Noise level=-96 dBm
                    Encryption key:on
                    IE: Unknown: 0003555753
                    IE: Unknown: 01080B0C129618243048
                    IE: Unknown: 030101
                    IE: Unknown: 0706434120010B1A
                    IE: Unknown: 2A0100
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (1) : CCMP
                        Authentication Suites (1) : 802.1x
                    IE: Unknown: 3202606C
                    IE: Unknown: 9606004096000B00
                    IE: WPA Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (1) : TKIP
                        Authentication Suites (1) : 802.1x
                    IE: Unknown: DD06004096010104
                    IE: Unknown: DD050040960305
                    IE: Unknown: DD050040960B09
                    IE: Unknown: DD050040961401
                    Bit Rates:5.5 Mb/s; 6 Mb/s; 9 Mb/s; 11 Mb/s; 12 Mb/s
                              18 Mb/s; 24 Mb/s; 36 Mb/s; 48 Mb/s; 54 Mb/s
                    Extra:tsf=000001342521c11b
                    Extra: Last beacon: 3820ms ago
          Cell 02 - Address: 00:1E:7A:A7:53:02
                    ESSID:"eduroam"
                    Mode:Master
                    Channel:6
                    Frequency:2.437 GHz (Channel 6)
                    Quality=49/100 Signal level:-79 dBm Noise level=-96 dBm
                    Encryption key:on
                    IE: Unknown: 0007656475726F616D
                    IE: Unknown: 01080B0C129618243048
                    IE: Unknown: 030106
                    IE: Unknown: 0706434120010B1A
                    IE: Unknown: 2A0100
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (1) : CCMP
                        Authentication Suites (1) : 802.1x
                    IE: Unknown: 3202606C
                    IE: Unknown: 9606004096000B00
                    IE: WPA Version 1
                        Group Cipher : TKIP
  ...

Jeremy Nickurak (nickurak) wrote :
Jeremy Nickurak (nickurak) wrote :

Sure-enough, using wpa_supplicant directly connects to the strongest AP much much much more reliably. I'm using the following in /etc/wpa_supplicant.conf:

ctrl_interface_group=0
eapol_version=1
ap_scan=1
fast_reauth=1

network={
 ssid="UWS"
 scan_ssid=1
 key_mgmt=WPA-EAP
 eap=PEAP
 identity=(redacted)
 password=(redacted)
 phase1="peaplabel=0"
 phase2="auth=MSCHAPV2"
 priority=2
}

Chris Lasher (chris.lasher) wrote :

I get frequent disconnects too. This is on Jaunty 64-bit with NetworkManager 0.7.1~rc4.1.cf199a964-0ubuntu2 on a MacBook 5.1. See an example of the output from syslog during a disconnect and reconnection in the attached file. There are many WAPs of the same ESSID here because this is a university.

Gabriel Gravel (tolarian) wrote :

Hi.

I've been having the same issues when connecting to multiple APs at my university. Wifi network with no encryption. I tried several network cards (Broadcom 4311 with the b43 driver and Atheros AR2425 with ath5k driver) and I get the same issues.

I attached a commented version of my /var/log/syslog that I captured using the capture instructions on the DebuggingNetworkManager page.

Network is pretty stable when I connect at my home network (Linksys WRT54G with Tomato 1.21)

Thanks,
Gabriel

Gabriel Gravel (tolarian) wrote :

It seems that installing the linux-backports-modules-jaunty packaged fixed the problem for me; the connection on multiple APs is now rock solid once more (The problem appeared only since Jaunty). Might not be a bad idea to try installing the package if you're having trouble.

garyo (garyo) wrote :

I'm having a similar issue. I have two APs at home, ober83in2 (the good one I want it to use, it's wpa-2) and ober83in1 (the bad one I don't want used). If I'm connected to ober83in2 and suspend the laptop and resume, network manager auto connects me to ober83in1! Is there a config file somewhere I need to edit to make sure it tries ober83in2 first? Oddly, I can't find a man page for network manager.

Kim Toms (kim-toms) wrote :

I also have trouble using network manager. I am updated to 9.04. I had apt-get remove'd network-manager a month or two ago, and instead used a terminal window to manual type the wpa-supplicant commands. This almost always works instantly.

The network I'm attaching to is an open-mesh network with 3 nodes (all visible from my laptop usually).

When I use wpa-supplicant from the command line, it gets connected in a second or two, then I create another terminal and run the dhclient command to get a network address.

Today, I installed network-manager using 'apt-get install network-manager'.

This installed the following packages:
2009-07-22 07:29:29 install dnsmasq-base <none> 2.47-3
2009-07-22 07:29:29 install libnm-util1 0.7.1~rc4.1.cf199a964-0ubuntu2 0.7.1~rc4.1.cf199a964-0ubuntu2
2009-07-22 07:29:29 install libnm-glib0 0.7.1~rc4.1.cf199a964-0ubuntu2 0.7.1~rc4.1.cf199a964-0ubuntu2
2009-07-22 07:29:29 install libudev0 <none> 141-1.2
2009-07-22 07:29:29 install network-manager 0.7.1~rc4.1.cf199a964-0ubuntu2 0.7.1~rc4.1.cf199a964-0ubuntu2
2009-07-22 07:29:30 install network-manager-gnome 0.7.1~rc4.1-0ubuntu2 0.7.1~rc4.1-0ubuntu2

After rebooting, I could no longer get connected to the network using the network-manager method.

I next removed the network-manager-gnome and network-manager packages and, after rebooting, tried the wpa-supplicant method but it did not work. After a couple of minutes, I located the dpkg.log and removed all of the other packages listed above. I rebooted again, and now wpa-supplicant works to get associated.

Additional information
System is Sony Vaio laptop vgn-sz470n
wifi driver is iwl-3945

There is another symptom, but I have not verified it well enough to report it reliably. It appears that after using the network-manager it has affected something in the hardware, because it (may) be necessary to shut down and remove the laptop battery for a few seconds before booting the system and using the wpa-supplicant command-line method to get the network connected.

Seva Gluschenko (gvs-ya) wrote :

The problem persists on 9.04. I cannot provide logs for security reasons, but I can provide detailed description of what happens and why. This is because today we've studied the problem with our network engineer.

So, NetworkManager pings wpa_supplicant on regular basis with "scan" command. Besides blocking data throughput this way, in areas with multiple access points it results in continuous reconnect attempts because the signal from access points varies, and in the moment A the signal strength from access points looks like 208-201-197-191, but in the moment B it appears as 199-201-202-204, so wpa_supplicant breaks connection to the access point 1 and proceeds with access point 4.

I've found traces of discussion in linux-wireless mailing list dated 2009-05-14 about rescans:

http://osdir.com/ml/linux-wireless/2009-05/msg00596.html

Unfortunately, it seems like developers didn't come to any reasonable decision with that, 'cause no "stop scan" option appears in NetworkManager's properties, and no reasonable solution had been given.

The reasonable decision, from my point of view, would be to stop scans until signal strength falls beyond 128, e.g., because one indeed doesn't need to be very aware of other networks's presence while he's connected and is working. Probably, some scans could be initiated if the interface is idle for at least 2 minutes (i.e. no data sent or received through it).

Trek1701 (rtbuhler) wrote :

Th same problem persists on 9.10 for both Wlan and USB 3G connections.
If there are any log I can provide, please let me know.

Jeremy Nickurak (nickurak) wrote :

Same problem here under karmic with a bcm4322. What more information is required here?

Changed in network-manager (Ubuntu):
status: Incomplete → Confirmed
David Darrow (demiurgicdaemon) wrote :

I am having the exact same problem. My wireless is
Atheros Communications Inc. AR928X Wireless Network Adapter (PCI-Express)
It happens only when there are multiple access points. Thanks

Jeremy Nickurak (nickurak) wrote :

Upstream is asking for debugging logs from NetworkManager and wpasupplicant, but the instructions they provide ( http://live.gnome.org/NetworkManager/Debugging ) aren't providing the requested information.

Is there a way under ubuntu to enable/extract just the wpa_supplicant and NetworkManager logs, like there used to?

This is exceedingly awkward to debug, because everytime I do it, I have to start uninstall the working tools, re-install the broken ones, extract information with a broken connection, re-install the working tools again before submitting it, so I want to make sure I get this right before going through the process again.

David Darrow (demiurgicdaemon) wrote :

I have been monitoring the bug while my network connection goes out but network -manager thinks I am still connected. All messages in daemon.log and wpa_supplicant.log are simply state that everything connects well with no error messages after that. The network connection works well anywhere from 5-10 minutes. After that time there is no way to ping anything on the network or on the internet.
In order to use the connection after that I have to force network-manager to reconnect, which repeats this cycle. Let me know if there is somewhere else I can find relevant output.

Lukáš (lu-dolezal) wrote :

I'm noticing simillar problem. When I connect to WPA/WEP network, connection established only for 10-20 seconds. Then connection losts and NM starts trying to reconnect. But connection to not secured network or connection established via wicd is good. I read from logs that the cause of it can be APSCAN performed by NM. Using 9.10 and my wifi card is Intel 3945abg.

My comment with syslog attachment is at https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/363738/comments/4

andor (andreasfleig) wrote :

Still present in lucid.

Changed in network-manager:
status: Unknown → Invalid
Changed in network-manager:
status: Invalid → Confirmed
Teunis Peters (teunis) wrote :

The bug I reported is the same - except that it happens with older linksys routers and gets worse if the chip starts heating up. I have not tested anywhere with multiple APs.
#482668 - similar but slightly different.

Changed in network-manager:
importance: Unknown → High
Pascal Sachs (psachs) wrote :
Download full text (5.1 KiB)

I have the problem as well on my netbook (Asus eeePC 1000H) running Ubuntu 10.10.

My wireless card reports negative values for the signal level for "bad" APs and positiv values for the good AP. As the noise value is not reported (noise == 0) the quality of all signals is considered as maximal.

At the moment I think that the network manager, either consider quality instead of signal level to choose an AP or that it has problems with the mixing of negative and positive values.
As those values comes from the driver, I think the easiest way is to fix the network manager to handle this situation correctly.

Here is some example output from iwlist scan. The network manager tries to connect to the AP with MAC addr 00:03:52:29:62:43, which is actually the worst one considering the signal level.

          Cell 01 - Address: 00:03:52:29:62:43
                    Channel:9
                    Frequency:2.452 GHz (Channel 9)
                    Quality=70/70 Signal level=-188 dBm
                    Encryption key:on
                    ESSID:"eduroam"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
                              9 Mb/s; 12 Mb/s; 18 Mb/s
                    Bit Rates:24 Mb/s; 36 Mb/s; 48 Mb/s; 54 Mb/s
                    Mode:Master
                    Extra:tsf=000000086a538af7
                    Extra: Last beacon: 16ms ago
                    IE: Unknown: 0007656475726F616D
                    IE: Unknown: 010882848B960C121824
                    IE: Unknown: 030109
                    IE: Unknown: 2A0100
--
          Cell 12 - Address: 00:03:52:1C:18:43
                    Channel:9
                    Frequency:2.452 GHz (Channel 9)
                    Quality=70/70 Signal level=50 dBm
                    Encryption key:on
                    ESSID:"eduroam"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
                              9 Mb/s; 12 Mb/s; 18 Mb/s
                    Bit Rates:24 Mb/s; 36 Mb/s; 48 Mb/s; 54 Mb/s
                    Mode:Master
                    Extra:tsf=00000008848ace68
                    Extra: Last beacon: 460ms ago
                    IE: Unknown: 0007656475726F616D
                    IE: Unknown: 010882848B960C121824
                    IE: Unknown: 030109
                    IE: Unknown: 2A0100
--
          Cell 16 - Address: 00:03:52:1B:F5:03
                    Channel:9
                    Frequency:2.452 GHz (Channel 9)
                    Quality=70/70 Signal level=-182 dBm
                    Encryption key:on
                    ESSID:"eduroam"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
                              9 Mb/s; 12 Mb/s; 18 Mb/s
                    Bit Rates:24 Mb/s; 36 Mb/s; 48 Mb/s; 54 Mb/s
                    Mode:Master
                    Extra:tsf=000000090231fecc
                    Extra: Last beacon: 1168ms ago
                    IE: Unknown: 0007656475726F616D
                    IE: Unknown: 010882848B960C121824
                    IE: Unknown: 030109
                    IE: Unknown: 050400010000
--
          Cell 18 - Address: 00:03:52:1C:32:93
                    Channel:9
 ...

Read more...

Keith Berkoben (berkoben) wrote :

I can confirm the same issue in 10.04 with network manager. In a hall with a dozen or so APs on the same SSID.

log looks like this while trying to connect:
Mar 3 19:42:28 keith-t61u NetworkManager: <info> Activation (wlan0/wireless): connection 'Auto MIT' requires no security. No secrets needed.
Mar 3 19:42:28 keith-t61u NetworkManager: <info> Config: added 'ssid' value 'MIT'
Mar 3 19:42:28 keith-t61u NetworkManager: <info> Config: added 'scan_ssid' value '1'
Mar 3 19:42:28 keith-t61u NetworkManager: <info> Config: added 'key_mgmt' value 'NONE'
Mar 3 19:42:28 keith-t61u NetworkManager: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) complete.
Mar 3 19:42:28 keith-t61u NetworkManager: <info> (wlan0): supplicant connection state: scanning -> disconnected
Mar 3 19:42:28 keith-t61u NetworkManager: <info> Config: set interface ap_scan to 1
Mar 3 19:42:30 keith-t61u NetworkManager: <info> (wlan0): supplicant connection state: disconnected -> scanning
Mar 3 19:42:41 keith-t61u wpa_supplicant[988]: IWEVGENIE overflow
Mar 3 19:42:43 keith-t61u NetworkManager: <info> wlan0: link timed out.
Mar 3 19:42:47 keith-t61u wpa_supplicant[988]: IWEVGENIE overflow

Pascal, Keith, what you're describing here appear to be different bugs, most likely at the level of the wireless drivers, please file separate bug reports for them.

I have this problem too, or a similar one. Oneiric 11.10.

The Wifi here in my university has different SSIDs --- all normally with very similar strengths. I have sometime connected to all of them, but having them different "privileges".

For example, I have a WPA2 "local" SSID with full access to the network, and a WPA2 "global" SSID working in almost all Spanish Universities with quite reduced access (it's thought for guests, and it's the same SSID all around, so when I am in another university, I use it).

There seems no way to say to NM that I want the local one, if in range, even if the global could be stronger. If a disconnect occur, or if an auto-suspend occurs, NM reconnects to one of them in almost arbitrary way.

I understand the trend to keep the interfaces simple, but a way of marking "personal priority" should be provided.

And by the way, a "never ever again connect to that network automatically " should be there, too:
there are a lot of very insecure free hotspot around and if you make the error of connecting one time, then it's very convoluted to mark them off-limits (see also https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/891678)

2012, Ubuntu 11.10, still can't establish a reliable connection on networks with multiple APs. Immediately after connection dmesg states deauthenticated for reason 2 (authentication no longer valid). Network manager constantly prompts for password. No trouble establishing connections to single AP networks.

Consequence is I have to tether through my phone at most office buildings and universities. :(

Changed in network-manager:
status: Confirmed → Incomplete

This bug is a mix of a bunch of different issues, none of which actually related or even traceable to the same issue. All of them are hardware-specific and thus need to be file separately.

PLEASE, if you're seeing "this bug" or anything that makes you think whatever you're experiencing as issues are "this bug", file a new bug report for your own issues, don't comment here. This bug report actually really just needs to be closed as Invalid, since any new reports will cover the exact symptoms and issues specifically. The original issues reported have long since been fixed

There's a couple of different things in here:
- Issues with Broadcom drivers and/or the ath5k driver and keeping connections established, needs to be debugged separately, and needs wpa_supplicant logs: that all needs to be done as separate new bug reports, not as comments here.
- priorities for connections/don't automatically connect: a long-time Wishlist report alreday reported elsewhere.
- automatic connections to unwanted networks: they just need to be deleted from the connection editor, then won't be connected to automatically.

Changed in network-manager (Ubuntu):
status: Confirmed → Invalid
Changed in network-manager:
status: Incomplete → Confirmed
Changed in network-manager:
status: Confirmed → Incomplete
Changed in network-manager:
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.