Wifi roams too frequently

Bug #1071942 reported by Dima Ryazanov on 2012-10-26
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
network-manager (Ubuntu)
High
Mathieu Trudel-Lapierre

Bug Description

(This is very similar to bug #1057582 - but apport-collect told me to file a new bug.)

There are multiple access points here, and my laptop keeps switching between them for no reason. It was really bad in Ubuntu 12.04, but improved a little in 12.10. Still, it roams frequently enough to be annoying.

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: network-manager 0.9.6.0-0ubuntu7
ProcVersionSignature: Ubuntu 3.5.0-18.29+kamal11~DellXPS-generic 3.5.7
Uname: Linux 3.5.0-18-generic x86_64
ApportVersion: 2.6.1-0ubuntu6
Architecture: amd64
Date: Fri Oct 26 14:09:43 2012
IfupdownConfig:
 auto lo
 iface lo inet loopback
InstallationDate: Installed on 2012-05-30 (149 days ago)
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120425)
IpRoute:
 default via 172.16.80.1 dev wlan0 proto static
 169.254.0.0/16 dev wlan0 scope link metric 1000
 172.16.80.0/22 dev wlan0 proto kernel scope link src 172.16.83.58 metric 9
 192.168.72.0/24 dev vmnet8 proto kernel scope link src 192.168.72.1
 192.168.128.0/24 dev vmnet1 proto kernel scope link src 192.168.128.1
MarkForUpload: True
NetworkManager.state:
 [main]
 NetworkingEnabled=true
 WirelessEnabled=true
 WWANEnabled=true
 WimaxEnabled=true
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: network-manager
UpgradeStatus: Upgraded to quantal on 2012-09-30 (26 days ago)
nmcli-dev:
 DEVICE TYPE STATE DBUS-PATH
 wlan0 802-11-wireless connected /org/freedesktop/NetworkManager/Devices/0
nmcli-nm:
 RUNNING VERSION STATE NET-ENABLED WIFI-HARDWARE WIFI WWAN-HARDWARE WWAN
 running 0.9.6.0 connected enabled enabled enabled enabled enabled

Dima Ryazanov (dima-gmail) wrote :
Dima Ryazanov (dima-gmail) wrote :

It literally roams every 5 minutes - and disconnects for 5 seconds while doing that. It's *very* annoying.

So there's this commit upstream which might help a lot to avoid roaming too aggressively when there is relatively good signal:

http://cgit.freedesktop.org/NetworkManager/NetworkManager/commit/?h=nm-0-9-8&id=49f8da57ed18b62829919ba4f278b410642828ec

I'll go ahead and mark the next upload / package as fixing this bug (since it will include this commit); but let's be extra careful and set back this bug to New or Confirmed if there are still issues.

Changed in network-manager (Ubuntu):
status: New → In Progress
importance: Undecided → High
assignee: nobody → Mathieu Trudel-Lapierre (mathieu-tl)
Matthieu Baerts (matttbe) wrote :

Hello,

I also have this problem but not with an Intel WiFi card and I confirm that it's better with this patch.

@Mathieu: NM devs say that some changes should be made in wpa_supplicant too in order to be less aggressive [1]
Fedora devs are using this patch: http://pkgs.fedoraproject.org/cgit/wpa_supplicant.git/tree/rh837402-less-aggressive-roaming.patch

[1] The discussion: https://mail.gnome.org/archives/networkmanager-list/2013-October/msg00020.html

summary: - [iwlwifi] Wifi roams too frequently
+ Wifi roams too frequently
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package network-manager - 0.9.8.4-0ubuntu3

---------------
network-manager (0.9.8.4-0ubuntu3) trusty; urgency=low

  * Set "allow-stderr" for debian/tests/apparmor_workaround to avoid failure
    on AppArmor warnings.
 -- Martin Pitt <email address hidden> Tue, 05 Nov 2013 09:48:28 +0100

Changed in network-manager (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers