dnsmasq and network manager broken if dnsmasq package has 'enable-dbus'

Bug #1034946 reported by Scott Moser on 2012-08-09
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
dnsmasq (Ubuntu)
High
Mathieu Trudel-Lapierre
network-manager (Ubuntu)
Critical
Mathieu Trudel-Lapierre

Bug Description

I've just had a debugging session with cyphermox in ubuntu-devel [1].

The symptoms I was seeing was dns resolution failure. I had the dnsmasq package installed (as opposed to only dnsmasq-base) and that also had 'enable-dbus' in /etc/dnsmasq.d/enable-dbus (that I configured at some point in the past). The result was /etc/resolv.conf and /run/dnsmasq/resolv.conf had only 127.0.0.1 in them, making dns resolution completley broken.

There were two suggested fixes:
 a.) remove dnsmasq package
 b.) disable 'enable-dbus' from system dnsmasq package.

[1] http://irclogs.ubuntu.com/2012/08/09/%23ubuntu-devel.html

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: network-manager 0.9.6.0-0ubuntu2
ProcVersionSignature: Ubuntu 3.5.0-8.8-generic 3.5.0
Uname: Linux 3.5.0-8-generic x86_64
ApportVersion: 2.4-0ubuntu6
Architecture: amd64
Date: Thu Aug 9 10:59:49 2012
EcryptfsInUse: Yes
IfupdownConfig:
 auto lo
 iface lo inet loopback

 #iface eth0 inet dhcp
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
IpRoute:
 default via 192.168.1.1 dev wlan0 proto static
 10.0.3.0/24 dev lxcbr0 proto kernel scope link src 10.0.3.1
 169.254.0.0/16 dev wlan0 scope link metric 1000
 192.168.1.0/24 dev wlan0 proto kernel scope link src 192.168.1.101 metric 9
 192.168.122.0/24 dev virbr0 proto kernel scope link src 192.168.122.1
NetworkManager.state:
 [main]
 NetworkingEnabled=true
 WirelessEnabled=true
 WWANEnabled=true
 WimaxEnabled=true
ProcEnviron:
 TERM=xterm
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: network-manager
UpgradeStatus: Upgraded to quantal on 2011-11-07 (276 days ago)
nmcli-dev:
 DEVICE TYPE STATE DBUS-PATH
 wlan0 802-11-wireless connected /org/freedesktop/NetworkManager/Devices/1
 eth0 802-3-ethernet disconnected /org/freedesktop/NetworkManager/Devices/0
nmcli-nm:
 RUNNING VERSION STATE NET-ENABLED WIFI-HARDWARE WIFI WWAN-HARDWARE WWAN
 running 0.9.6.0 connected enabled enabled enabled enabled disabled

Scott Moser (smoser) wrote :
Changed in network-manager (Ubuntu):
status: New → Triaged
importance: Undecided → Critical
assignee: nobody → Mathieu Trudel-Lapierre (mathieu-tl)

The fix for this depends on dnsmasq 2.63 (which is about to get released); so that NM can use a custom DBus name for dnsmasq.

As soon as the new version is released I'll apply the changes to use --enable-dbus=blah to set a different DBus name within the NM namespace, include a dbus config file for the ACL, and it should be good.

Changed in dnsmasq (Ubuntu):
status: New → In Progress
importance: Undecided → High
assignee: nobody → Mathieu Trudel-Lapierre (mathieu-tl)
Changed in network-manager (Ubuntu):
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package dnsmasq - 2.63-1ubuntu1

---------------
dnsmasq (2.63-1ubuntu1) quantal; urgency=low

  * Merge with Debian unstable; remaining changes:
    - debian/control: dnsmasq-base Breaks/Replaces dnsmasq (<< 2.62-3ubuntu1)
      due to the dbus config file move.
  * dnsmasq 2.63 noteworthy changes:
    - Allow setting a dbus name with --enable-dbus which overrides the default
      name. (LP: #1034946)
    - Add --bind-dynamic. A hybrid mode between default and --bind-interfaces
      which copes with dynamically created interfaces. (LP: #526386)
    - Fix regression in 2.61 which broke caching of CNAME chains.
    - Allow the target of a --cname flag to be another --cname.
    - Teach DHCPv6 about the RFC 4242 information-refresh-time option, and add
      parsing for the minutes, hours and days format for options.
    - Allow "w" (for week) as multiplier in lease times.
 -- Mathieu Trudel-Lapierre <email address hidden> Mon, 20 Aug 2012 14:24:30 -0400

Changed in dnsmasq (Ubuntu):
status: In Progress → Fix Released
Changed in network-manager (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package network-manager - 0.9.6.0-0ubuntu4

---------------
network-manager (0.9.6.0-0ubuntu4) quantal; urgency=low

  * debian/patches/dns-dnsmasq-interface-and-dbus-path.patch: set the address
    dnsmasq (and bind) plugins should listen on for DNS resolution to 127.0.1.1,
    as opposed to 127.0.0.1 to avoid conflicts with other instances that might
    need to run on the system with that address.
    Also set the dnsmasq DBus service name to our own custom name:
    org.freedesktop.NetworkManager.dnsmasq, which will also avoid conflicting
    with other dnsmasq instances which might have --enable-dbus enabled.
    (LP: #1034946)
 -- Mathieu Trudel-Lapierre <email address hidden> Tue, 21 Aug 2012 11:45:46 -0400

Changed in network-manager (Ubuntu):
status: Fix Committed → Fix Released

Any chance of getting this fix backported to 12.04? As 12.04's built-in dnsmasq doesn't support /etc/NetworkManager/dnsmasq.d/, having a usable DBus interface would at least provide a means of altering the service's configuration.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers