[quantal] no network resolution after latest upgrade of network-manager

Bug #1031350 reported by Pete Graner on 2012-07-31
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
network-manager (Ubuntu)
Critical
Mathieu Trudel-Lapierre

Bug Description

After latest upgrade of network manager on Quantal, the system cannot do DNS resolution.

ProblemType: BugDistroRelease: Ubuntu 12.10
Package: network-manager 0.9.6.0~git201207271115.edb85e9-0ubuntu1
ProcVersionSignature: Ubuntu 3.5.0-6.6-generic 3.5.0
Uname: Linux 3.5.0-6-generic x86_64
ApportVersion: 2.4-0ubuntu6
Architecture: amd64
Date: Tue Jul 31 09:32:47 2012
EcryptfsInUse: Yes
IfupdownConfig:
 auto lo
 iface lo inet loopback
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120425)
IpRoute:
 default via 10.0.1.1 dev wlan0 proto static
 10.0.1.0/24 dev wlan0 proto kernel scope link src 10.0.1.4 metric 9
 169.254.0.0/16 dev wlan0 scope link metric 1000
NetworkManager.state:
 [main]
 NetworkingEnabled=true
 WirelessEnabled=true
 WWANEnabled=true
 WimaxEnabled=true
ProcEnviron:
 TERM=xterm
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
RfKill:
 0: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: noSourcePackage: network-manager
UpgradeStatus: No upgrade log present (probably fresh install)
modified.conffile..etc.dnsmasq.d.network.manager: [deleted]
nmcli-dev:
 DEVICE TYPE STATE DBUS-PATH
 wlan0 802-11-wireless connected /org/freedesktop/NetworkManager/Devices/1
 eth0 802-3-ethernet unavailable /org/freedesktop/NetworkManager/Devices/0
nmcli-nm:
 RUNNING VERSION STATE NET-ENABLED WIFI-HARDWARE WIFI WWAN-HARDWARE WWAN
 running 0.9.5.96 connected enabled enabled enabled enabled disabled

WORKAROUND:
  sudo mkdir /etc/NetworkManager/dnsmasq.d
  sudo shutdown -r now

Pete Graner (pgraner) wrote :
C de-Avillez (hggdh2) wrote :

Confirmed.

Changed in network-manager (Ubuntu):
importance: Undecided → High
status: New → Confirmed
Changed in network-manager (Ubuntu):
status: Confirmed → In Progress
importance: High → Critical
assignee: nobody → Mathieu Trudel-Lapierre (mathieu-tl)
Jean-Baptiste Lallement (jibel) wrote :

On this system nameserver is set to 10.0.1.1 instead of 127.0.0.1, all updates applied, and network is working.

There's at least /etc/NetworkManager/dnsmasq.d not getting created by the package. However, failures in dnsmasq starting should still get handled gracefully, but it doesn't seem to be the case here.

On the same network; Jean-Baptiste's syslog shows the failover being done properly and DNS information entered in /etc/resolv.conf via resolvconf.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package network-manager - 0.9.6.0~git201207271115.edb85e9-0ubuntu2

---------------
network-manager (0.9.6.0~git201207271115.edb85e9-0ubuntu2) quantal; urgency=low

  * debian/network-manager.dirs: add /etc/NetworkManager/dnsmasq.d to the
    directories shipped; so that dnsmasq can start successfully. (LP: #1031350)
 -- Mathieu Trudel-Lapierre <email address hidden> Tue, 31 Jul 2012 09:41:30 -0400

Changed in network-manager (Ubuntu):
status: In Progress → Fix Released
Mathieu Pellerin (nirvn-asia) wrote :

Hmm, I got the problematic nm package on my system, and therefore can't download the updated nm package as apt get fails to resolve domain. Work around please? :-)

You can manually create /etc/NetworkManager/dnsmasq.d and reboot (or restart NetworkManager, or "reset" the connection)

C de-Avillez (hggdh2) on 2012-07-31
description: updated
pureblood (freeseek) wrote :

I confirm that I have the same issue since upgrading today to the stable version Ubuntu Quantal. Manual creation of a correct resolv.conf file fixes the problem temporarily. But as soon as I connect to a different network, this operation needs to be repeated. This seems a very serious bug, it needs high priority. I don't know how to debug it. I had dnsmasq installed prior to upgrading. Could this be related in any way?

Nick Booker (nmbooker) wrote :

I also had this issue after an upgrade from Precise, but /etc/NetworkManager/dnsmasq.d was there.

I found I had a permanantly blank resolv.conf, and had to

 dpkg-reconfigure resolvconf

and say 'Yes' to "Prepare /etc/resolv.conf for dynamic updates?"
and I said 'No' when it asked me if it should append my current contents to the config file.

It now works, with /etc/resolv.conf pointing at 127.0.1.1 which I presume means that it's delegating to dnsmasq on localhost.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers