Ubuntu

Many package hooks not ported to python3

Reported by Chris Johnston on 2012-06-14
124
This bug affects 14 people
Affects Status Importance Assigned to Milestone
apache2 (Ubuntu)
Undecided
Matthieu Baerts
Quantal
Undecided
Matthieu Baerts
apport (Ubuntu)
Critical
Martin Pitt
Quantal
Critical
Martin Pitt
apport-symptoms (Ubuntu)
Medium
Martin Pitt
Quantal
Medium
Martin Pitt
bluez (Ubuntu)
Undecided
Unassigned
Quantal
Undecided
Unassigned
cairo-dock (Ubuntu)
Undecided
Matthieu Baerts
Quantal
Undecided
Matthieu Baerts
chromium-browser (Ubuntu)
Undecided
Matthieu Baerts
Quantal
Undecided
Matthieu Baerts
compiz (Ubuntu)
Undecided
Matthieu Baerts
Quantal
Undecided
Matthieu Baerts
connman (Ubuntu)
Undecided
Matthieu Baerts
Quantal
Undecided
Matthieu Baerts
dkms (Ubuntu)
Medium
Martin Pitt
Quantal
Medium
Martin Pitt
gnome-control-center (Ubuntu)
Undecided
Unassigned
Quantal
Undecided
Unassigned
gnome-settings-daemon (Ubuntu)
Undecided
Unassigned
Quantal
Undecided
Unassigned
indicator-applet (Ubuntu)
Undecided
Matthieu Baerts
Quantal
Undecided
Matthieu Baerts
libatasmart (Ubuntu)
Medium
Martin Pitt
Quantal
Medium
Martin Pitt
lxpanel (Ubuntu)
Undecided
Matthieu Baerts
Quantal
Undecided
Matthieu Baerts
mdadm (Ubuntu)
Medium
Dimitri John Ledkov
Quantal
Medium
Dimitri John Ledkov
mysql-5.5 (Ubuntu)
Undecided
Matthieu Baerts
Quantal
Undecided
Matthieu Baerts
mythtv (Ubuntu)
Undecided
Mario Limonciello
Quantal
Undecided
Mario Limonciello
nautilus (Ubuntu)
Undecided
Unassigned
Quantal
Undecided
Unassigned
network-manager (Ubuntu)
Undecided
Mathieu Trudel-Lapierre
Quantal
Undecided
Mathieu Trudel-Lapierre
shadow (Ubuntu)
Medium
Unassigned
Quantal
Medium
Unassigned
udisks2 (Ubuntu)
Medium
Martin Pitt
Quantal
Medium
Martin Pitt
unity (Ubuntu)
Undecided
Matthieu Baerts
Quantal
Undecided
Matthieu Baerts
xdiagnose (Ubuntu)
High
Oliver Grawert
Quantal
High
Oliver Grawert

Bug Description

Since the description here is the only post that can be updated, it seems the best place to keep a changing list of packages that need examining. (The original description was brief, and about only one package.)

We've fixed all the packages that found in the apt logs uploaded in the first round of breakage. Now I've tried to review all the other apport hooks I could find in Quantal. Working from the archive's Contents file, I got the list of packages that have files under /usr/share/apport/package-hooks . I skipped the packages already fixed above, and those that were on my system, during the first round of breakage, and had no problems. For the rest, I downloaded the debs, extracted the apport hooks, and ran '2to3' on them. I've posted patches for every package that broke under python3.

Thanks - Edward Donovan <email address hidden>

These packages didn't break during the apport upgrade that forced a recompile, but they get warnings from the 2to3 tool:

  compiz-core
  eclipse-platform
  gnome-control-center-data
  gnome-settings-daemon
  grub-common
  nautilus-data
  unity-common
  apache2.2-common

Now we have a bug report for at least gnome-control-center, bug 1018537, which I've duped here. So these may need patching, too.

Hm...from a preliminary look, a number of those use the same code:

    if report.has_key("Stacktrace")

which generates an exception with python3. We're probably going to want to change those to

   if "Stacktrace" in report

and I'll try to post some of those simple patches, soon.

Side note:

  rss-glx: the python is fine, but the hook file is just named 'source', with no package name or extension, so I filed bug 1017780 about that.

Related branches

lp:~ogra/xdiagnose/py3port
Merged into lp:xdiagnose at revision 256
Bryce Harrington: Approve on 2012-06-15
Colin Watson (community): Approve on 2012-06-11
Chris Johnston (cjohnston) wrote :
Chris Johnston (cjohnston) wrote :
Chris Johnston (cjohnston) wrote :
Scott Kitterman (kitterman) wrote :

running python rtupdate hooks for python3.2...
  File "/usr/share/apport/apport-gpu-error-intel.py", line 156
    print "# %s" %(report_filename)
               ^
SyntaxError: invalid syntax

affects: python3-defaults (Ubuntu) → xdiagnose (Ubuntu)
Changed in xdiagnose (Ubuntu):
importance: Undecided → Critical
milestone: none → quantal-alpha-2
status: New → Confirmed
summary: - Could not install python3
+ xdiagnose run in python3, but not ported

Do you guys think this is really the same as bug 1012707? I don't know whether this should be a report for each package; maybe it should.

Scott Kitterman (kitterman) wrote :

It doesn't need a separate bug, just add tasks to this one.

Changed in apport-symptoms (Ubuntu Quantal):
status: New → Confirmed
importance: Undecided → Critical
milestone: none → quantal-alpha-2
Changed in udisks2 (Ubuntu Quantal):
status: New → Confirmed
importance: Undecided → Critical
milestone: none → quantal-alpha-2
Edward Donovan (edward.donovan) wrote :

Thanks, Scott, that makes sense.

That bug, and the ones I duped to it, were assigned to python3-defaults. Do you (or does anyone) think these bugs don't belong to python itself, but to the python-using packages that have apport hooks, and rtupdate files, that fail? Either way, we probably need a more general bug title.

I ask not only for bug assignments, but for fixes and workarounds. Is python3 the way we want it, and the numerous other packages are out of compliance?

I'm uncertain, partly because this has not happened on a box that I upgraded to Quantal several weeks ago -- neither then, nor as I keep it up to date. The box that I just upgraded to Quantal today, I can't get past this problem yet. Thanks.

Edward Donovan (edward.donovan) wrote :

For reference, there's a discussion of this problem on #ubuntu-devel today, seen partway down here:

  http://irclogs.ubuntu.com/2012/06/14/%23ubuntu-devel.html

I get the impression that the bugs are only in the separate packages with hooks, not in python3 itself. I can't tell why it's happening on my newly-upgraded box, but not the other quantal box. I don't have time to read that whole conversation yet. Nor time and focus to summarize it here. Maybe later. Thanks.

Edward Donovan (edward.donovan) wrote :

Well, I have tried to give this bug a more general title for now. Please revise. :)

summary: - xdiagnose run in python3, but not ported
+ Many package hooks not ported to python3

The rt update script that is triggering this is from one of python3-defaults packages. That's why the bugs get attributed to python3-defaults.

The actual problem is that apport was just updated to python3, but not all the hooks provided by other packages have been updated.

The reason your first upgrade worked was because it was before the switch.

Thanks a lot, Scott. I only had conjectures about that, and it's much nicer to hear from someone who knows.

Would it be good to go through the list of packages that failed, and add them here?

I can also try to make some patches by monkey-see, monkey-do, if I get time. Thanks.

Yes and Yes, after you check if there's an existing bzr branch with a fix for
this. There was a Python 3 porting sprint this week and not everything has
been uploaded yet from it.

Great. Here's a start on a list.

I combined and sorted my error logs, and those attached by Chris and dahar. Here is a quick list of broken apport hooks seen there, and not added to the bug yet. It doesn't include other kinds of python hooks, yet, just the apport ones. I will try to get time to follow up on these, and to look at the other broken hooks in these logs.

Package: login
  File "/usr/share/apport/package-hooks/source_shadow.py", line 26

Package: firefox
  File "/usr/share/apport/package-hooks/source_firefox.py", line 976

Package: thunderbird
  File "/usr/share/apport/package-hooks/source_thunderbird.py", line 977

Package: mdadm
  File "/usr/share/apport/package-hooks/source_mdadm.py", line 26

Package: dkms
  File "/usr/share/apport/package-hooks/dkms_packages.py", line 54

Package: libatasmart4
  File "/usr/share/apport/package-hooks/libatasmart4.py", line 31

Package: notify-osd
  File "/usr/share/apport/package-hooks/source_notify-osd.py", line 83

Changed in shadow (Ubuntu Quantal):
status: New → Confirmed
importance: Undecided → Critical
Changed in firefox (Ubuntu Quantal):
importance: Undecided → Critical
status: New → Confirmed
Changed in thunderbird (Ubuntu Quantal):
importance: Undecided → Critical
milestone: none → quantal-alpha-2
status: New → Confirmed
Changed in firefox (Ubuntu Quantal):
milestone: none → quantal-alpha-2
Changed in shadow (Ubuntu Quantal):
milestone: none → quantal-alpha-2
Changed in mdadm (Ubuntu Quantal):
importance: Undecided → Critical
milestone: none → quantal-alpha-2
status: New → Confirmed
Changed in dkms (Ubuntu Quantal):
importance: Undecided → Critical
milestone: none → quantal-alpha-2
status: New → Confirmed
Changed in libatasmart (Ubuntu Quantal):
importance: Undecided → Critical
milestone: none → quantal-alpha-2
status: New → Confirmed
Changed in notify-osd (Ubuntu Quantal):
importance: Undecided → Critical
milestone: none → quantal-alpha-2
status: New → Confirmed
Scott Kitterman (kitterman) wrote :

Thanks. I've added them all to the bug.

I know there's an xdiagnose port for Python 3 in work, so don't bother trying to fix that one.

no longer affects: bluez
Martin Pitt (pitti) wrote :

I already fixed udisks2's hook in the Debian git.

Changed in udisks2 (Ubuntu Quantal):
assignee: nobody → Martin Pitt (pitti)
status: Confirmed → Fix Committed
Changed in gnome-screensaver (Ubuntu Quantal):
status: New → Confirmed
Martin Pitt (pitti) wrote :

Reproducer: sudo apt-get install --reinstall python3

The actual bug is that apport ships a file /usr/share/python3/runtime.d/apport.rtupdate . This is not supposed to be there (autogenerated by dh_python3, I assume), and is just plain wrong. I'll remove it.

This will leave the remaining tasks open, but will stop breaking upgrades and thus be a lot less urgent.

Changed in apport (Ubuntu Quantal):
assignee: nobody → Martin Pitt (pitti)
importance: Undecided → Critical
milestone: none → quantal-alpha-2
status: New → In Progress
Changed in apport-symptoms (Ubuntu Quantal):
importance: Critical → Medium
assignee: nobody → Martin Pitt (pitti)
status: Confirmed → In Progress
Changed in dkms (Ubuntu Quantal):
importance: Critical → Medium

Ok, here are a few more, also apport hooks. (These had a different error message, and I didn't grab them in the first batch.)

  Sorry: TabError: inconsistent use of tabs and spaces in indentation (source_network-manager.py, line 67)

  Sorry: TabError: inconsistent use of tabs and spaces in indentation (source_gnome-screensaver.py, line 48)

  Sorry: TabError: inconsistent use of tabs and spaces in indentation (source_bluez.py, line 17)

I added the packages, but am not man enough to set the milestones and severity. (I had to refresh my LP skills; I added bluez the wrong way, at first.)

Martin Pitt (pitti) wrote :

Leaving xdiagnose as high, as there are a bazillion packages symlinking to this. Oliver already has the fix in a branch.

Changed in xdiagnose (Ubuntu Quantal):
assignee: nobody → Oliver Grawert (ogra)
importance: Critical → High
status: Confirmed → In Progress
Martin Pitt (pitti) wrote :

This patch should be the bulk of porting firefox' package hook, and should also apply (at least in spirit) to thunderbird's : http://paste.ubuntu.com/1040952/ . All these changes are backwards compatible with Python 2 as well.

I'm not quite sure how your ExtensionINIParserIter parser works, "python3 source_firefox.py" now fails there.

Changed in thunderbird (Ubuntu Quantal):
assignee: nobody → Chris Coulson (chrisccoulson)
importance: Critical → Medium

Oh, thank you, Martin; that's great.

Changed in network-manager (Ubuntu Quantal):
status: New → Confirmed
Changed in bluez (Ubuntu Quantal):
status: New → Confirmed
Martin Pitt (pitti) on 2012-06-15
Changed in udisks2 (Ubuntu Quantal):
importance: Critical → Medium
Changed in firefox (Ubuntu Quantal):
assignee: nobody → Chris Coulson (chrisccoulson)
importance: Critical → Medium
Changed in libatasmart (Ubuntu Quantal):
assignee: nobody → Martin Pitt (pitti)
importance: Critical → Medium
status: Confirmed → In Progress
Changed in shadow (Ubuntu Quantal):
importance: Critical → Medium
Changed in mdadm (Ubuntu Quantal):
importance: Critical → Medium
Changed in notify-osd (Ubuntu Quantal):
importance: Critical → Medium
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apport - 2.2.3-0ubuntu1

---------------
apport (2.2.3-0ubuntu1) quantal; urgency=low

  [ Martin Pitt ]
  * New upstream bug fix release:
    - test/run: Do not run pep8 and pyflakes when running against the sytem
      installed Apport.
    - test_backend_apt_dpkg.py: For the "are we online" check, verify that we can
      download from http://ddebs.ubuntu.com/, not just whether we have a default
      route. The latter is not sufficient for e. g. buildd environments which are
      online, but are restricted by proxies or firewalls.
    - test_report.py: Call "sync" after test script write core dumps, to ensure
      that subsequent operations have a complete one.
    - test_signal_crashes.py: Drop the broken and obsolete test_local_python()
      test. Instead, add two tests which check proper logging.
    - launchpad.py: Fix urlopen() for Python3. Thanks Steve Langasek.
    - test/run: Run the tests under LC_MESSAGES=C, to avoid failing tests on
      translated strings.
  * debian/control: Add libc6-dbg | libc6-dbgsym dependency to apport-retrace,
    to ensure gdb can decipher the abort_msg_s struct and thus read assertion
    messages. Also add libc6-dbg to debian/tests/control so that
    report.test_add_gdb_info_abort can succeed in autopkgtest.
  * debian/control, debian/tests/control: apport-retrace needs a terminal
    emulator, so add an x-terminal-emulator dependency. Add xterm as build and
    autopkgtest dependency, so that the tests have one available.
  * debian/control: Drop python-launchpadlib from Depends to Suggests for
    python-apport, too.

  [ Steve Langasek ]
  * debian/rules: call dh_python3 with --skip-private, to avoid incorrect
    generation of a .rtupdate script for /usr/share/apport. LP: #1013171.
 -- Martin Pitt <email address hidden> Fri, 15 Jun 2012 08:27:17 +0200

Changed in apport (Ubuntu Quantal):
status: In Progress → Fix Released
Martin Pitt (pitti) on 2012-06-15
Changed in libatasmart (Ubuntu Quantal):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libatasmart - 0.19-1git1

---------------
libatasmart (0.19-1git1) quantal; urgency=low

  Upload current Debian packaging git head.

  * debian/local/apport-hook.py: Fix syntax to be Python 3 compatible.
    (LP: #1013171)
  * debian/local/apport-hook.py: Include output of "udisksctl dump" from
    udisks2.
 -- Martin Pitt <email address hidden> Fri, 15 Jun 2012 08:29:53 +0200

Changed in libatasmart (Ubuntu Quantal):
status: Fix Committed → Fix Released
Martin Pitt (pitti) on 2012-06-15
Changed in apport-symptoms (Ubuntu Quantal):
status: In Progress → Fix Committed
Chris Coulson (chrisccoulson) wrote :

This was fixed in the Firefox nightly and aurora packaging branches last night

Changed in firefox (Ubuntu Quantal):
status: Confirmed → Fix Committed
Chris Coulson (chrisccoulson) wrote :

And thunderbird...

Changed in thunderbird (Ubuntu Quantal):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apport-symptoms - 0.17

---------------
apport-symptoms (0.17) quantal; urgency=low

  * symptoms/_audio_data.py: Fix syntax to be Python 3 compatible.
    (LP: #1013171)
  * symptoms/storage.py: Fix decoding of stdout/err in subprocesses.
  * symptoms/storage.py: Move to udisks2.
  * debian/copyright: Move to copyright format 1.0.
  * debian/control: Bump Standards-Version to 3.9.3.
  * debian/control: Move ${misc:Depends} to Depends.
 -- Martin Pitt <email address hidden> Fri, 15 Jun 2012 09:44:18 +0200

Changed in apport-symptoms (Ubuntu Quantal):
status: Fix Committed → Fix Released
Dimitri John Ledkov (xnox) wrote :

I will look into mdadm hook

Changed in mdadm (Ubuntu Quantal):
assignee: nobody → Dmitrijs Ledkovs (dmitrij.ledkov)
Didier Roche (didrocks) on 2012-06-15
Changed in notify-osd (Ubuntu Quantal):
assignee: nobody → Didier Roche (didrocks)
Changed in gnome-screensaver (Ubuntu Quantal):
assignee: nobody → Didier Roche (didrocks)
Changed in network-manager (Ubuntu Quantal):
assignee: nobody → Didier Roche (didrocks)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xdiagnose - 2.7

---------------
xdiagnose (2.7) quantal; urgency=low

  [ Oliver Grawert ]
  * port all program code to new python3 conventions
  * adjust shebang lines for all python scripts to use python3
  * update debian/rules and control for python3 support
  * remove unused debian/pycompat file
  * switch test suite to python3
  * make test suite skip testing of directories
  * add dependency on python3-apport
  * make launchpadlib usage optional until it is ported to python3
  * adjust apport-gpu-error-intel.py for new apport API
  * xdiagnose/applet.py fix string handling of subprocess.Popen
  * fixes (LP: #1013171)

  [ Bryce Harrington ]
  * Add a couple preliminary edid tools
  * Fix apt_install to not use chroots
  * Install general.lib
  * Don't show xdiagnose in the menu (LP: #994048)
  * Build depend on both py2 and py3 versions of distutils-extra, required by dh_auto_clean
 -- Bryce Harrington <email address hidden> Thu, 14 Jun 2012 11:00:23 -0700

Changed in xdiagnose (Ubuntu Quantal):
status: In Progress → Fix Released

Hi - upgrading to the new xdiagnose exposed another little python3 problem.

  /usr/lib/python3/dist-packages/xdiagnose/assistant.py

has some old-style print statements, from line 72-80. You may not need a patch that just puts in the parentheses, but I'll attach one in case that helps bring attention to it. It's:

  xdiagnose-assistant.py.patch

Unfortunately, I cannot re-open the bug for xdiagnose. I wish I could. Thanks.

Here is the trivial patch needed to fix the 'login' package.

Oh, the binary package is called login, but the source is 'shadow'. Minor correction to the patch description, then.

Here is the small patch for gnome-screensaver's apport hook. There was one old print statment to fix, and a few tabs, mixed among spaces, that had to be removed.

notify-osd just has one print statement to fix.

network-manager's apport hook has two lines with tabs among spaces, and one old print statement.

The apport hook for bluez only has whitespace problems. Removed tab characters.

For dkms, I wasn't sure of the most proper python3 form, for the print statments redirected to stderr. So I let the 2to3 tool generate this patch. It fixes those print statements, and one exception statement, where the syntax now requires 'as'.

Ah, I see second xdiagnose issues were solved, noted in bug 1013911. Rather than needing to patch assistant.py, the whole file was able to be dropped, apparently. So I deleted my patch for that one.

Dimitri John Ledkov (xnox) wrote :

It would help a lot to keep the python hooks both python2.7 (precise) and python3 (quantal+) for the upgrade case where your hook maybe run with either pythons.

https://wiki.ubuntu.com/Python/3

Most of the time it's easy to accomplish with:
from __future__ import print_function

Which is valid in both python2.6+ and python3.

Also note:
Consider passing universal_newlines=True to subprocess.Popen() and friends to get text output directly.

Which nicely helps to deal with unicode vs bytes in python3 vs python2 cases.

Martin Pitt (pitti) wrote :

Seconded what Dmitrijs says. Instead of

- print >> sys.stderr, 'ERROR (dkms apport): both -m and -v are required'
+ print('ERROR (dkms apport): both -m and -v are required', file=sys.stderr)

use something like

  sys.stderr.write('ERROR... required\n')

(i. e. add the explicit \n at the end). This will work with both Python 2 and 3. Alternatively, use

  from __future__ import print_statement.

Martin Pitt (pitti) wrote :

I'll sponsor Edward's fixes which work with both Python 2 and 3, thanks! I can't find an email address of him, so I can only credit his name in the uploads, but not upload the packages under his name.

Martin Pitt (pitti) wrote :

Handing network-manager to Mathieu, as I cannot push to lp:~network-manager/network-manager/ubuntu . Mathieu, can you please apply the apport hook patch? Thanks!

Changed in network-manager (Ubuntu Quantal):
assignee: Didier Roche (didrocks) → Mathieu Trudel-Lapierre (mathieu-tl)
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bluez - 4.99-2ubuntu2

---------------
bluez (4.99-2ubuntu2) quantal; urgency=low

  * debian/source_bluez.py: Drop tabs to fix compatibility with Python 3.
    Thanks Edward Donovan! (LP: #1013171)
 -- Martin Pitt <email address hidden> Mon, 18 Jun 2012 14:58:49 +0200

Changed in bluez (Ubuntu Quantal):
status: Confirmed → Fix Released
Martin Pitt (pitti) on 2012-06-18
Changed in xdiagnose (Ubuntu Quantal):
status: Fix Released → In Progress
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package notify-osd - 0.9.34-0ubuntu3

---------------
notify-osd (0.9.34-0ubuntu3) quantal; urgency=low

  * debian/source_notify-osd.py: Drop tabs to fix compatibility with Python 3.
    Thanks Edward Donovan! (LP: #1013171)
 -- Martin Pitt <email address hidden> Mon, 18 Jun 2012 15:05:56 +0200

Changed in notify-osd (Ubuntu Quantal):
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package shadow - 1:4.1.4.2+svn3283-3ubuntu6

---------------
shadow (1:4.1.4.2+svn3283-3ubuntu6) quantal; urgency=low

  * debian/source_shadow.py: Fix compatibility with python3. Thanks Edward
    Donovan! (LP: #1013171)
 -- Martin Pitt <email address hidden> Mon, 18 Jun 2012 15:09:54 +0200

Changed in shadow (Ubuntu Quantal):
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-screensaver - 3.4.1-0ubuntu4

---------------
gnome-screensaver (3.4.1-0ubuntu4) quantal; urgency=low

  * debian/source.apport: Fix compatibility with Python 3. Thanks Edward
    Donovan! (LP: #1013171)
 -- Martin Pitt <email address hidden> Mon, 18 Jun 2012 15:14:56 +0200

Changed in gnome-screensaver (Ubuntu Quantal):
status: Confirmed → Fix Released
Martin Pitt (pitti) wrote :

Unsubscribing sponsors team as everything that can be sponsored has been uploaded. Please re-subscribe if you attach new/fixed patches. Thanks!

Setting network-manager task to Fix Committed; it's in the branch now, and I'll make a new upload shortly.

Changed in network-manager (Ubuntu Quantal):
status: In Progress → Fix Committed
Changed in dkms (Ubuntu Quantal):
assignee: nobody → Brian Murray (brian-murray)
status: Confirmed → In Progress

Hi all - I was starting to redo the dkms patch, but it looks like Brian's taking that.

Thanks for the "Thanks". :) For future ref, I have email addresses on my LP page, so this makes me wonder if they're properly visible. There are two, anyway, and <email address hidden> would be the better one to use. The launchpad@numble is where bug mail goes, for filtering. Maybe that's not the smoothest way to do it. (Maybe this process question is best asked somewhere else; I don't know.)

I'm also a uncertain, after reading your comments, if the patches should be redone, to work better with python 2 or 3, as you're talking about. When there was a print statement in these hooks, my little patches just made it a python 3 function, with parentheses. I was just thinking about python 3 compatibility, and didn't add any

    from __future__ import print_statement

lines. Would it be best to redo them, that way? Thanks.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package udisks2 - 1.98.0-2

---------------
udisks2 (1.98.0-2) experimental; urgency=low

  * debian/local/apport-hook.py: Fix syntax to also work with Python 3.
    (LP: #1013171)
  * debian/tests/upstream-system: Ensure that /var/run/udisks2 exists.
  * debian/tests/control: Add dbus-x11 dependency for dbus-launch.
  * debian/control: Add XS-Testsuite header, as per current DEP-8.
 -- Martin Pitt <email address hidden> Wed, 20 Jun 2012 07:29:40 +0200

Changed in udisks2 (Ubuntu Quantal):
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

@Edward:

> For future ref, I have email addresses on my LP page, so this makes me wonder if they're properly visible.

They are not. https://launchpad.net/~edward.donovan says "No public address provided.", I figure you need to agree to showing them in public. It's certainly a sensible default to not show them, as an email address on a public web page attracts a lot of spam.

As for the print statement, print() works just as well in Python 2 as long as you don't use commas in there; if you do, it prints a tuple instead. So these are fine:

  print('hello')
  print('hello %s' % world)

but this needs the __future__ statement or need to be rewritten to have one single argument:

  print('hello', 'world')

Martin Pitt (pitti) wrote :

Taking dkms, as I already have the patch now (Jean-Baptiste was pointing this out to me this morning).

Changed in dkms (Ubuntu Quantal):
assignee: Brian Murray (brian-murray) → Martin Pitt (pitti)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package dkms - 2.2.0.3-1ubuntu4

---------------
dkms (2.2.0.3-1ubuntu4) quantal; urgency=low

  * Add apport_python3.patch: Port apport hook to Python 3 (LP: #1013171) and
    take care of opening the output file in binary mode (LP: #1008092)
 -- Martin Pitt <email address hidden> Thu, 21 Jun 2012 08:52:35 +0200

Changed in dkms (Ubuntu Quantal):
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (3.3 KiB)

This bug was fixed in the package mdadm - 3.2.5-1ubuntu1

---------------
mdadm (3.2.5-1ubuntu1) quantal; urgency=low

  * Merge from Debian testing. (LP: #920324) Remaining changes:
    - Call checks in local-premount to avoid race condition with udev
      and opening a degraded array.
    - d/initramfs/mdadm-functions: Record in /run when boot-degraded
      question has been asked so that it is only asked once
    - pass --test to mdadm to enable result codes for degraded arrays.
    - debian/control: we need udev and util-linux in the right version. We
      also remove the build dependency from quilt and docbook-to-man as both
      are not used in Ubuntus mdadm.
    - debian/initramfs/hook: kept the Ubuntus version for handling the absence
      of active raid arrays in <initramfs>/etc/mdadm/mdadm.conf
    - debian/initramfs/script.local-top.DEBIAN, debian/mdadm-startall,
      debian/mdadm.raid.DEBIAN: removed. udev does its job now instead.
    - debian/mdadm-startall.sgml, debian/mdadm-startall.8: documentation of
      unused startall script
    - debian/mdadm.config, debian/mdadm.postinst - let udev do the handling
      instead. Resolved merge conflict by keeping Ubuntu's version.
    - debian/mdadm.postinst, debian/mdadm.config, initramfs/init-premount:
      boot-degraded enablement; maintain udev starting of RAID devices;
      init-premount hook script for the initramfs, to provide information at
      boot
    - debian/mkconf.in is the older mkconf. Kept the Ubuntu version.
    - debian/rules: Kept Ubuntus version for installing apport hooks, not
      installing un-used startall script.
    - debian/install-rc, check.d/_numbers, check.d/root_on_raid: Ubuntu partman
      installer changes
    - debian/presubj: Dropped this unused bug reporting file. Instead use
      source_mdadm.py act as an apport hook for bug handling.
    - d/p/debian-changes-3.1.4-1+8efb9d1ubuntu4: mdadm udev rule
      incrementally adds mdadm member when detected. Starting such an
      array in degraded mode is possible by mdadm -IRs. Using mdadm
      -ARs without stopping the array first does nothing when no
      mdarray-unassociated device is available. Using mdadm -IRs to
      start a previously partially assembled array through incremental
      mode. Keeping the mdadm -ARs for assembling arrays which were for
      some reason not assembled through incremental mode (i.e through
      mdadm's udev rule).

  * Additional Ubuntu changes:
      - debian/initramfs/local-premount: add call wait_for_udev to wait a
      little longer for RAID devices to appear (LP: #942106)

  * Dropped Ubuntu changes:
    - Build udeb with -O2 on ppc64, working around a link error. Builds
      fine without it on debian.
    - rename debian/mdadm.vol_id.udev to debian/mdadm.mdadm-blkid.udev so
      that the rules file ends up with a more reasonable name. debian/rules
      changes for adding ubuntu's udev rule corresponding to mdadm. As we
      are now using 'upstream' udev rules see 3.2.3-2ubuntu2.

  * Changes to Ubuntu changes:
    - debian/source_mdadm.py: make apport hook python 2 and 3 compatible
      (LP: #1013171).

  * New upstream release closes this...

Read more...

Changed in mdadm (Ubuntu Quantal):
status: Confirmed → Fix Released
Dimitri John Ledkov (xnox) wrote :

All done now! Thank you everyone for quick responses and patches!

That was fast work from everyone, yeah. :)

It's possible there may be some more apport hooks that need looking at. I built up the list of affected packages, from the error logs of three users, including me. That probably got us the most commonly installed packages. But as far as I know, we haven't checked every package in the archive. (If some automated testing is taking care of that, great!) I've got a list, from the Contents file for Quantal, of all packages that have files under apport/package-hooks. I'll try to post the list of packages that don't seem to be tested yet. And, possibly, install and test as many as I can. I guess I can't predict how soon I'll be able to get to that, so we'll see. Thanks.

@Martin: Thank you. I made my email visible on Launchpad, and now (I think) I get the difference in print usage.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package firefox - 14.0~b9+build1-0ubuntu1

---------------
firefox (14.0~b9+build1-0ubuntu1) quantal; urgency=low

  * New upstream release from the beta channel (FIREFOX_14_0b9_BUILD1)

  [ Chris Coulson <email address hidden> ]
  * Update globalmenu-extension to 3.3 prerelease r386
    - Fix LP: #1016081 - Menubar is not hidden when using the Firefox
      button outside of Unity
    - Fix LP: #775305 - An empty menu appears when FFChrome is installed
    - Fix LP: #1017247 - Menubar appears in the window as well as the
      Unity panel. Manually register our UA stylesheet rather than relying
      on this happening via chrome registration, to work around a bug
      in various bootstrapped third party addons (eg, pentadactyl),
      which initialize and use the stylesheet service before extension
      chrome is registered for non-restartless addons such as ours
    - Add a small delay when opening the menu with the keyboard, so that
      the additional items are added before the menu appears. Fixes an
      issue where keyboard focus isn't on the first item when opening the
      history menu with the keyboard
  * Apport hook improvements:
    - Sort preferences alphabetically in the apport data
    - Treat preferences set in default addons as default prefs so that
      they don't show up in apport data, unless the preference files have
      been modified
    - Support random pref files dropped in to the Firefox install folder, and
      preferences from application bundles
    - Fix ordering issues when loading preferences
  * Fix LP: #1013171 - Fully support Python 3 in the apport hook
    - update debian/apport/source_firefox.py.in

  [ Martin Pitt <email address hidden> ]
  * Add partial support for Python 3 in the apport hook (LP: #1013171)
    - update debian/apport/source_firefox.py.in
 -- Chris Coulson <email address hidden> Thu, 21 Jun 2012 11:15:26 +0100

Changed in firefox (Ubuntu Quantal):
status: Fix Committed → Fix Released

indicator-applet is another package that needs an update. Here's the trivial patch for one print statement in source_indicator-applet.py. Thanks.

Changed in indicator-applet (Ubuntu Quantal):
status: New → Confirmed
description: updated
Changed in chromium-browser (Ubuntu Quantal):
status: New → Confirmed
description: updated
description: updated
description: updated
description: updated
description: updated
description: updated

chromium-browser has three different things that need to be changed, in its apport hook. The print and except statements, I understand what to do. The third issue is a list comprehension, I think. It looked like this:

    for ext in entry['extensions']['settings'].keys():

The 2to3 tool wants to wrap that in "list()" :

    for ext in list(entry['extensions']['settings'].keys()):

That looks fair enough, according to the python 3 docs. But I don't really know why this line needs fixing, while

    for plugin in entry['plugins']['plugins_list']:

does not. I can see that the former line has a method call or something, with ".keys()". But since I can't tell you why those are treated differently, I'd better ask for someone more knowledgeable to look at this. Thanks.

description: updated
description: updated

Sorry, my first try at a chromium patch had mistakes. I deleted that, and here's a new one.

connman needs simple 'print' fixes. Here's a patch.

description: updated
description: updated
description: updated
description: updated
description: updated

lxpanel's apport hook uses '<>' operators . Here's a patch replacing them with '!=', which works under python 2 and 3.

Changed in connman (Ubuntu Quantal):
status: New → Confirmed
Changed in lxpanel (Ubuntu Quantal):
status: New → Confirmed
description: updated
description: updated

apache2.2-common has a hook that uses 'unicode()'. That can be replaced by 'str()', but doesn't actually break on my python3 install. So I'm not sure whether we want to change that, or leave it alone. Here is the simple patch, but I won't add apache2 to the bug report, I think, until someone with more experience chimes in on that. Thanks.

description: updated
Changed in cairo-dock (Ubuntu Quantal):
status: New → Confirmed

cairo-dock needs a print statement updated. Here's a patch to make it work under python 2 or 3.

description: updated
description: updated
description: updated
description: updated
description: updated
description: updated

mysql-5.5 has a print statement that needed fixing. This patch also changes unicode() to str(), as 2to3 suggests -- whether that's really called for, I'll leave for someone else to decide. Thanks.

description: updated
Changed in mysql-5.5 (Ubuntu Quantal):
status: New → Confirmed
Changed in mythtv (Ubuntu Quantal):
status: New → Confirmed
description: updated

mythtv-common needs the usual 'print' fix. Here's a patch. The 2to3 tool also wanted to change:

    if report.has_key('Package')

into

    if 'Package' in report

But since neither python 2 or 3 take exception to that original syntax, I did not make that change in the patch. Advice welcome. Thanks.

description: updated
description: updated
tags: added: patch
no longer affects: firefox (Ubuntu)
no longer affects: firefox (Ubuntu Quantal)
no longer affects: thunderbird (Ubuntu)
no longer affects: thunderbird (Ubuntu Quantal)
no longer affects: gnome-screensaver (Ubuntu Quantal)
no longer affects: gnome-screensaver (Ubuntu)
no longer affects: notify-osd (Ubuntu)
no longer affects: notify-osd (Ubuntu Quantal)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cairo-dock - 3.0.2-0ubuntu2

---------------
cairo-dock (3.0.2-0ubuntu2) quantal; urgency=low

  * debian/apport/cairo-dock.py: ported to python3 (LP: #1013171)
     Thanks to Edward Donovan for the patch
 -- Matthieu Baerts (matttbe) <email address hidden> Tue, 26 Jun 2012 12:50:23 +0200

Changed in cairo-dock (Ubuntu Quantal):
status: Confirmed → Fix Released
Changed in mythtv (Ubuntu Quantal):
assignee: nobody → Mario Limonciello (superm1)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mythtv - 2:0.25.0+fixes.20120626.25dd4ce-0ubuntu1

---------------
mythtv (2:0.25.0+fixes.20120626.25dd4ce-0ubuntu1) quantal; urgency=low

  * fix get-orig-source rule's broken tarball fetch from archive.
  * Enable libcec support (LP: #982272)
  * Add missingok to additional mythtv-backend logs. (LP: #982162)
  * Pull an updated snapshot of Mythbuntu theme, to avoid theme
    downloader telling the user there is an updated theme on first
    boot.
  * Test for an empty key on public mysql. (LP: #989371)
  * Update amejia's email on uploaders field.
  * Drop recommends on adept-notifier.
  * Bump standards version.
  * Update apport hook for python3 (LP: #1013171)
  * New upstream checkout (25dd4ce)
 -- Mario Limonciello <email address hidden> Tue, 26 Jun 2012 11:22:57 -0500

Changed in mythtv (Ubuntu Quantal):
status: Confirmed → Fix Released
Changed in gnome-control-center (Ubuntu Quantal):
status: New → Confirmed
description: updated

gnome-control-center's apport hook breaks under python 3, as reported in bug 1018357, now duped here. Here is a one-line patch that fixes this error. And here's the original report pasted in from that bug:

On Quantal up to date
TEST CASE:
1. From a terminal run:
  $ ubuntu-bug gnome-control-center

RESULT:
ERROR: hook /usr/share/apport/package-hooks//source_gnome-control-center.py crashed:
Traceback (most recent call last):
  File "/usr/lib/python3/dist-packages/apport/report.py", line 799, in add_hooks_info
    symb['add_info'](self, ui)
TypeError: add_info() takes exactly 1 positional argument (2 given)

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
  File "/usr/lib/python3/dist-packages/apport/report.py", line 804, in add_hooks_info
    symb['add_info'](self)
  File "/usr/share/apport/package-hooks//source_gnome-control-center.py", line 6, in add_info
    if report.has_key("Stacktrace") and "/usr/lib/control-center-1" in report["Stacktrace"]:
AttributeError: 'Report' object has no attribute 'has_key'

description: updated
Martin Pitt (pitti) wrote :

Pushed Edward's gnome-control-center to bzr, thank you!

Changed in gnome-control-center (Ubuntu Quantal):
status: Confirmed → Fix Committed

Another one-line patch.

Changed in gnome-settings-daemon (Ubuntu Quantal):
status: New → Confirmed

nautilus, same one-liner.

Changed in nautilus (Ubuntu Quantal):
status: New → Confirmed

unity, same one-line patch; thanks.

Changed in unity (Ubuntu Quantal):
status: New → Confirmed

compiz needs the same one-line patch as the last few, and it has another issue, at least on my machine. It appears the 'source_compiz.py' hook needs this import:

  from apport.hookutils import *

And I've added that in my patch. Without it 'ubuntu-bug compiz' throws an exception, saying the function 'command_output' is not defined.

  ERROR: hook /usr/share/apport/package-hooks//source_compiz.py crashed:
  Traceback (most recent call last):
    File "/usr/lib/python3/dist-packages/apport/report.py", line 799, in add_hooks_info
      symb['add_info'](self, ui)
    File "/usr/share/apport/package-hooks//source_compiz.py", line 18, in add_info
      report['CompizPlugins'] = command_output(['gconftool-2',
  NameError: global name 'command_output' is not defined

Some apport hooks have the import statement above. Some have just 'import apport.hookutils'. Only the former fixed this on my system. The latter seems to work fine for other packages, but not here. Maybe I'm misssing something; I didn't explore this any further. (Nor did I try to fix bug 777221 while I was in there. :)

Thanks.

Changed in compiz (Ubuntu Quantal):
status: New → Confirmed
Martin Pitt (pitti) wrote :

I pushed Edward's gnome-settings-daemon and nautilus hook fixes to bzr. Thanks!

From now on, can you please file new bug reports for similar issues? This bug is starting to get huge and already times out a lot. Feel free to subscribe me for sponsoring. Thanks!

Changed in gnome-settings-daemon (Ubuntu Quantal):
status: Confirmed → Fix Committed
Changed in nautilus (Ubuntu Quantal):
status: Confirmed → Fix Committed
Changed in unity (Ubuntu Quantal):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package connman - 0.78-0ubuntu2

---------------
connman (0.78-0ubuntu2) quantal; urgency=low

  * debian/source_connman.py:
   - Update apport hook for python3 ; Thanks to Edward Donovan (LP: #1013171)
 -- Matthieu Baerts (matttbe) <email address hidden> Tue, 03 Jul 2012 21:16:07 +0000

Changed in connman (Ubuntu Quantal):
status: Confirmed → Fix Released
Changed in unity (Ubuntu Quantal):
assignee: nobody → Matthieu Baerts (matttbe)
status: Fix Committed → Fix Released
Changed in cairo-dock (Ubuntu Quantal):
assignee: nobody → Matthieu Baerts (matttbe)
Changed in connman (Ubuntu Quantal):
assignee: nobody → Matthieu Baerts (matttbe)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-applet - 0.5.0-0ubuntu2

---------------
indicator-applet (0.5.0-0ubuntu2) quantal; urgency=low

  * debian/source_indicator-applet.py:
   - Update apport hook for python3 (LP: #1013171)
  * debian/control:
   - Added python3-xdg as new dependence (needed by its apport hook)
 -- Matthieu Baerts (matttbe) <email address hidden> Mon, 02 Jul 2012 19:22:45 +0200

Changed in indicator-applet (Ubuntu Quantal):
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package chromium-browser - 20.0.1132.47~r144678-0ubuntu2

---------------
chromium-browser (20.0.1132.47~r144678-0ubuntu2) quantal; urgency=low

  * debian/control
    - Dropped build depends for libvpx-dev
  * -debian/patches/vpx.patch
    - dropped, build with internal vpx

  [ Matthieu Baerts ]
  * debian/apport:
   - Update apport hook for python3 (LP: #1013171)
     patch made with the help of Edward Donovan
 -- Ken VanDine <email address hidden> Thu, 12 Jul 2012 15:56:59 -0400

Changed in chromium-browser (Ubuntu Quantal):
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lxpanel - 0.5.10-1ubuntu2

---------------
lxpanel (0.5.10-1ubuntu2) quantal; urgency=low

  * debian/patches: Refresh all patches.

  [ Matthieu Baerts (matttbe) ]
  * debian/local/source_lxpanel.py:
   - Update apport hook for python3 ; thanks to Edward Donovan (LP: #1013171)
 -- Julien Lavergne <email address hidden> Sun, 15 Jul 2012 13:00:20 +0200

Changed in lxpanel (Ubuntu Quantal):
status: Confirmed → Fix Released
Changed in compiz (Ubuntu Quantal):
assignee: nobody → Matthieu Baerts (matttbe)
status: Confirmed → Fix Committed
Changed in indicator-applet (Ubuntu Quantal):
assignee: nobody → Matthieu Baerts (matttbe)
Changed in lxpanel (Ubuntu Quantal):
assignee: nobody → Matthieu Baerts (matttbe)
Changed in chromium-browser (Ubuntu Quantal):
assignee: nobody → Matthieu Baerts (matttbe)
Changed in apache2 (Ubuntu Quantal):
assignee: nobody → Matthieu Baerts (matttbe)
status: New → Fix Released
Changed in mysql-5.5 (Ubuntu Quantal):
assignee: nobody → Matthieu Baerts (matttbe)
status: Confirmed → Fix Committed
Matthieu Baerts (matttbe) wrote :

It seems that all sources packages listed here have been modified to fix this bug. (Fix Commited or Fix Released)

PS: thanks to Edward Donovan for his help ;)

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package network-manager - 0.9.6.0~git201207161259.00297f4-0ubuntu1

---------------
network-manager (0.9.6.0~git201207161259.00297f4-0ubuntu1) quantal; urgency=low

  * upstream snapshot 2012-07-16 12:59:59 (GMT)
    + 00297f49fbbe05c51c02da43cda254c35e053589

  [ Edward Donovan ]
  * debian/source_network-manager.py: port package hook to python3.
    (LP: #1013171)

  [ Mathieu Trudel-Lapierre ]
  * debian/patches/lp292054_tune_supplicant_timeout_60s.patch: disable the
    patch. It adds unnecessary delays to things like detecting that hidden
    networks are not in range, and since Jaunty drivers have changed a lot.
    If we're still seeing timing issues with the supplicant, then perhaps the
    drivers should be fixed instead, or we'll re-enable the patch. (LP: #446623)
  * debian/network-manager.dnsmasq, debian/rules:
    install a config file to /etc/dnsmasq.d to avoid system-wide instances of
    dnsmasq to bind to 0.0.0.0 and the loopback interface, so that the NM-
    spawned instance can claim an IP on lo and provide local resolution.
    (LP: #959037)
  * debian/patches/add-veth-support.diff: add support for the veth* virtual
    ethernet devices. Thanks to Stéphane Graber for the patch.
  * debian/patches/nm-ip6-rs.patch: dropped, applied upstream.
  * debian/libnm-util2.symbols: add symbols:
    + nm_utils_file_is_pkcs12@Base
  * debian/control: move policykit-1 from Recommends to Depends: without it
    calls to the backend (e.g. when starting nm-tool), will fail. Thanks to
    Stéphane Graber for the testing and solution.
  * debian/rules: fix clean to properly remove m4/intltool.m4.
  * debian/tests/control, debian/tests/nm: add an autopkgtest control file and
    initial test to verify that NM works once installed.
  * debian/control: add XS-Testsuite: autopkgtest.
 -- Mathieu Trudel-Lapierre <email address hidden> Mon, 16 Jul 2012 17:17:51 -0400

Changed in network-manager (Ubuntu Quantal):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus - 1:3.5.4-0ubuntu1

---------------
nautilus (1:3.5.4-0ubuntu1) quantal; urgency=low

  * New upstream version:
    * Add Copy To and Move To actions
    * Add a notification while ejecting volumes
    * List view:
      - New date format display
      - Use a list model instead of a tree model for list view
      - Use a better default column order
      - Change some list column names
      - Use 32px icons by default
      - Tweak padding
    * Search:
      - "Just type" search
      - Combine the search bar and the query editor
      - Tracker engine performance improvements and fixes
    * Sidebar:
      - Add a recent files place
      - Use symbolic icons
      - Improve order of the items
    * Toolbar:
      - Change toolbar layout to the GNOME 3 style
      - Don't show titlebar when maximized
      - Use a linked style for the pathbar
    * Menus:
      - Migrate the menubar to a gear menu
      - Remove "Go" menu
      - Remove "Bookmarks" menu
    * Remove "Text beside icons" option for icon view
    * Fix loading string not disappearing in image properties on load
  * debian/patches/00git_hide_toolbar_on_desktop.patch:
    - dropped, the patch is in the new version
  * Re-enabled patches that were commented in the previous commit
    without reason, they seem to work fine
  * debian/patches/git-0001-Workaround-focus-issues-on-typeahead.patch:
    - dropped, the new version integrate typeahead with the search and has
      no floating widget used which deprecates this patch
  * debian/patches/workaround_ellipsizing_bug.patch:
    - dropped, the bug got properly fixed in the new version
  * debian/patches/05_desktop_menu_export.patch:
    - commented, it needs to be mostly rewriten for the new design
      or implemented in a different place or way

  [ Edward Donovan ]
  * debian/source_nautilus.py: Fix for Python 3. (LP: #1013171)

  [ Jeremy Bicha ]
  * New upstream release.
  * debian/patches/05_desktop_menu_export.patch: Refreshed
  * debian/patches/21_correct_timestamp_use_fix_focus_issue.patch: Refreshed
 -- Sebastien Bacher <email address hidden> Wed, 18 Jul 2012 15:13:46 +0200

Changed in nautilus (Ubuntu Quantal):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mysql-5.5 - 5.5.25a-0ubuntu1

---------------
mysql-5.5 (5.5.25a-0ubuntu1) quantal; urgency=low

  [ Clint Byrum ]
  * New upstream release.
  * d/additions/my.cnf: Ensure mysql errors are written to log file.
    (LP: #1014732)
  * d/mysql-server-5.5.mysql-server.logrotate: Add
    /var/log/mysql/error.log so it is rotated properly. (LP: #879560)
  * d/control: remove Vcs-* as they are inaccurate in Ubuntu.
  * d/rules: use WITH_SSL=bundled to ensure that we do not accidentally
    build against openssl.
  * d/control, d/rules: cherry pick fix from Debian to use gcc 4.4 only
    for i386 to work around problems with yaSSL assembly (LP: #1012139)

  [ Matthieu Baerts (matttbe) ]
  * Update apport hook for python3 ; patch by Edward Donovan (LP: #1013171)
 -- Clint Byrum <email address hidden> Thu, 19 Jul 2012 16:14:50 -0700

Changed in mysql-5.5 (Ubuntu Quantal):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (7.9 KiB)

This bug was fixed in the package compiz - 1:0.9.8+bzr3319-0ubuntu1

---------------
compiz (1:0.9.8+bzr3319-0ubuntu1) quantal-proposed; urgency=low

  [ Didier Roche ]
  * debian/patches/ubuntu-config.patch:
    - refresh with latest trunk
  * debian/*docs:
    - remove the TODO copy now removed upstream
  * debian/compiz-plugins.install:
    - install stackswitch, trip plugins
  * debian/rules, debian/control:
    - remove the compiz gnome-control-center key sedding through metacity.
      Compiz now directly ships them.
    - we do not need metacity-common anymore as a build-dep then
  * debian/compiz-gnome.migrations, debian/control:
    - build-dep on dh-migrations and ship gconf -> gsettings migration file

  [ Matthieu Baerts (matttbe) ]
  * Update apport hook for python3 ; thanks to Edward Donovan (LP: #1013171)

  [ Timo Jyrinki ]
  * New upstream snapshot.
    - Fix Compiz crash in movementWindowOnScreen (LP: #1015151)
    - Start window decorator when decor plugin starts (LP: #1014461)
    - Fixed: Crash in compiz::wall::movementWindowOnScreen (LP: #1015151)
    - Don't waste memory leaving /bin/sh running (LP: #1015422)
    - Add reliable detection of the compiz bin directory (LP: #1015898)
    - Check if the window would actually paint before painting the shadow,
      since it is possible that another plugin could be inhibiting paint of
      the dock window. (LP: #1012956)
    - Don't insert the window into the server list above the window it was
      created above. (LP: #1008020) (LP: #886605)
    - makes compiz enhanced zoom and show mouse plugins considerably
      smoother to use (LP: #930783)
    - Don't set decoration contexts on undecorated windows, since that
      might be read later and code will assume the window is decorated when
      it isn't. (LP: #1015593)
    - Fix potentially unterminated string leading to an uninitialized memory
      read (LP: #1018302)
    - Lift the 31/32 character restriction on key names that was causing so
      many warnings. It's now 1024 characters according to glib. (LP: #1018730)
    - Don't print the result of BUILD_DEB. It prevents ccsm et al from
      installing. (LP: #1018916)
    - Use the XDamage extension more efficiently (the way it was designed to be
      used). This dramatically reduces CPU usage, reduces wakeups, and
      increases frame rates. It also solves at least one observed performance
      bug (LP: #1007299) and probably several more.
    - Do the initial work to get libcompizconfig under test. (LP: #990690)
    - Add support for initiating window picker in other than nomal mode. For
      now added only the additional 'All windows' picker (LP: #933776)
      (LP: #955035)
    - Fixes (LP: #1018602) : An invalid read when using g_variant_iter_loop.
    - Don't allow unbinds of textures kept around for animations in any case,
      not just resizing. (LP: #1016366)
    - Wait for the server to finish processing requests before doing a bind
      (LP: #1016367)
    - Using the next/previous bindings the wall plugin didn't calculate
      correctly the next workspace when it reaches the begin or the end of a
      row of workspaces, so it didn't jump to the n...

Read more...

Changed in compiz (Ubuntu Quantal):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-settings-daemon - 3.4.2-0ubuntu9

---------------
gnome-settings-daemon (3.4.2-0ubuntu9) quantal-proposed; urgency=low

  [ Sebastien Bacher ]
  * debian/control.in:
    - don't build-depends on gconf
    - updated gnome-control-center breaks version for gsettings
  * debian/patches/revert_git_a11y_gsettings.patch,
    debian/patches/revert_git_stop_using_gconf.patch,
    debian/patches/revert_git_use_gsetting_keybindings.patch:
    - drop the gconf to gsettings migration reverts (LP: #1035261)

  [ Keng-Yu Lin ]
  * debian/patches/git-mask-out-virtual-modifiers.patch
    - patch from upstream git, fix the grabbing issue of the
      keyboard shortcut with virtual (Super, Hyper, Meta) modifier.
      (lp: #950160)

  [ Edward Donovan ]
  * debian/source_gnome-settings-daemon.py: Fix for Python 3. (LP: #1013171)

  [ Hsin-Yi, Chen (hychen) ]
  * debian/patches/git_xrandr_explicitly_set_clone_state.patch:
    - "xrandr; explicitly set clone state variable when generating monitor
      configs" (LP: #1014533)

  [ Michael Terry ]
  * debian/patches/git-smartcard-crash.patch:
    - Don't crash on login with a smartcard (LP: #1031034)
 -- Sebastien Bacher <email address hidden> Thu, 23 Aug 2012 17:04:16 +0200

Changed in gnome-settings-daemon (Ubuntu Quantal):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-control-center - 1:3.4.2-0ubuntu11

---------------
gnome-control-center (1:3.4.2-0ubuntu11) quantal; urgency=low

  * debian/control.in:
    - updated clutter requirement to match the configure version
  * debian/patches/96_sound_nua_panel.patch:
    - drop hacks and merge upstream changes for mouse scrolling (lp: #953757)
  * debian/patches/git_sound_sliders.patch:
    - "sound: Fix mouse scrolls on sliders"
  * debian/patches/git_update_keyring_password.patch
  * debian/source_gnome-control-center.py:
    - updated for python3, thanks Edward Donovan (lp: #1013171)
  * debian/UbuntuLogo.png:
    - updated logo for 12.10 (lp: #1035501)
 -- Sebastien Bacher <email address hidden> Fri, 24 Aug 2012 18:57:15 +0200

Changed in gnome-control-center (Ubuntu Quantal):
status: Fix Committed → Fix Released
Tobiasz Jarczyk (dotnokato-q) wrote :

Hi,
I see reoccurence of this bug in gnome-control-center 3.6.3 (3.6.3-0ubuntu49).
Also, there is a separate bug reported for that - https://bugs.launchpad.net/ubuntu/+source/gnome-control-center/+bug/1237119
Should we mark the other one a duplicate for this one or is there another way we want to cope with it?

Thanks,
Tobiasz

This report was already getting too big for Launchpad to handle quickly, and is all marked fixed. In these cases I'm usually advised to leave the closed report as it is, and handle the new occurrence with the new bug. You can certainly put a link to this bug, there, for informational purposes. Maybe I can get to that.

Thanks!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers