Needs more then 3 minutes to boot

Bug #1000764 reported by Ludin7 on 2012-05-17
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
network-manager (Ubuntu)
Undecided
Unassigned

Bug Description

I added an alias for eth0 to /etc/networking/interfaces:

# generated by wxp04_network start lo
auto lo
iface lo inet loopback
# generated by wxp04_network end lo

# generated by wxp04_network start 192.168.2.218
auto eth0
iface eth0 inet static
address 192.168.2.218
netmask 255.255.255.0
network 192.168.2.0
gateway 192.168.2.1
broadcast 192.168.2.255
# generated by wxp04_network end 192.168.2.218

# generated by wxp04_network start 192.168.2.30
auto eth0:1
iface eth0:1 inet static
address 192.168.2.30
netmask 255.255.255.0
network 192.168.2.0
gateway 192.168.2.1
broadcast 192.168.2.255
# generated by wxp04_network end 192.168.2.30

and /etc/resolv.conf:

nameserver 195.186.1.111
search 195.186.4.111

It work fine, I can use all IP addresses. But the boottime will be over 3 minutes.
If a remove the definition of eth0:1 the boottime wil be a few seconds.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: gnome-terminal 3.4.1.1-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-24.37-generic 3.2.14
Uname: Linux 3.2.0-24-generic x86_64
ApportVersion: 2.0.1-0ubuntu7
Architecture: amd64
Date: Thu May 17 15:42:19 2012
ExecutablePath: /usr/bin/gnome-terminal
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta amd64 (20120301)
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, no user)
 LANG=en_US.UTF-8
SourcePackage: gnome-terminal
UpgradeStatus: No upgrade log present (probably fresh install)

Ludin7 (ludin7) wrote :
Ludin7 (ludin7) wrote :

grep -i eth0 /var/log/kernel.log:

May 15 15:09:46 Hundwil kernel: [ 1.812093] e1000 0000:02:01.0: eth0: (PCI:66MHz:32-bit) 00:0c:29:09:27:ea
May 15 15:09:46 Hundwil kernel: [ 1.812097] e1000 0000:02:01.0: eth0: Intel(R) PRO/1000 Network Connection
May 15 15:09:46 Hundwil kernel: [ 2.454603] ADDRCONF(NETDEV_UP): eth0: link is not ready
May 15 15:09:46 Hundwil kernel: [ 3.603416] e1000: eth0 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: None
May 15 15:09:46 Hundwil kernel: [ 3.604395] ADDRCONF(NETDEV_UP): eth0: link is not ready
May 15 15:09:46 Hundwil kernel: [ 3.604440] ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
May 15 15:09:57 Hundwil kernel: [ 14.591346] eth0: no IPv6 routers present
May 15 15:17:26 Hundwil kernel: [ 1.926964] e1000 0000:02:01.0: eth0: (PCI:66MHz:32-bit) 00:0c:29:09:27:ea
May 15 15:17:26 Hundwil kernel: [ 1.926968] e1000 0000:02:01.0: eth0: Intel(R) PRO/1000 Network Connection
May 15 15:17:26 Hundwil kernel: [ 26.490097] ADDRCONF(NETDEV_UP): eth0: link is not ready
May 15 15:17:26 Hundwil kernel: [ 28.118052] e1000: eth0 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: None
May 15 15:17:26 Hundwil kernel: [ 28.123597] ADDRCONF(NETDEV_UP): eth0: link is not ready
May 15 15:17:26 Hundwil kernel: [ 28.123641] ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
May 15 15:17:36 Hundwil kernel: [ 38.741693] eth0: no IPv6 routers present
May 17 10:30:26 Hundwil kernel: [ 1.930936] e1000 0000:02:01.0: eth0: (PCI:66MHz:32-bit) 00:0c:29:09:27:ea
May 17 10:30:26 Hundwil kernel: [ 1.930939] e1000 0000:02:01.0: eth0: Intel(R) PRO/1000 Network Connection
May 17 10:30:26 Hundwil kernel: [ 21.403029] ADDRCONF(NETDEV_UP): eth0: link is not ready
May 17 10:30:26 Hundwil kernel: [ 22.582181] e1000: eth0 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: None
May 17 10:30:26 Hundwil kernel: [ 22.586304] ADDRCONF(NETDEV_UP): eth0: link is not ready
May 17 10:30:26 Hundwil kernel: [ 22.586348] ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
May 17 10:30:36 Hundwil kernel: [ 32.984673] eth0: no IPv6 routers present
May 17 10:39:58 Hundwil kernel: [ 1.797544] e1000 0000:02:01.0: eth0: (PCI:66MHz:32-bit) 00:0c:29:09:27:ea
May 17 10:39:58 Hundwil kernel: [ 1.797548] e1000 0000:02:01.0: eth0: Intel(R) PRO/1000 Network Connection
May 17 10:39:58 Hundwil kernel: [ 2.547137] ADDRCONF(NETDEV_UP): eth0: link is not ready
May 17 10:39:59 Hundwil kernel: [ 3.036987] e1000: eth0 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: None
May 17 10:39:59 Hundwil kernel: [ 3.042661] ADDRCONF(NETDEV_UP): eth0: link is not ready
May 17 10:39:59 Hundwil kernel: [ 3.043745] ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
May 17 10:40:10 Hundwil kernel: [ 13.902618] eth0: no IPv6 routers present

can't find an english source with this information, but using the /etc/networking/interfaces with the Network Manager seems to make problems...

http://wiki.ubuntuusers.de/interfaces

affects: ubuntu → network-manager (Ubuntu)
Ludin7 (ludin7) wrote :

New installation of Ubuntu Desktop 12.10 64-bit
I create the /etc/interface with different IP-addresses.
Than I reboot des System and create some additional snapshots and copy the syslog file with this reboot.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in network-manager (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers