"Export VPN Connection" shouldn't point to Filesystem

Bug #634913 reported by Sergio Zanchetta on 2010-09-10
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
network-manager-applet (Ubuntu)
Low
Mathieu Trudel-Lapierre
network-manager-openconnect (Ubuntu)
Low
Unassigned
network-manager-openvpn (Ubuntu)
Low
Unassigned
network-manager-pptp (Ubuntu)
Low
Unassigned
network-manager-vpnc (Ubuntu)
Low
Unassigned

Bug Description

1) Open network Manager.
2) Click on VPN tab
4) Select a VPN connection and click on Export.

Export window propose Filesystem as default folder to save the file in.

Obviously there are permission problem on / directory, so the default should be User's Home.

Ack, I messed up. This really is in the various VPN plugins, so by default I'm opening a task for each plugin, we can clean up and mark Invalid after.

Changed in network-manager-applet (Ubuntu):
status: New → Confirmed
importance: Undecided → Low
affects: network-manager-applet (Ubuntu) → network-manager-vpnc (Ubuntu)
Changed in network-manager-openvpn (Ubuntu):
status: New → Confirmed
importance: Undecided → Low
Changed in network-manager-pptp (Ubuntu):
importance: Undecided → Low
Changed in network-manager-openconnect (Ubuntu):
importance: Undecided → Low

Turns out it really is done in nm-applet directly.

Changed in network-manager-openconnect (Ubuntu):
status: New → Invalid
Changed in network-manager-applet (Ubuntu):
status: New → In Progress
importance: Undecided → Low
assignee: nobody → Mathieu Trudel-Lapierre (mathieu-tl)
Changed in network-manager-openvpn (Ubuntu):
status: Confirmed → Invalid
Changed in network-manager-pptp (Ubuntu):
status: New → Invalid
Changed in network-manager-vpnc (Ubuntu):
status: Confirmed → Invalid
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package network-manager-applet - 0.9.1.90-0ubuntu1

---------------
network-manager-applet (0.9.1.90-0ubuntu1) oneiric; urgency=low

  * New upstream release.
    - Split wireless/mobile dialogs into a new libnm-gtk library.

  [ Dylan McCall ]
  * debian/patches/04-autostart.patch:
    - disable autostart when using gnome-shell (LP: #852961)

  [ Mathieu Trudel-Lapierre ]
  * debian/control: add libnm-gtk0 and libnm-gtk-dev binary packages.
  * debian/control: bump network-manager-dev, libnm-*-dev Build-Depends
    to (>= 0.9.1).
  * debian/control: add iso-codes to Build-Depends.
  * debian/network-manager-gnome.install,
    debian/libnm-gtk0.install,
    debian/libnm-gtk-dev.install: install files to the right packages now that
    we have multiple binary packages.
  * debian/patches/nm-applet-use-indicator.patch: refresh.
  * debian/control, debian/rules: add network-manager-gnome-dbg. (LP: #415394)
  * debian/patches/vpn-import-export-dir.patch: fix default path for importing
    or exporting VPN connections. (LP: #634913)
  * debian/patches/mobile-wizard.patch: clear up the mobile wizard intro page
    buttons and titles. (LP: #856785)
 -- Mathieu Trudel-Lapierre <email address hidden> Fri, 23 Sep 2011 15:25:35 -0400

Changed in network-manager-applet (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers