Transitioning GNOME away from libnm-glib

Bug #1744619 reported by Jeremy Bicha on 2018-01-22
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
network-manager-iodine (Ubuntu)
Undecided
Unassigned
network-manager-l2tp (Ubuntu)
Undecided
Unassigned
network-manager-openvpn (Ubuntu)
Undecided
Unassigned
network-manager-pptp (Ubuntu)
Undecided
Unassigned
network-manager-vpnc (Ubuntu)
Undecided
Unassigned
unity-control-center (Ubuntu)
High
Unassigned

Bug Description

Debian has dropped libnm-glib support from most of its VPN plugins.

We need to cherry-pick the gnome-shell 3.26.2-4 changes for gnome-shell to properly interact with VPNs.

unity-control-center will need to be ported away from libnm-glib for it to display VPNs.

The only other known affected desktop is Cinnamon which has fixes "pending"

Here's the Debian transition bug:
https://bugs.debian.org/cgi-bin/pkgreport.cgi?<email address hidden>;tag=libnm

At first look, KDE Plasma did not seem to be hurt by the libnm-glib support removal, but Kubuntu should probably check more closely.

I am filing this bug to coordinate this transition and keep the VPN plugins in -proposed until we at least update gnome-shell.

Jeremy Bicha (jbicha) on 2018-01-22
description: updated
Jeremy Bicha (jbicha) on 2018-01-22
description: updated
Jeremy Bicha (jbicha) on 2018-01-23
description: updated
Sebastien Bacher (seb128) wrote :

That was discussed on IRC and there are some details in the upstream report (https://bugzilla.gnome.org/show_bug.cgi?id=779776)

The main issue on the GNOME side seems to be that libnm and libnm-glib bindings can't be loaded at the same time, which means that gnome-shell and its plugins need to be using the same library, which means they need to be updated in sync to avoid issue.

There doesn't seem to be a need to remove libnm-glib from Ubuntu yet though (if it's still needed/used), upstream hasn't removed it either but building the nm plugins without it might lead to issues for unity-control-center which is using the old library still

summary: - libnm-glib removal transition
+ Transitioning GNOME away from libnm-glib
Sebastien Bacher (seb128) wrote :

Changing the title to reflect what I think the changeset is about, let me know if you think it's not an accurate summary

Changed in gnome-shell (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Jeremy Bicha (jbicha) on 2018-02-15
no longer affects: gnome-shell (Ubuntu)
no longer affects: unity-control-center (Ubuntu)
Khurshid Alam (khurshid-alam) wrote :

Jeremy, why u-c-c is not affected any more? If we want to compile u-c-c with lbnma we will still have to port it along other nertwork-manager-* packages.

Jeremy Bicha (jbicha) wrote :

Khurshid, I apologize for changing this bug without adding a comment to explain myself.

This bug has block-proposed set which is the only thing preventing those NM addons to land in bionic. However, it also was preventing unrelated bug fixes to gnome-shell to land in bionic today.

I will be uploading unity-control-center within a few days as part of the gnoem-desktop3 transition so I removed that task temporarily. We could add it back now if you want or we can wait for these transitions to finish first.

But yes, it would be nice if unity-control-center would be updated to not require libnm-glib in time for 18.04.

Khurshid Alam (khurshid-alam) wrote :

Thanks. I will wait for these transitions to finish first.

Jeremy Bicha (jbicha) wrote :

You're welcome to work on this bug before those transitions happen. :)

Jeremy Bicha (jbicha) wrote :

Khurshid, any progress on unity-control-center?

I believe this issue is a problem if we want to try to land gnome-shell 3.27.91 before Feature Freeze next week.

Khurshid Alam (khurshid-alam) wrote :

I haven't finished porting but close. But we don't have time for testing.

Jeremy Bicha (jbicha) on 2018-02-24
Changed in network-manager-pptp (Ubuntu):
status: New → Fix Released
Changed in network-manager-l2tp (Ubuntu):
status: New → Fix Released
Jeremy Bicha (jbicha) wrote :

I had to let network-manager-l2tp and -pp2p migrate because it was blocking NetworkManager 1.10 from bionic.

Maybe we should let the others migrate now too?

Jeremy Bicha (jbicha) wrote :

I am letting all of these migrate now except for openvpn. There are reports in Debian of problems with the new openvpn version so I want someone that uses that to check it first.

Changed in network-manager-iodine (Ubuntu):
status: New → Fix Released
Changed in network-manager-vpnc (Ubuntu):
status: New → Fix Released
Jeremy Bicha (jbicha) wrote :

Actually, it appears like the Debian problem was because some users hadn't updated their gnome-shell yet. Since Ubuntu 18.04 already has the updated gnome-shell, let's let this last plugin in now.

https://bugs.debian.org/888653

Changed in network-manager-openvpn (Ubuntu):
status: New → Fix Released
tags: removed: block-proposed
Jeremy Bicha (jbicha) wrote :

Debian's network-manager-applet 1.8.10-4 has dropped libnm-gtk-dev and libnm-gtk0.

While that's not necessarily going to be done for Ubuntu 18.04 LTS, I believe you still need to update unity-control-center so that the VPN features will work there.

Changed in unity-control-center (Ubuntu):
importance: Undecided → High
status: New → Confirmed
Jeremy Bicha (jbicha) wrote :

And Debian is now dropping libnm-util-dev and libnm-glib-dev.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.