added IPv4 routes/settings are not saved

Bug #439511 reported by C Anthony Risinger on 2009-09-30
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
network-manager-pptp (Ubuntu)
Undecided
Unassigned
Nominated for Karmic by Richard Wall

Bug Description

Binary package hint: network-manager-pptp

this is a fresh Karmic install, x86_64, all updates as of ten minutes ago.

i use a vpn/pptp connection to connect to work. i am trying to add a route to the connection via the interface, but it is not saved after clicking "apply"

REPRODUCE:
1) click nm-applet, VPN Connections > Configure VPN
2) add/edit a connection
3) click IPv4 tab > Routes...
4) add a route, i added:

10.0.0.0 255.0.0.0 10.0.0.1

5) check any boxes, i checked "Use this connection only for resources on its network"
6) click OK, at this point if you click "Routes..." again, it will still be there
7) click Apply
8) go back into IPv4 > Routes... for that connection
9) everything you just set is not there

C Anthony Risinger (extofme) wrote :

forgot to mention i get the same behavior on my x86 laptop

C Anthony Risinger (extofme) wrote :

as a workaround, i am using a script to do this for me. place/name the script:

/etc/NetworkManager/dispatcher.d/99vpnfix

and chmod +x it. dont forget to edit the interfaces/network addresses/host addresses/etc to reflect YOUR actual network!! these values are what i need and don't apply to anyone else!! (i also use an extensive /etc/hosts which is why i can use names like db1/db2/etc....)

>>>START SCRIPT
#!/bin/sh -e
# Fix VPN

IFACE="ppp0"

if [ "x$IFACE" = "x$1" ]; then
 case "$2" in
     vpn-up)
  # reinstate the default gateway
  /sbin/route del default ppp0
  /sbin/route add default gw 192.168.42.1 eth0
  # add the network routes
  /sbin/route add -net 10.0.0.0 netmask 255.0.0.0 dev ppp0
  /sbin/route add -net 192.168.0.0 netmask 255.255.255.0 dev ppp0
  /sbin/route add -net 192.168.7.0 netmask 255.255.255.0 dev ppp0
  # add the host routes
  /sbin/route add -net db1 netmask 255.255.255.255 dev ppp0
  /sbin/route add -net db2 netmask 255.255.255.255 dev ppp0
  /sbin/route add -net serv1 netmask 255.255.255.255 dev ppp0
  ;;
 esac
fi
<<<END SCRIPT

Alexander Sack (asac) on 2009-10-02
Changed in network-manager-pptp (Ubuntu):
status: New → Fix Committed
C Anthony Risinger (extofme) wrote :

has this fix been pushed out? i have latest updates and the bug persists. just making sure.

Mark Schewe (quorr) wrote :

Same problem on my notebook. But I just tried to use the "Use this connection only for resources on its network" option. But the option is not saved. I just updated. But there is not yet any fix? Hope it will be fixed in Karmic final.

Changed in network-manager-pptp (Ubuntu):
status: Fix Committed → Fix Released
status: Fix Released → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package network-manager-pptp - 0.8~a~git.20091005t192316.5f7412f-0ubuntu1

---------------
network-manager-pptp (0.8~a~git.20091005t192316.5f7412f-0ubuntu1) karmic; urgency=low

  * upstream snapshot 2009-10-05 19:23:16 (GMT)
    + 5f7412feb7a2a8adac8086fb3f2ae8475290b9a7
    - fix LP: #439511 added IPv4 routes/settings are not saved
  * rebuild vpn packages after landing of ABI padding in NM
    - update debian/control

 -- Alexander Sack <email address hidden> Tue, 06 Oct 2009 01:19:39 +0200

Changed in network-manager-pptp (Ubuntu):
status: Fix Committed → Fix Released
C Anthony Risinger (extofme) wrote :

this is confirmed working, thank you

idlehands (johannxsxe) wrote :

I changed some settings but still have issues:
 VPN connection 'Cloud' (IP Config Get) reply received.
Jan 22 14:26:20 johannt61p NetworkManager: <info> VPN Gateway: <removed>
Jan 22 14:26:20 johannt61p NetworkManager: <info> Tunnel Device: ppp0
Jan 22 14:26:20 johannt61p NetworkManager: <info> Internal IP4 Address: <removed>
Jan 22 14:26:20 johannt61p NetworkManager: <info> Internal IP4 Prefix: 32
Jan 22 14:26:20 johannt61p NetworkManager: <info> Internal IP4 Point-to-Point Address: 172.16.8.2
Jan 22 14:26:20 johannt61p NetworkManager: <info> Maximum Segment Size (MSS): 0
Jan 22 14:26:20 johannt61p NetworkManager: <info> Internal IP4 DNS: 172.16.0.2
Jan 22 14:26:20 johannt61p NetworkManager: <info> Internal IP4 DNS: 172.16.0.3
Jan 22 14:26:20 johannt61p NetworkManager: <info> DNS Domain: '(none)'
Jan 22 14:26:20 johannt61p NetworkManager: <info> Login Banner:
Jan 22 14:26:20 johannt61p NetworkManager: <info> -----------------------------------------
Jan 22 14:26:20 johannt61p NetworkManager: <info> (null)
Jan 22 14:26:20 johannt61p NetworkManager: <info> -----------------------------------------
Jan 22 14:26:21 johannt61p NetworkManager: <info> VPN connection 'Cloud' (IP Config Get) complete.
Jan 22 14:26:21 johannt61p NetworkManager: <info> Policy set 'Cloud' (ppp0) as default for routing and DNS.
Jan 22 14:26:21 johannt61p NetworkManager: <info> VPN plugin state changed: 4
Jan 22 14:26:21 johannt61p nm-dispatcher.action: Script '/etc/NetworkManager/dispatcher.d/01ifupdown' exited with error status 1.
Jan 22 14:28:17 johannt61p NetworkManager: <info> VPN plugin state changed: 5
Jan 22 14:28:17 johannt61p NetworkManager: <info> VPN plugin state changed: 6
Jan 22 14:28:17 johannt61p NetworkManager: <info> VPN plugin state change reason: 0
Jan 22 14:28:17 johannt61p NetworkManager: <WARN> connection_state_changed(): Could not process the request because no VPN connection was active.
Jan 22 14:28:19 johannt61p NetworkManager: <info> Policy set 'Auto eth0' (eth0) as default for routing and DNS.
Jan 22 14:28:19 johannt61p NetworkManager: SCPlugin-Ifupdown: devices removed (path: /sys/devices/virtual/net/ppp0, iface: ppp0)
Jan 22 14:28:19 johannt61p nm-dispatcher.action: Script '/etc/NetworkManager/dispatcher.d/01ifupdown' exited with error status 1.
Jan 22 14:28:31 johannt61p NetworkManager: <debug> [1264188511.002911] ensure_killed(): waiting for vpn service pid 6668 to exit
Jan 22 14:28:31 johannt61p NetworkManager: <debug> [1264188511.003020] ensure_killed(): vpn service pid 6668 cleaned u

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers