PPTP connection frequently dropped with "short read (-1)"

Bug #294564 reported by ngc2997
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
network-manager (Ubuntu)
Incomplete
Undecided
Unassigned
network-manager-pptp (Ubuntu)
Confirmed
Undecided
Unassigned
ppp (Ubuntu)
Invalid
Undecided
Unassigned

Bug Description

Binary package hint: network-manager-pptp

Package: 0.7~~svn20081015t024626-0ubuntu1

Since Ubuntu 8.10, my office VPN connection (PPTP) frequently drops with:

Nov 6 07:46:18 Antares pptp[6352]: nm-pptp-service-6346 warn[decaps_gre:pptp_gre.c:331]: short read (-1): Message too long

Actually, this happens when generating traffic by e.g. calling web sites that are routed over VPN (office intranet) or when working with an RDP connection over VPN, but _not_ when being connected to my office machine with a VNC session over VPN (strange though).

Is this perhaps related to the missing MTU configuration since NM 0.7? The VPN connection, when established, reads as follows:

[..]
Nov 6 07:41:19 Antares NetworkManager: <info> Maximum Segment Size (MSS): 0
[..]

and

ppp0 Link encap:Punkt-zu-Punkt-Verbindung
          inet Adresse:x.x.x.x P-z-P:x.x.x.x Maske:255.255.255.255
          UP PUNKTZUPUNKT RUNNING NOARP MULTICAST MTU:1452 Metrik:1
          RX packets:1725 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1218 errors:0 dropped:0 overruns:0 carrier:0
          Kollisionen:0 Sendewarteschlangenlänge:3
          RX bytes:522551 (522.5 KB) TX bytes:78426 (78.4 KB)

Revision history for this message
ngc2997 (ngc2997-deactivatedaccount) wrote :

Ok, seems this actually depends on the connection's MTU setting. When manually setting MTU to 1412 (as it was configured in Hardy) with a 'sudo ifconfig ppp0 mtu 1412', the connection is stable. Marking as duplicate of 278309.

Revision history for this message
Alexander Sack (asac) wrote : Re: [Bug 294564] [NEW] PPTP connection frequently dropped with "short read (-1)"

ngc2997 wrote:
> Public bug reported:
>
> Binary package hint: network-manager-pptp
>
> Package: 0.7~~svn20081015t024626-0ubuntu1
>
> Since Ubuntu 8.10, my office VPN connection (PPTP) frequently drops
> with:
>
> Nov 6 07:46:18 Antares pptp[6352]: nm-pptp-service-6346
> warn[decaps_gre:pptp_gre.c:331]: short read (-1): Message too long
>
> Actually, this happens when generating traffic by e.g. calling web sites
> that are routed over VPN (office intranet) or when working with an RDP
> connection over VPN, but _not_ when being connected to my office machine
> with a VNC session over VPN (strange though).
>
> Is this perhaps related to the missing MTU configuration since NM 0.7?
> The VPN connection, when established, reads as follows:
>
i actually think its a ppp issue. we should upgrade ppp to latest
upstream in jaunty and see if that helps you.

 affects ubuntu/network-manager
 status incomplete
 affectes ubuntu/ppp
 status incomplete
 subscribe

Revision history for this message
Alexander Sack (asac) wrote : Re: [Bug 294564] Re: PPTP connection frequently dropped with "short read (-1)"

ngc2997 wrote:
> *** This bug is a duplicate of bug 278309 ***
> https://bugs.launchpad.net/bugs/278309
>
> Ok, seems this actually depends on the connection's MTU setting. When
> manually setting MTU to 1412 (as it was configured in Hardy) with a
> 'sudo ifconfig ppp0 mtu 1412', the connection is stable. Marking as
> duplicate of 278309.
>
>
hmm ... ok

 affects ubuntu/ppp
 status invalid

Changed in network-manager-pptp (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers