[Hardy] network-manager-pptp requires system restart but will not tell you

Bug #200304 reported by Lex Ross on 2008-03-09
44
This bug affects 2 people
Affects Status Importance Assigned to Milestone
network-manager-pptp (Debian)
Fix Released
Unknown
network-manager-pptp (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: network-manager-pptp

My ISP requires VPN connection to get to the Internet. Now with Hardy 8.04 Alpha 6 I have dowloaded and installed network-manager-pptp 0.6.5+svnhead2574-0ubuntu1 package which is not found on Desktop Installation CD.

The package installs just fine, and Network Manager applet allowed me to configure my VPN connection. There is no way to use that connection however until system reboot.

Steps to reproduce.

1. Download networ-manager-pptp package
2. Install the package by double-clicking on it
3. Go to Network Manager applet to observe that there is VPN Connections -> Configure VPN menu available
4. Configure VPN connection as usual
5. Go to Network Manager applet -> VPN Connections menu

Expected result: to see newly configured connection there
Actual result: only Configure VPN menu is available.

6. Go to NM Applet -> VPN Connections -> Configure VPN to verify whether your new connection is there. It is.

6. Log out and log back in
7. Go through steps 5-6 and observe logging out did not help
8. Take it one step further and reboot the machine.
9. Go to step 5 and finally see your connection where it should be.

The point is, either new VPN connection should be available immediately after configuring it, or network-manager-pptp should tell you restart (which less preferred solution of course) immediately upon its installation. Or better yet make it installed during initial system setup. This way it will work as expected right out of the box!

Dana_r (danarea) wrote :

I believe that the setup of network-manager-pptp has always required a restart of the networking services as described here:
http://pptpclient.sourceforge.net/howto-ubuntu.phtml
That said, I haven't yet been able to get my own vpn connection working so far and my syslog is getting flooded with console kit errors (may be do to a restart of dbus?).

It does seem like it would be helpful if the installation for this package automated the restart of the services, or at least indicated that a restart was required (if necessary??)

Robert (robrwo) wrote :

I have the same problem.

It should either be able to restart the networking services, or it should at least advise that they need to be restarted.

Changed in network-manager-pptp:
status: New → Confirmed

I am using 8.04 beta 4 and I have the same problem. I was reading how-to for ages trying work out why the VPN entries I could configure, didn't appear anywhere. Then, after I haven't to reboot, then they appeared and I could use them.

Aaron.

meowijan (meowijan) wrote :

I found this bug as well when I first tried to add a VPN, but I (or a friend of mine really) found a way around it without having to do a full restart. I just went to the terminal and typed

sudo /etc/init.d/dbus restart

and then restarted the network manager with

nm-applet

the only problem is that the network manager only stays open while the terminal that you started it with is running, but i suppose this isn't much of a problem if you only need a stop gap measure until your next restart.

Phill

meowijan (meowijan) wrote :

Just found this out, if you open nm-applet using alt+f2 you dont have to worry about the terminal problem.
I'm new to ubuntu so i'm still learning all these little tricks

Phill

D (daniel-hagen-pedersen) wrote :

Another way around at least to get your configuration showed, is to:
After configuring the VPN
log out,
press Ctrl+Alt+backspace (restarts the X-server etc.)
And log back in.

But I still think it would be preferred with a real solution, because this is things like these details, that stops people like my boss to change to linux.

Kind Regards
Daniel

Bump. Just confirmed this on Hardy AMD64. I've tried logging out of X, CTRL+ALT+BACKSPACE, and /etc/init.d/networking stop/start

Does anyone care, or like most bugs on here nothing happens until 3 releases later?

maff (maff-ailoo) wrote :

I confirm the bug on Hardy i686. However, it affects only the first VPN connection you configure. Additional connections get displayed without the need to restart services or to reboot the system.

The solution posted above with restarting dbus and nm-applet worked for me.

Johan Kröckel (jnkl) wrote :

Like maff, same here.

Matt Underwood (matt-bargolf) wrote :

Don't know if this is related - but I configured a VPN connection today, it _was_ immediately visible and _was_ operational. I returned to my PC later and logged in again (NB - not a reboot + restart) and the entry simply wasn't shown on the VPN Connections menu any more, although was visible if I chose the "Add" option. i.e. no way to initiate the connection.

I discovered that both my partner and daughter had logged on to their accounts whilst I was away from the machine and that my daughter's account was still logged in. I logged that account out and then re-logged in as myself and the entry was then available again on the menu.

Matt Underwood wrote:
> Don't know if this is related - but I configured a VPN connection today,
> it _was_ immediately visible and _was_ operational. I returned to my PC
> later and logged in again (NB - not a reboot + restart) and the entry
> simply wasn't shown on the VPN Connections menu any more, although was
> visible if I chose the "Add" option. i.e. no way to initiate the
> connection.
>
> I discovered that both my partner and daughter had logged on to their
> accounts whilst I was away from the machine and that my daughter's
> account was still logged in. I logged that account out and then re-
> logged in as myself and the entry was then available again on the menu.
>
>
interesting ... did a restart of NM / system help?

Matt Underwood (matt-bargolf) wrote :

Restarting NM hadn't helped (I tried that a couple of times - including making superficial changes to the VPN properties and saving them). I didn't have to restart the system - just log out the other user that was logged in.

Subsequently I have restarted the system and the VPN connection is still correctly visible on the "VPN Connections" menu.

So at the moment it only looks like it was invisible whilst someone else was logged in.

I'll attempt to reproduce the situation.

Alexander Sack (asac) wrote :

If you still see this issue on intrepid, please test the final 0.7 packages in jaunty or the network-manager team ppa (for intrepid): http://launchpad.net/~network-manager/+archive and let us know if its still there.

Changed in network-manager-pptp:
status: Confirmed → Incomplete

I am still seeing this issue in Jaunty. Just installed network-manager-pppd and tried to connect but nothing happened. Had to run /etc/init.d/NetworkManager restart in order to get it to try the connection.

Gabriel M. (gabrielm) wrote :

Well, the bug changed faces (so to speak) in Karmic: after step 5 of the bug description, you can now see the connection, but clicking on it yields no visual feedback on the network manager system tray icon. I tried it a few times, and eventually got a popup notification saying that VPN connection "null" failed (with "missing vpn secrets") .

The workaround is still the same: rebooting - or I suppose restarting the networking services would work. After rebooting, I could connect properly to the VPN.

Changed in network-manager-pptp (Ubuntu):
status: Incomplete → Confirmed

Same as Gabriel M. stated in comment #15.
Here is what I get in daemon.log until reboot:
Nov 29 12:57:19 booxter-laptop NetworkManager: <info> Starting VPN service 'org.freedesktop.NetworkManager.pptp'...
Nov 29 12:57:19 booxter-laptop NetworkManager: <info> VPN service 'org.freedesktop.NetworkManager.pptp' started (org.freedesktop.NetworkManager.pptp), PID 12519
Nov 29 12:57:19 booxter-laptop NetworkManager: <info> VPN service 'org.freedesktop.NetworkManager.pptp' just appeared, activating connections
Nov 29 12:57:19 booxter-laptop NetworkManager: nm-vpn-connection.c.828: NeedSecrets failed: dbus-glib-error-quark Rejected send message, 1 matched rules; type="method_call", sender=":1.6" (uid=0 pid=1200 comm="NetworkManager) interface="org.freedesktop.NetworkManager.VPN.Plugin" member="NeedSecrets" error name="(unset)" requested_reply=0 destination="org.freedesktop.NetworkManager.pptp" (uid=0 pid=12519 comm="/usr/lib/network-manager-pptp/nm-pptp-service))
Nov 29 12:57:19 booxter-laptop NetworkManager: <WARN> connection_state_changed(): Rejected send message, 1 matched rules; type="method_call", sender=":1.6" (uid=0 pid=1200 comm="NetworkManager) interface="org.freedesktop.NetworkManager.VPN.Plugin" member="Disconnect" error name="(unset)" requested_reply=0 destination="org.freedesktop.NetworkManager.pptp" (uid=0 pid=12519 comm="/usr/lib/network-manager-pptp/nm-pptp-service))
Nov 29 12:57:19 booxter-laptop NetworkManager: <info> (wlan0): writing resolv.conf to /sbin/resolvconf
Nov 29 12:57:19 booxter-laptop NetworkManager: <info> Policy set 'Auto booxter' (wlan0) as default for routing and DNS.
Nov 29 12:57:31 booxter-laptop NetworkManager: <debug> [1259492251.000994] ensure_killed(): waiting for vpn service pid 12519 to exit
Nov 29 12:57:31 booxter-laptop NetworkManager: <debug> [1259492251.001174] ensure_killed(): vpn service pid 12519 cleaned up

search for "NeedSecrets failed" in daemon.log I attached. Seems that dbus should be restarted before pptp becomes usable.

Changed in network-manager-pptp (Debian):
status: Unknown → New
Changed in network-manager-pptp (Debian):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.