network-manager-pptp does not change mtu even if specified

Bug #151112 reported by Ironphil on 2007-10-09
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
network-manager-pptp (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: network-manager-pptp

I installed network-manager-pptp and configured a vpn connection. I know I have to change the mtu to 1000 in order to be able to transfer some data. There is box in the vpn setup dialogue to specify the mtu value. But once connected, the connection will quickly hang as soon as I try to transfer some data. If I do a "ifconfig" I see that the mtu value for interface ppp0 is still the original 1416, it has not been changed to 1000 as specified in the configuration dialogue.

This is an old bug of network-manager-pptp and there is a patch to fix it but it seems you either did not implement it or you are still using a version that cannot be fixed for that bug. The maintainer of pptpconfig (which I still have to use) says it is now obsolete because of network-manager-pptp and will not improve it.

So it seem for the future everybody is relying on network-manager-pptp for MS vpn connectivity but without the ability to change the mtu value, it is useless for many people so I think it is a very important bug to fix.

Ironphil (p-plamondon) wrote :

The problem is still there. Will it be fixed in Hardy?

Ironphil (p-plamondon) wrote :

I tried it in the latest Hardy alpha and the problem is still there. I set the mtu to 1000 when I set up the connection and when connected, ifconfig tells me that the mtu is 1416. The connection eventually hangs.

Ironphil (p-plamondon) wrote :

There is patch since 2006 that fixes this known problem see here:
http://bugzilla.gnome.org/show_bug.cgi?id=344967

How come it still does not work properly?

Change the mtu setting, connect and look at the output of ifconfig, you will see the mtu does not change...

Ludovico Cavedon (cavedon) wrote :

I am experiencing the same problem (hardy amd64).
If I specifiy the mtu in the a /etc/ppp/peers/file and use "pon file" to connect to the vpn, mtu is set correctly. But with network-manager, even if "mtu 1300" is specified on the command line of pppd, the setting is not effective.

Ludovico Cavedon (cavedon) wrote :

I checked the code: it has been modified and the fix is no longer included, so the MTU is always set to 1412 for VPN interfaces.
I tried to commenting the code which sets the MTU, so it should leave the value set by pppd.

Changed in network-manager-pptp:
status: New → Confirmed
Ironphil (p-plamondon) wrote :

I found a very simple temporary fix. After connecting, I just issue the command:

sudo ifconfig ppp0 mtu 1000

I can then use my vpn connection without any problem. It does not hang anymore and ifconfig tells me the mtu is really 1000. Hope it will be fixed in Intrepid.

Several people have reported the problem here (Ecole Polytechnique) when connecting to a pptp VPN with either Ubuntu Feisty or Hardy. We probably have a big bad router which messes the MTU negotiation and the MTU must be set explicitly to a value below 1400. Setting the MTU in /etc/ppp/options or through a script in /etc/network/if-up.d does not work either; presumably network manager comes afterwards and forces arbitrarily the MTU to 1412. Thus, each time the VPN connection is established, entering afterwards in a console the following command fixes the problem as suggested by Ironphil.

sudo ifconfig ppp0 mtu 1300

Fortunately, the source package for network-manager in Intrepid alpha (8.10 alpha) appears to be fixed.

Beoran (beoran) wrote :

This bug still is not fixed in 10.04! As a workaround, you have to edit the file /etc/NetworkManager/system-connections/XXX
where XXX is the name for the network and set the MTU there. somehow the GUI is ineffective in changing this file.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.