NetworkManager PPTP VPN does not work; bad pptp plugin

Bug #134547 reported by Alexander Jones on 2007-08-24
22
Affects Status Importance Assigned to Milestone
network-manager-pptp (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: network-manager-pptp

Attempting to use a PPTP VPN connection, I get this:

NetworkManager: <info> VPN Activation (Imperial College VPN) Stage 3 of 4 (Connect) complete, waiting for IP configuration...
/usr/sbin/pppd: /usr/lib/pppd/2.4.4/nm-pptp-service-pppd-plugin.so: cannot open shared object file: No such file or directory
/usr/sbin/pppd: Couldn't load plugin nm-pptp-service-pppd-plugin.so

** (process:9895): WARNING **: <WARNING> pptp_watch_cb (): pptp exited with error code 2

The "network-manager-pptp" package installs "/usr/lib/network-manager-pptp/nm-pptp-service-pppd-plugin.so", so I symlinked it at "/usr/lib/pppd/2.4.4/nm-pptp-service-pppd-plugin.so", and now I get this instead:

NetworkManager: <info> VPN Activation (Imperial College VPN) Stage 3 of 4 (Connect) complete, waiting for IP configuration...
/usr/sbin/pppd: Plugin nm-pptp-service-pppd-plugin.so is for pppd version 2.4.3, this is 2.4.4

** (process:10379): WARNING **: <WARNING> pptp_watch_cb (): pptp exited with error code 2

So it seems that the plugin is built against the an old version of pppd, and it's not installed in the right place anyway.

ProblemType: Bug
Architecture: i386
Date: Fri Aug 24 16:44:10 2007
DistroRelease: Ubuntu 7.10
Package: network-manager 0.6.5-0ubuntu9
PackageArchitecture: i386
SourcePackage: network-manager
Uname: Linux flash 2.6.22-10-generic #1 SMP Wed Aug 22 08:11:52 GMT 2007 i686 GNU/Linux

Alexander Jones (alex-weej) wrote :

yes,

can't establish pptp/vpn connection too since my upgrade feisty>gutsy yesterday.

hope a fix soon....

confirmed

Craig Box (craig.box) wrote :

Fixed by revert to 2574 (now called 0.6.5+svnhead2574-0ubuntu1)

Changed in network-manager-pptp:
status: New → Fix Released
lor (astarventure) wrote :

cannot create pptp connection in kubuntu. network-manager-kde even do not show PPTP as tunnel option and network-manager-pptp is installed

lor (astarventure) wrote :

in kubuntu fix doesnt work. network-manager-kde doenst allow to choose PPTP vpn

Changed in network-manager-pptp:
status: Fix Released → Incomplete
wolfger (wolfger) wrote :

Not seeing why this bug was marked "incomplete". You should only set "incomplete" if:
-you have to ask the reporter questions
-you ask the reporter to provide any necessary information in a comment

I am marking it "confirmed" again, since the above comments indicate it was confirmed in the past.

Changed in network-manager-pptp:
status: Incomplete → Confirmed
cmnorton (octopusgrabbus) wrote :

What is the status of this bug? I am using 10.04 LTS and the problem has persisted over a few releases.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers