Network-manager vpn dialog only shows "import from file"

Bug #1250016 reported by Kaare Baastrup on 2013-11-11
This bug report is a duplicate of:  Bug #1250832: cannot edit VPN preferences via GUI. Edit Remove
110
This bug affects 26 people
Affects Status Importance Assigned to Milestone
NetworkManager
New
Undecided
Unassigned
network-manager-pptp (Ubuntu)
Undecided
Unassigned

Bug Description

When I try to create a vpn profile from gnome 3.10 network settings clicking on + and choose vpn.
The only option i have is to import from file....

so im missing the dialog where you choose openvpn or pptp etc.

the following packages is installed.
ii network-manager 0.9.8.8-0ubuntu1~saucy1 amd64 network management framework (daemon and userspace tools)
ii network-manager-gnome 0.9.8.4-0ubuntu1~saucy1 amd64 network management framework (GNOME frontend)
ii network-manager-openvpn 0.9.8.2-1ubuntu2 amd64 network management framework (OpenVPN plugin core)
ii network-manager-openvpn-gnome 0.9.8.2-1ubuntu2 amd64 network management framework (OpenVPN plugin GNOME GUI)
ii network-manager-pptp 0.9.8.2-1ubuntu2 amd64 network management framework (PPTP plugin core)
ii network-manager-pptp-gnome 0.9.8.2-1ubuntu2 amd64 network management framework (PPTP plugin GNOME GUI)
ii network-manager-vpnc 0.9.8.2-1ubuntu1 amd64 network management framework (VPNC plugin core)
ii network-manager-vpnc-gnome 0.9.8.2-1ubuntu1 amd64 network management framework (VPNC plugin GNOME GUI)

im running ubuntu 13.10 with gnome shell 3.10 from the officel gnome PPA team

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in network-manager-pptp (Ubuntu):
status: New → Confirmed
Richard Ayotte (rich-ayotte) wrote :

In the mean time, you can try using.

$ nm-connection-editor

James (jjadigo) wrote :

same here..

Per Engström (per-10823-n) wrote :

dito, only import from file. My ISP support PPTP.

Thomas Vachon (vachon) wrote :

I see this for all VPN type (openconnect for me). This seems upstream in Network Manager

Srdjan Grubor (sgnn7) on 2014-08-19
affects: network-manager-pptp → network-manager
affects: network-manager → network-manager-applet
affects: network-manager-applet → network-manager
Sashkin (alexanders-pavlov) wrote :

Same here

Nikolaj Hansen (barnabasdk) wrote :

Same here.

hyz (hyz) wrote :

Same here. And thanks to #2, that command works for me.

$ nm-connection-editor

BeachSamurai (beach-samurai) wrote :

I spent 1 week looking for this ....

someone please fix this .....

Bruno Finger (brunofin) wrote :

Thanks for comment #2 too.

As far as I remember, this happens since a very long time.

It affects Linux Mint's Cinnamon as well, as it's based on GTK3.

oriol (oriolpc01) wrote :

Hi,

I solved the problem in Debian-Gnome installing "network-manager-pptp-gnome" paquet. To add openvpn connection in network manager, is needed " network-manager-openvpn-gnome" paquet.

I hope this help you.

Mehran Hatami (mehranhatamie) wrote :

@oriol thank you for your comment, it perfectly worked for me. all I did was:

$ sudo apt-get install network-manager-pptp-gnome

then when opening the new VPN wizard the pptp option showed up.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers