Ubuntu

network-manager-openvpn plugin needs to be updated to 0.9 version

Reported by SoftExpert on 2011-09-12
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
network-manager-openvpn (Ubuntu)
Undecided
Unassigned

Bug Description

Trying to establish a VPN connexion (using x509 and private key file with password) results in following being recorded in syslog:
-------------
Sep 11 09:25:38 abc NetworkManager[1594]: <info> Starting VPN service 'openvpn'...
Sep 11 09:25:38 abc NetworkManager[1594]: <info> VPN service 'openvpn' started (org.freedesktop.NetworkManager.openvpn), PID 5083
Sep 11 09:25:38 abc NetworkManager[1594]: <info> VPN service 'openvpn' appeared; activating connections
Sep 11 09:25:38 abc NetworkManager[1594]: <info> VPN plugin state changed: 1
Sep 11 09:25:38 abc NetworkManager[1594]: <info> VPN plugin state changed: 3
Sep 11 09:25:38 abc NetworkManager[1594]: <info> VPN connection 'XYZ' (Connect) reply received.
Sep 11 09:25:38 abc NetworkManager[1594]: <warn> VPN connection 'XYZ' failed to connect: 'property 'user-name' invalid or not supported'.
Sep 11 09:25:38 abc NetworkManager[1594]: <warn> error disconnecting VPN: Could not process the request because no VPN connection was active.
Sep 11 09:25:38 abc NetworkManager[1594]: <info> Policy set 'Auto eth0' (eth0) as default for IPv4 routing and DNS.
Sep 11 09:25:43 abc NetworkManager[1594]: <info> VPN service 'openvpn' disappeared
------------

According to KDE bug (https://bugs.kde.org/show_bug.cgi?id=274930), a series of corrections have been implemented and should take advantage of NetworkManager version 0.9.
The openvpn plugin version currently available is 0.899 which does not implement "user-name" property handling, hence no OpenVPN connexion can be established.

This is definitely a showstopper; can someone, please, take care of this update?

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in network-manager-openvpn (Ubuntu):
status: New → Confirmed
Benny (benny-malengier) wrote :

I have the same bug, but not for openvpn, but for vpnc.
So this bug affects more than openvpn.

I cannot use Ubuntu 11.10 beta at work due to this bug.
So a high importance for this bug please.

SoftExpert (marian.popescu) wrote :

After further investigation, I found out that in the config file for my OpenVPN connexion (located in /etc/NetworkManager/system-connections) the entry user-name should be username . The old syntax was handled and generated by the previous version of the plugin (I upgraded my system from 10.04 to 11.10 beta).

Benny (benny-malengier) wrote :

This is fixed I believe with latest packages as the system-connections file were updated, this bug can hence be closed

Changed in network-manager-openvpn (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers