[FFE] OpenVPN NM does not support IPv6

Bug #777161 reported by Eimann on 2011-05-04
42
This bug affects 8 people
Affects Status Importance Assigned to Milestone
network-manager-openvpn (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: network-manager-openvpn

When entering an IPv6 gateway address in network-manager-openvpn-gnome UI it is accepted and passed to network-manager-openvpn but it will handle any IPv6 address as a hostname.

nm-openvpn[752]: RESOLVE: Cannot resolve host address: 2001:0db8::1: [HOST_NOT_FOUND] The specified host is unknown.

Eimann (eimann) wrote :

network-manager-openvpn:
  Installed: 0.8.1+git.20100810t173015.1711d04-0ubuntu1
  Candidate: 0.8.1+git.20100810t173015.1711d04-0ubuntu1
  Version table:
 *** 0.8.1+git.20100810t173015.1711d04-0ubuntu1 0
        500 http://nl.archive.ubuntu.com/ubuntu/ maverick/universe i386 Packages
        100 /var/lib/dpkg/status

network-manager-openvpn-gnome:
  Installed: 0.8.1+git.20100810t173015.1711d04-0ubuntu1
  Candidate: 0.8.1+git.20100810t173015.1711d04-0ubuntu1
  Version table:
 *** 0.8.1+git.20100810t173015.1711d04-0ubuntu1 0
        500 http://nl.archive.ubuntu.com/ubuntu/ maverick/universe i386 Packages
        100 /var/lib/dpkg/status

Linux libelle 2.6.35-28-generic-pae #50-Ubuntu SMP Fri Mar 18 20:43:15 UTC 2011 i686 GNU/Linux

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in network-manager-openvpn (Ubuntu):
status: New → Confirmed

In the OpenVPN Editing settings exists only the IPv4 Settings, the IPv6 settings is missing like other connection types (wired, wireless, ecc).

summary: - OpenVPN NM does not support IPv6 gateway address
+ OpenVPN NM does not support IPv6

NM supports IPv6 quite well now, and so does openvpn; applying upstream patch to just enable them to talk together...

I will upload a package patched to enable the openvpn ipv6 bits in NM and transfer config shortly, branch is linked.

Build log for n-m-openvpn

summary: - OpenVPN NM does not support IPv6
+ [FFE] OpenVPN NM does not support IPv6

Given that we will support 14.04 until 2019, I think having proper support for IPv6 in VPN plugins where possible would be a major bonus; the changes are reasonable, relatively small and well-tested.

Stéphane Graber (stgraber) wrote :

FFe accepted, not changing bug state since it's already confirmed... :)

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package network-manager-openvpn - 0.9.8.2-1ubuntu3

---------------
network-manager-openvpn (0.9.8.2-1ubuntu3) trusty; urgency=medium

  * debian/patches/enable_ipv6.patch: allow openvpn to tunnel IPv6.
    (LP: #777161)
 -- Mathieu Trudel-Lapierre <email address hidden> Thu, 06 Mar 2014 11:58:16 -0500

Changed in network-manager-openvpn (Ubuntu):
status: Confirmed → Fix Released

When trying to connect to an ipv6 only (no A address but only AAAA resolution) openvpn server I get :

oct. 20 16:03:29 nfl-pad nm-openvpn[29304]: RESOLVE: Cannot resolve host address: xxx.xxx.xxx: Name or service not known

Dimitri John Ledkov (xnox) wrote :

I'm on xenial, and i'm not sure if this is my server or client issue. The server has both A, and AAAA records. In the np-applet using hostname, or ipv6 address fails to connect from an ipv6 client-side network.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers