Network-manager-openvpn doesn't work in GNOME without -openvpn-gnome

Bug #516854 reported by Jamie Strandboge on 2010-02-04
84
This bug affects 14 people
Affects Status Importance Assigned to Milestone
network-manager-openconnect (Ubuntu)
Undecided
Unassigned
Lucid
Undecided
Unassigned
network-manager-openvpn (Ubuntu)
Medium
Unassigned
Lucid
Medium
Unassigned
network-manager-pptp (Ubuntu)
Medium
Unassigned
Lucid
Medium
Unassigned
network-manager-vpnc (Ubuntu)
Medium
Unassigned
Lucid
Medium
Unassigned

Bug Description

Binary package hint: network-manager-openvpn

After installing network-manager-openvpn and restarting network manager (via a reboot), I am unable to configure a VPN. Eg:

1. Left click on network manager
2. Select VPN Connections/Configure
3. all buttons under the VPN tab (Add, Edit, Delete, Import, Export) are grayed out

ProblemType: Bug
Architecture: i386
Date: Wed Feb 3 17:24:42 2010
DistroRelease: Ubuntu 10.04
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha i386 (20100130)
Package: network-manager-openvpn 0.8~rc1-0ubuntu2
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-12.16-generic
SourcePackage: network-manager-openvpn
Uname: Linux 2.6.32-12-generic i686

Jamie Strandboge (jdstrand) wrote :
Jaromir Obr (jaromir-obr) wrote :

I have same problem with PPTP (network-manager-pptp).
An existing connection I set in past isn't working (bug 508740) and a new connection cannot be created because button "Add" is grayed out.

Used SW:
Ubuntu 10.04 Lucid, amd64
network-manager-pptp: 0.8~rc1-0ubuntu2

Can you try to install network-manager-openvpn-gnome and see if it works?

Jamie Strandboge (jdstrand) wrote :

It works if I install network-manager-openvpn-gnome.

Jaromir Obr (jaromir-obr) wrote :

I can confirm that installation of package "network-manager-pptp-gnome" fixed my problem with PPTP. It seems that plugin and GUI were separated and it caused the problem. Thank you for advice.

brazz (brazz-ardent) wrote :

I have same problem and after installing network-manager-openvpn-gnome (and restart) it works ...

labadimate (labadimate) wrote :

I had the same problem with package network-manager-openvpn.
I could not create new openvpn connection, and when I tried to connect with my previously created openvpn configuration, the gnome GUI answered a message box ("There was a problem launching the authentication dialog for VPN connection type 'org.freedesktop.NetworkManager.openvpn'. Contact your system administrator.").

Installing network-manager-openvpn-gnome and restarting network-manager with "sudo restart network-manager" solved the problem.

Software environment:
Ubuntu 10.04 lucid "Ubuntu lucid (development branch)"
Linux labadim-laptop 2.6.32-15-generic #22-Ubuntu SMP Tue Mar 2 02:23:29 UTC 2010 x86_64 GNU/Linux
network-manager-openvpn 0.8-0ubuntu1 network management framework (OpenVPN plugin)
network-manager-openvpn-gnome 0.8-0ubuntu1 network management framework (OpenVPN plugin, GNOME UI)

Richard Harding (rharding) wrote :

The reported fix of installing the network-manager-openvpn-gnome package is not enabling the vpn control buttons for me on a fully updated lucid install as of today.

Changed in network-manager-openvpn (Ubuntu):
status: New → Confirmed

Updated the description of the bug since it is indeed what's happening.

Richard, since installing network-manager-openvpn-gnome doesn't work for you, could you report a new bug for your problem (preferably using the 'ubuntu-bug' command, if possible), and report the number here?

summary: - [lucid] can't configure VPN
+ [lucid] network-manager-openvpn doesn't work in GNOME without -openvpn-
+ gnome
Changed in network-manager-openvpn (Ubuntu):
importance: Undecided → Medium
Laurent Bigonville (bigon) wrote :

I think that network-manager-openvpn-gnome should depends on network-manager-openvpn too

Changed in network-manager-openvpn (Ubuntu Lucid):
milestone: none → ubuntu-10.04-beta-2
Changed in network-manager-pptp (Ubuntu Lucid):
importance: Undecided → Medium
status: New → Confirmed
James Gregory (jamgregory) wrote :

I've also seen this behaviour with network-manager-vpnc - if network-manager-vpnc-gnome is installed without network-manager-vpnc, then you can't configure a Cisco VPNC connection. Installing both packages fixes this, so the -gnome version should probably be dependent on the main network-manager-vpnc package.

Changed in network-manager-vpnc (Ubuntu Lucid):
status: New → Confirmed
importance: Undecided → Medium
Martin Pitt (pitti) on 2010-04-09
Changed in network-manager-openvpn (Ubuntu Lucid):
milestone: ubuntu-10.04-beta-2 → ubuntu-10.04
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package network-manager-pptp - 0.8-0ubuntu2

---------------
network-manager-pptp (0.8-0ubuntu2) lucid; urgency=low

  * Add Recommends on network-manager-pptp-gnome or network-manager-kde to
    network-manager-pptp, to handle upgrades with the package split (LP: #516854)
    - update debian/control
  * Add Depends on network-manager-pptp to network-manager-pptp-gnome, it's
    useless without the backend. (LP: #534218)
    - update debian/control
 -- Mathieu Trudel <email address hidden> Thu, 25 Mar 2010 09:08:05 -0400

Changed in network-manager-pptp (Ubuntu Lucid):
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package network-manager-openconnect - 0.8-0ubuntu2

---------------
network-manager-openconnect (0.8-0ubuntu2) lucid; urgency=low

  * Recommend network-manager-openconnect-gnome or network-manager-kde for
    network-manager-openconnect, so that some GUI gets installed (LP: #516854)
    - update debian/control
  * Have network-manager-openconnect-gnome depend on its backend as provided
    by network-manager-openconnect (LP: #534218)
    - update debian/control
 -- Mathieu Trudel <email address hidden> Fri, 09 Apr 2010 11:12:51 -0400

Changed in network-manager-openconnect (Ubuntu Lucid):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package network-manager-openvpn - 0.8-0ubuntu2

---------------
network-manager-openvpn (0.8-0ubuntu2) lucid; urgency=low

  * Recommend network-manager-openvpn-gnome or network-manager-kde for
    network-manager-openvpn, so that so UI gets installed (LP: #516854)
    - update debian/control
  * Have network-manager-openvpn-gnome depend on network-manager-openvpn,
    otherwise it's useless (no backend installed) (LP: #534218)
    - update debian/control
 -- Mathieu Trudel <email address hidden> Fri, 09 Apr 2010 11:17:11 -0400

Changed in network-manager-openvpn (Ubuntu Lucid):
status: Confirmed → Fix Released
dwmw2 (dwmw2) wrote :

For network-manager-openconnect, there is no KDE support. Only network-manager-openconnect-gnome is acceptable; network-manager-kde won't work. I believe this may be the case for other types of VPN plugin too, but I'm not sure.

cf. https://bugs.kde.org/show_bug.cgi?id=226028

dwmw2, on the other hand, won't this work for now until there is support provided by network-manager-kde or a network-manager-openconnect-kde package?

papukaija (papukaija) on 2010-08-15
summary: - [lucid] network-manager-openvpn doesn't work in GNOME without -openvpn-
- gnome
+ Network-manager-openvpn doesn't work in GNOME without -openvpn-gnome
C de-Avillez (hggdh2) on 2010-08-24
tags: added: regression-release
removed: regression-potential

Oops, this didn't get closed for -vpnc... Marking Fix Released now. It's also not a regression-release bug, it was fixed during lucid development.

Changed in network-manager-vpnc (Ubuntu):
status: Confirmed → Fix Released
Changed in network-manager-vpnc (Ubuntu Lucid):
status: Confirmed → Fix Released

Had the same bug with Ubuntu Maverick. The depency issue is fixed now but I still had to restart network-manager.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.