NM OpenVPN applet won't store "Local IP address", simple config using static shared key

Bug #355509 reported by davee
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
network-manager-openvpn (Ubuntu)
Undecided
Unassigned

Bug Description

Ubuntu Intrepid. I installed openvpn and network-manager-openvpn

network-manager-openvpn 0.7~~svn20081015t024626-0ubuntu1
openvpn 2.1~rc11-1ubuntu2

I can create a VPN tunnel 'by hand' using appropriate config files and running 'openvpn' on the command line. However, I'm trying to make this work via the Network Manager applet.

When I attempt to configure a VPN, any values I insert in the "Local IP Address" field are never saved (i.e. when I go back to edit the config, the value I put there previously has disappeared). This does not affect the other settings in the config. I note that one is only presented with a "Local IP address" field when using a Static Key configuration.

This means that I cannot make OpenVPN work via Network Manager. I cannot determine whether the problem is that the IP address I give is being ignored and simply not saved, or whether it is considered invalid for some reason.

Revision history for this message
Feddar (ubuntu-bugs-biazzi) wrote :

Same problem. This is my log, if it can help. thanks

May 4 21:11:32 NetworkManager: <info> Starting VPN service 'org.freedesktop.NetworkManager.openvpn'...
May 4 21:11:32 NetworkManager: <info> VPN service 'org.freedesktop.NetworkManager.openvpn' started (org.freedesktop.NetworkManager.openvpn), PID 8279
May 4 21:11:32 NetworkManager: <info> VPN service 'org.freedesktop.NetworkManager.openvpn' just appeared, activating connections
May 4 21:11:32 NetworkManager: <info> VPN plugin state changed: 1
May 4 21:11:32 NetworkManager: <info> VPN plugin state changed: 3
May 4 21:11:32 NetworkManager: <info> VPN connection 'myvpn' (Connect) reply received.
May 4 21:11:32 NetworkManager: <WARN> nm_vpn_connection_connect_cb(): VPN connection 'myvpn' failed to connect: 'Missing required local IP address for static key mode.'.
May 4 21:11:32 NetworkManager: <info> Policy set 'Ethernet' (eth0) as default for routing and DNS.
May 4 21:11:44 NetworkManager: <debug> [1241464304.190249] ensure_killed(): waiting for vpn service pid 8279 to exit
May 4 21:11:44 NetworkManager: <debug> [1241464304.190392] ensure_killed(): vpn service pid 8279 cleaned up

Revision history for this message
davee (davee-sungate) wrote :

> May 4 21:11:32 NetworkManager: <WARN> nm_vpn_connection_connect_cb(): VPN connection 'myvpn' failed to connect:
> 'Missing required local IP address for static key mode.'.

That's the pertinent line. The GUI for managing the VPN config fails to store the local IP address; this error is correctly diagnosed when one attempts to start the VPN.

Revision history for this message
Christian Funder Sommerlund (zero3) wrote :

This works for me in network-manager-openvpn 0.7.1~rc4.1.20090323+bzr27-0ubuntu2 in 9.04, so it has probably been fixed since.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers