Impossible to deselect "Use additional TLS authentication"

Bug #280429 reported by Gabriel Bauman on 2008-10-08
2
Affects Status Importance Assigned to Milestone
network-manager-openvpn (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: network-manager-openvpn

If I edit an OpenVPN connection, click "Advanced", select the "Certificates (TLS)" tab, uncheck the previously checked "Use additional TLS authentication" option, and select OK -> OK -> Ok... My change is not saved.

Visiting the "Certificates (TLS)" section again shows that the "Use additional TLS authentication" is checked again, despite apparently having been allowed to disable it.

Description: Ubuntu intrepid (development branch)
Release: 8.10

network-manager-openvpn:
  Installed: 0.7~~svn20080928t225540-0ubuntu1
  Candidate: 0.7~~svn20080928t225540-0ubuntu1
  Version table:
 *** 0.7~~svn20080928t225540-0ubuntu1 0
        500 http://archive.ubuntu.com intrepid/universe Packages
        100 /var/lib/dpkg/status

Thierry Carrez (ttx) wrote :

Confirmed with latest 20081008t224042
Workaround is to remove/recreate configuration.

Changed in network-manager-openvpn:
importance: Undecided → Medium
status: New → Confirmed
der_vegi (m-may) wrote :

Maybe this is related to bug 282752 ? Because since some version of n-m-openvpn, you cannot configure TLS auth in the GUI any more, deselection maybe does not work either? This was fixed upstream "in NM svn r4189" (so says Fedora bugzilla).

Gabriel Bauman (gabrielbauman) wrote :

I see we have a fix on a branch. Has it been packaged and released?

der_vegi (m-may) wrote :

If this is indeed related to bug 282752, it was fixed upstream two days after the current snapshot of network-manager-openvpn in Ubuntu (0.7~~svn20081015t024626-0ubuntu1).

der_vegi (m-may) wrote :

I wonder why it hasn't been packaged, yet. In the release of network-manager (0.7~~svn20081018t105859-0ubuntu1) it says "Changes in upstream snapshot that don't affect directly produced binary packages: [...] + (bzr3646) NA/openvpn: The "Certificates (TLS)" tab should also be present for NM_OPENVPN_CONTYPE_PASSWORD (LP: #280429)".

But network-manager-openvpn has not been updated.

Mathew Hodson (mhodson) wrote :

This should have been fixed with the final release of 0.7.0

Changed in network-manager-openvpn (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers