VPN Stopped working after installing Ubuntu patch

Bug #1899410 reported by Joe
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
network-manager-openvpn (Ubuntu)
Undecided
Unassigned

Bug Description

My Surfshark VPN stopped working after installing Ubuntu software updates.
I have Ubuntu 20.04.1 LTS I received a pop-up on around Sept. 24 or 25 to install updates and did so accordingly.

Since installing that set of updates I cannot connect to a VPN on this computer.

Using Surfshark. I enter ...

sudo surfshark-vpn

I get ...

Checking for connection status...
Not connected to Surfshark VPN
Was unable to connect to VPN server. Please try another server.

I also have Protonmail VPN as a backup. When I try that with ...

sudo protonvpn connect

I get ...

Connecting to JP-FREE#2 via UDP...
[!] There was an error connecting to the ProtonVPN API.
[!] Please make sure your connection is working properly!

I have another Ubuntu computer on the same home network. It is running 18.04 LTS. Both Surfshark and Proton VPN work on that laptop. I also have a work computer running Win7 and the Big-IP Edge VPN. That also works without issues. Therefore, I know it's not my Router or ISP.

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-docs (Ubuntu):
status: New → Confirmed
Revision history for this message
Tiziana (tialo) wrote :

Same here, Ubuntu 20.04.
It worked previously, now it gives me the same message as above.
Not sure when this happened exactly, but it should be around the same time (end of September).

Revision history for this message
Tiziana (tialo) wrote :

It is a problem of conflicting packages I think.
I got it working by uninstalling network-manager-openvpn, network-manager-openvpn-gnome, and openvpn-systemd-resolved. This also gets rid of OpenVPN and Surfshark itself, so the two packages need to be reinstalled afterwards.

Revision history for this message
Gunnar Hjalmarsson (gunnarhj) wrote :

Please note that ubuntu-docs is a package for the Desktop user documentation, and thus unrelated to the problem. Changed this report to a generic bug for now, since it lacks information about which package is the culprit.

I see that you also posted at <https://askubuntu.com/q/1278241>.

affects: ubuntu-docs (Ubuntu) → ubuntu
Revision history for this message
Gunnar Hjalmarsson (gunnarhj) wrote :

Hmm.. While I wrote that comment, Tiziana provided valuable input.

affects: ubuntu → network-manager-openvpn (Ubuntu)
Revision history for this message
Tiziana (tialo) wrote :

Someone told me that the output from journalctl would be useful.
I reduced the ginormous output to the stuff from 19 Dec. When it starts (Dec 19 19:37:20), things were still broken. Non sure at what time I got it working, but at some point I did the steps listed in my second post and it was working again.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers