Can't confirm country selection with Enter when navigating the list

Bug #981472 reported by Kangarooo Jānis on 2012-04-14
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Network Manager Applet
Fix Released
Medium
network-manager-applet (Ubuntu)
Low
T. Porangaba

Bug Description

Make new mobile connection and on asking about country just pressing Letters goes to country starting that letter.
So then i press keys down/up to select correct one and then ENTER but its not reacting to that.

Instead it should react to Enter since country names arent 2 lined so therefore no need to leave Enter at this wizzard stage to work as Enter

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: network-manager-gnome 0.8-0ubuntu3
ProcVersionSignature: Ubuntu 2.6.32-40.87-generic 2.6.32.57+drm33.23
Uname: Linux 2.6.32-40-generic i686
Architecture: i386
CRDA: Error: [Errno 2] No such file or directory
Date: Sat Apr 14 12:31:11 2012
IfupdownConfig:
 auto lo
 iface lo inet loopback
InstallationMedia: Ubuntu-Netbook 10.04 "Lucid Lynx" - Release i386 (20100429.4)
IpRoute:
 10.64.64.64 dev ppp0 proto kernel scope link src 10.37.148.248
 169.254.0.0/16 dev ppp0 scope link metric 1000
 default via 10.64.64.64 dev ppp0 proto static
Keyfiles: Error: [Errno 2] No such file or directory
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
RfKill:
 0: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: no
SourcePackage: network-manager-applet

Related branches

Kangarooo Jānis (kangarooo) wrote :
summary: - Searching by letters country makes Enter not react
+ In mobile newtwork Wizzard Searching country by letters makes Enter not
+ react

Simple enough to fix, looks like Enter may have not been set as a way to confirm selections, fully reproducible in Precise.

Changed in network-manager-applet (Ubuntu):
status: New → Triaged
importance: Undecided → Low
tags: added: bitesize
summary: - In mobile newtwork Wizzard Searching country by letters makes Enter not
- react
+ Can't confirm country selection with Enter when navigating the list
Changed in network-manager-applet (Ubuntu):
assignee: nobody → T. Porangaba (tiagoporangaba)
status: Triaged → In Progress
Changed in network-manager-applet (Ubuntu):
status: In Progress → Fix Committed
Martin Pitt (pitti) wrote :

This sounds like https://bugzilla.gnome.org/show_bug.cgi?id=663774 . Can you please forward your fix there, so that it can be reviewed and included upstream? Thanks!

Changed in network-manager-applet:
importance: Unknown → Medium
status: Unknown → New
Changed in network-manager-applet:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.