nm-applet doesn't update quickly IconAccessibleDesc

Bug #944766 reported by Quentin Horlay on 2012-03-02
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
network-manager-applet (Ubuntu)
Undecided
Mathieu Trudel-Lapierre

Bug Description

Cairo-Dock uses a plugin to display the information of indicator-application. And we can display the value of IconAccessDesc, but we must wait five minutes until this value get update. The value is lock at "getting ip address" even if the connection is complete.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: network-manager-gnome 0.9.1.90-0ubuntu6
ProcVersionSignature: Ubuntu 3.0.0-16.28-generic 3.0.17
Uname: Linux 3.0.0-16-generic i686
ApportVersion: 1.23-0ubuntu4
Architecture: i386
CRDA: Error: [Errno 2] Aucun fichier ou dossier de ce type
Date: Fri Mar 2 13:33:28 2012
Gconf:

IfupdownConfig:
 auto lo
 iface lo inet loopback
InstallationMedia: Ubuntu 11.10 "Oneiric" - Build i386 LIVE Binary 20111013-11:02
IpRoute:
 default via 192.168.1.1 dev wlan0 proto static
 169.254.0.0/16 dev wlan0 scope link metric 1000
 192.168.1.0/24 dev wlan0 proto kernel scope link src 192.168.1.196 metric 2
Keyfiles: Error: [Errno 2] Aucun fichier ou dossier de ce type
NetworkManager.state:
 [main]
 NetworkingEnabled=true
 WirelessEnabled=true
 WWANEnabled=true
 WimaxEnabled=true
ProcEnviron:
 PATH=(custom, no user)
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
SourcePackage: network-manager-applet
UpgradeStatus: No upgrade log present (probably fresh install)

Quentin Horlay (quintus89) wrote :
Matthieu Baerts (matttbe) wrote :

I'm using Ubuntu Precise and I confirm this bug.

Cairo-Dock uses informations received through DBus (on the bus: com.canonical.indicator.application).
(I checked with d-feet that these informations are the same)

But I also have other problem:
 * if I switch off my wireless card, IconAccessibleDesc propertie is still: "Wireless network connection '...' active: '...' (...%)"
 * if I click on the disconnect entry from this DbusMenu: IconAccessibleDesc propertie is now "Wireless network connection '...' active" (but only after a few time)

I think that this description is only updated when the icon is modified.

Thank you

Changed in network-manager-applet (Ubuntu):
status: New → Confirmed

Thank you for taking the time to report this bug and helping to make Ubuntu better. The issue that you reported is one that should be reproducible with the live environment of the Desktop CD of the development release - Precise Pangolin. It would help us greatly if you could test with it so we can work on getting it fixed in the next release of Ubuntu. You can find out more about the development release at http://www.ubuntu.com/testing/ . Thanks again and we appreciate your help.

Changed in network-manager-applet (Ubuntu):
status: Confirmed → Incomplete
Matthieu Baerts (matttbe) wrote :

Hello Mathieu,

Yes I'm using Ubuntu Precise and I confirm that the tooltip (the value of IconAccessibleDesc's propertie) is only updated when the icon is modified (and then this value can be wrong)

Changed in network-manager-applet (Ubuntu):
status: Incomplete → Confirmed

Well, that's very fine but of course it's only updated when the icon is modified, since the icon should always show the current state.

Can you confirm the issue is only reproduceable with the Disconnect functions?

Changed in network-manager-applet (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Mathieu Trudel-Lapierre (mathieu-tl)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package network-manager-applet - 0.9.4.1-0ubuntu2

---------------
network-manager-applet (0.9.4.1-0ubuntu2) precise; urgency=low

  * debian/patches/nm-applet-use-indicator.patch: move the tooltip/accessible
    description update to after the tooltip string gets updated; so that we get
    the right string rather than what was just changed. (LP: #944766)
 -- Mathieu Trudel-Lapierre <email address hidden> Tue, 03 Apr 2012 12:24:24 -0400

Changed in network-manager-applet (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers